Jump to content

MWB not opening on desktop


Recommended Posts

Hi everyone! 

I'm having a bit of an issue right now, being that MalwareBytes is active as a program. The processes are running. However when I try to open the application on my desktop, it just wont. So now I'm unable to use it, which is quite a bummer. I've tried reinstalling and using MB_Clean (so two clean installs) and I also just ran MB_Check. The programs gave the following logs.

I hope someone's able to help me out, 'cause I'd like to be able to scan my pc once again as it's already been a while. 

Thanks!
Bart

mb-clean-results.txt

mb-check-results.txt

Link to post
Share on other sites

  • Staff

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes 3 Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Download Malwarebytes Support Tool
  • Once the file is downloaded, open your Downloads folder/location of the downloaded file
  • Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  • Place a checkmark next to Accept License Agreement and click Next
  • You will be presented with a page stating, "Welcome to the Malwarebytes Support Tool!"
  • Click the Advanced Options link
    welcome mbst.png
  • Click the Gather Logs button
    gatherlogs.png
  • A progress bar will appear and the program will proceed to gather troubleshooting information from your computer
  • Upon completion, click OK
  • A file named mbst-grab-results.zip will be saved to your Desktop
  • Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:
     notify me.jpeg  

    Click "Reveal Hidden Contents" below for details on how to attach a file:
    Spoiler

    To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

    _mb_attach.jpg.a0465aaafd6cae688aa38ab16

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites

Hello and Welcome

Using the same Malwarebytes Support Tool lets get a clean install

Lets try this new tool called Malwarebytes Support Tool to get a clean install of Malwarebytes.

  1. Please download our new Support Tool from RIGHT HERE
  2. Double click the downloaded file and click Yes if prompted for the UAC warning
  3. Place a check mark to Accept License Agreement and click Next
  4. Click on Advanced Options (below Get Started box)
  5. Click on "Clean" box
  6. Click on "Yes" on the warning about removing Malwarebytes (this will start the cleanup process and there is no need to deactivate)
  7. Once complete click "OK" to reboot the computer
  8. After Reboot click on "Yes" to reinstall the latest version of Malwarebytes
  9. Malwarebytes should now be installed and activated if you use the Premium Version
  10. You can now exit the Malwarebytes Support Tool

If you do not get prompted to reinstall Malwarebytes then download the latest version from the link below.

Download the Latest MB3 v3.5.1.2522 CU 1.0.374 from ->>RIGHT HERE<<-

Link to post
Share on other sites

Sorry to hear about your issues @BartiriX. Can you please perform the following to get us some more information about what's going on?

  1. Download and extract the following two files
    1. CaptureTrace - Logman.zip
    2. procdump.zip
  2. Reboot your computer
  3. Once back inside windows, find capture.bat from the first zip file
    1. Right click capture.bat and choose Run as Administrator
    2. A black window should come up which tells you to reproduce your issue
    3. Double click the Malwarebytes icon on your desktop, and wait for 30 seconds
    4. Click on the black window from step 2, and press Enter
    5. Zip up any .etl files that are in the same folder as the capture.bat, as well as processes-before.txt and processes-after.txt
      1. If you extracted these to a folder, just zip up the whole folder
  4. After doing the above, find 5 - mbamservice_memory.bat from the procdump.zip file
    1. Right click 5 - mbamservice_memory.bat and choose Run as Administrator
    2. A black window should come up with some text, and then disappear after a few seconds
    3. Once it 's done, zip up the .dmp file next to the batch file
  5. Upload both zip files from steps 3.5 and 4.3 above in your reply
Edited by dcollins
Link to post
Share on other sites

  • 2 weeks later...

I tried a few more things with my brother to see if we could get MWB to work somehow.

Installing it from a USB didnt make it work.
Starting my laptop in Safe Mode With Networking did make it work.

I dont know if this is of any use to you guys, but I figured I'd mention it :)

Link to post
Share on other sites

That's very helpful.  It means that something loading in normal mode is preventing Malwarebytes from starting, and it isn't present in Safe Mode.  That means it could be a driver conflicting with Malwarebytes, some other program that loads at startup in normal more, or an infection that doesn't load in Safe Mode.

The logs and other info you provided will hopefully reveal the exact cause, but every clue helps to narrow it down.

In the meantime, since you can get it running in Safe Mode with Networking, I'd suggest going ahead and opening Malwarebytes and navigating to Settings>Protection and below Scan Options, enable the Scan for rootkits option then perform a Threat Scan to have Malwarebytes check for the presence of any rootkits as that would be one possible cause (a malicious rootkit driver blocking Malwarebytes from running in normal mode).  It's one more item to check off the list.

Link to post
Share on other sites

OK, let's try something else.  It's possible this issue is related to permissions since you are able to launch it from the hidden admin account in Safe Mode so please do the following:

  1. Uninstall Malwarebytes (if necessary, perform this step from Safe Mode if you are unable to do so from booting normally)
  2. Log into Windows normally and create a new administrator user account.  Instructions on how to do so may be found here
  3. Restart your computer and log into the new administrative user account you just created
  4. Download and install a fresh copy of Malwarebytes from the new administrative user account you just created.  The latest build may be downloaded from here
  5. Once that's done, assuming it installed OK, try launching it to see if it works from the new user account
  6. If it does, go ahead and restart your PC again and log back into your normal user account and see if it functions there now as well

Please let us know how it goes.

Thanks

Link to post
Share on other sites

Yes, that's exactly what I expected to happen.  Somehow permissions got corrupted on your original user account causing this issue.

You may attempt a fix for it if you wish, or you can migrate your files and settings to the new user account.

Below are instructions for an automated repair that should correct the issue.

Tweaking.com Windows Repair All-in-One

  • Download Tweaking.com Windows Repair from here and install it or if you would prefer, you may instead download and extract the portable version from here
  • Once installed or extracted, launch Repair_Windows.exe
  • Click on the Repairs - Main tab
  • Click on the Open Repairs button
  • Once it displays the list of repairs, click the checkbox next to All Repairs so that everything listed is UNCHECKED
  • Now, click the checkbox next to Reset Registry Permissions and Reset File Permissions so that they are checked
  • Click on the Start Repairs button at the bottom
  • Once it completes, allow it to restart your system

Link to post
Share on other sites

Excellent, I'm glad to hear that this issue is finally resolved.  You may of course now delete the additional user account you created if you don't have any reason to keep it, assuming you haven't already (or you can keep it around as a secondary backup account if you wish just in case anything goes wrong with your current account in the future and you'd like to have an alternative to Safe Mode for attempting repairs which can at times come in quite handy, especially since most modern threats install on a local per-user account basis to avoid being blocked by User Account Control).

If there is anything else we might assist you with in the future, please don't hesitate to let us know.

Thanks

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.