Jump to content
lljwagg

Real Time Protection Won't Turn On

Recommended Posts

I am absolutely fed up with this issue. I keep going round in circles with Malwarebytes asking me to reboot to get real time protection started.  It just will not start no matter what I do. I am on Windows 7. What am I paying for? This problem is OVER A YEAR OLD!!! Right now I've given up and am running it without real time protection. Just not good enough is it really?

Share this post


Link to post
Share on other sites
On 5/14/2018 at 10:27 AM, lljwagg said:

I am absolutely fed up with this issue. I keep going round in circles with Malwarebytes asking me to reboot to get real time protection started.  It just will not start no matter what I do. I am on Windows 7. What am I paying for? This problem is OVER A YEAR OLD!!! Right now I've given up and am running it without real time protection. Just not good enough is it really?

Do you have another security program installed that might be conflicting? Have you tried version 3.51 yet? All I can think of right now. :)

Edited by plb4333

Share this post


Link to post
Share on other sites

Which component of real-time protection is failing?  If it is Web Protection then please try the following to see if it resolves it (without requiring a reboot):

Right-click on the Malwarebytes tray icon and select Quit Malwarebytes and click Yes to the User Account Control prompt
Next, click on START and type cmd in the search box and once you see cmd.exe listed at the top, right-click on it and select Run as administrator.  This should open up a command prompt.
In the command prompt, enter the following text and press Enter:

SC DELETE MBAMWebProtection

Once that is done, open Malwarebytes again and Web Protection should work.  Also check to make sure that all of the other protection components are turned on as they may have been disabled when you deleted that item, but you should be able to turn all of them back on and they should all be functioning normally after that.  Please let us know if it does not resolve the issue or if there are any additional problems.

Share this post


Link to post
Share on other sites

If the above does not work, then the team would need some logs to see what is going on.

Lets try this new tool called Malwarebytes Support Tool to gather some logs.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Welcome to the Malwarebytes Support Tool!"
  6. Click the Advanced Options link
  7. The Advanced Options page has two options, please choose one:
    • Gather Logs: Collects troubleshooting information from the computer using Check and Grab functionality. As part of this process, Farbar Recovery Scan Tool (FRST) is also run to perform a complete diagnosis of the computer. The troubleshooting information is saved to a file on the Desktop named mbst-grab-results.zip. This file can be added as an email attachment or uploaded to a forum post and will assist your Malwarebytes Support agent with troubleshooting the issue currently being experienced.
    • Clean: Performs an automated uninstallation of all Malwarebytes products currently installed to the computer and prompts to install the latest version of Malwarebytes for Windows afterwards. This process may require a reboot of the computer, which must be manually consented to.
  8. To provide logs for review click the Gather Logs button
  9. A progress bar will appear and the program will proceed to gather troubleshooting information from your computer
  10. Upon completion, click OK
  11. A file named mbst-grab-results.zip will be saved to your Desktop
  12. Please attach the file in your next reply.

Share this post


Link to post
Share on other sites

OK, I'm going to download the Support tool now.

I have a slightly different issue now: the system tray icon has the red exclamation mark showing and says Real Time Protection is off, but when I open the programme it says I am fully protected and all protection tabs show as on. So which is it??? I don't know if I can even trust this programme to work properly anymore, I'd like to recommend it to others - but how can I? It's so unreliable now.

I'll post a log from the support tool shortly.

Share this post


Link to post
Share on other sites

Please try the following to see if it corrects the issues you're experiencing:

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced Options on the main page (not Get Started)
  3. Click the Clean button, and allow it to restart your system and then reinstall Malwarebytes, either by allowing the tool to do so when it offers to on restart, or by downloading and installing the latest version from here

Please let us know how it goes.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.