Jump to content
Ant Dude

Keep losing my Windows Explorer's right click for context menu scanning...

Recommended Posts

Every time I do an internal MBAM3 upgrade, I lose it. Even unchecking and rechecking its settings doesn't always work. I have to uninstall and reinstall in my updateed 64-bit W7 HPE SP1 PC to make it come back fully. Why? It's so annoying. :(

Thank you in advance.  :)

Edited by Ant Dude

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes 3 Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Download Malwarebytes Support Tool
  • Once the file is downloaded, open your Downloads folder/location of the downloaded file
  • Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  • Place a checkmark next to Accept License Agreement and click Next
  • You will be presented with a page stating, "Welcome to the Malwarebytes Support Tool!"
  • Click the Advanced Options link
    welcome mbst.png
  • Click the Gather Logs button
    gatherlogs.png
  • A progress bar will appear and the program will proceed to gather troubleshooting information from your computer
  • Upon completion, click OK
  • A file named mbst-grab-results.zip will be saved to your Desktop
  • Please attach the file in your next reply. Click "Reveal Hidden Contents" below for details on how to attach a file:
    Spoiler

    To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

    _mb_attach.jpg.a0465aaafd6cae688aa38ab16

     

    After posting your new post, make sure you click the Follow button near the top right of this page, and select the option "An email when new content is posted Change how the notification is sent" so that you're alerted by email when someone has replied to your post.

    _mb_follow.jpg.7868cc281f66ac22e919c2c48

    _mb_follow_options.jpg.dcb79fc10aa35beb0

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Share this post


Link to post
Share on other sites

Greetings,

This could be due to a known issue where the context menu entry is tied to the tray notifications setting (even though it should not be) so that if you have notifications disabled in Malwarebytes, it turns off the right-click context menu for scanning items with Malwarebytes.  To fix it, open Malwarebytes and navigate to Settings>Application and beneath Notifications set the option Show Malwarebytes notifications in the Windows System Tray to On, then toggle the setting for the context menu shell extension off and then on again, reboot, and it should now be working.

Once that's complete you may disable notifications again, however the problem may return when you install the next build/release of Malwarebytes if you have notifications disabled when you do (unless they have fixed the issue by then).

Let us know if that corrected the problem or not, and if not, then please follow the above instructions in the automated reply beneath where it says technical issues and post back with the requested logs attached.

Thanks

Share this post


Link to post
Share on other sites
1 minute ago, dcollins said:

The issue mentioned by @exile360 above is also resolved in 3.5.1

I hope so! MalwareBytes took too long to fix it. :(

Share this post


Link to post
Share on other sites
On 5/12/2018 at 1:19 PM, Ant Dude said:

I hope so! MalwareBytes took too long to fix it. :(

So, I just got its new 3.6.1.2711 via MBAM (free). Once again, I lost my Windows Explorer's right click MBAM option. I did the instructions in

, but still had the missing MBAM option in my Windows Explorer's right click after the reboot. It did come back after toggling off and on again with "Windows Context Menus" option without rebooting. I don't know why this is so complex to fix for so long!

Share this post


Link to post
Share on other sites

Honestly it's really just because of the nature of shell extensions.  They're trying to load a DLL into a process (explorer.exe) that's already running which depends on the registry as well as explorer.exe itself.  It is definitely annoying and I have seen other programs handle it better and believe me, this is something the Developers spent a long time working on to try to get it right, and while I don't know the exact technical reasons as to why it always proves so difficult to make it behave consistently, but there is a good reason because I know they tried really hard to fix it to make it work as expected consistently.  Unfortunately, while they did at least somewhat improve it, it still has issues sometimes/on some systems.  I'm not convinced that it is impossible to fix, however it will require additional research and effort on the part of the Devs to work it out because they have tried several approaches and have yet to find one that consistently works as desired.  I also think that if they forced a reboot following an upgrade install it would be much easier to make it work consistently, however many users complain when the software prompts them to restart just to replace the shell extension DLL (they hate having to reboot in general, honestly, which was the big reason Malwarebytes made the decision to work out stopping/replacing/restarting everything, including drivers and services, without requiring a reboot even though it is more often the case that other software will prompt for a reboot when such items are replaced/updated).

I will report to the team that users are still seeing this behavior though, as it may motivate them to give it another look to see if anything can be done to improve the process.

Share this post


Link to post
Share on other sites

I notice when a new update is out & after installed, the file MBAMShlExt will be automatically removed from the CCleaner which caused the context menu disappeared for a reason. 

(..\Malwarebytes\Anti-Malware\mbshlext.dll)

Share this post


Link to post
Share on other sites

Yes, I was just going to say it must be something on your system either blocking or removing. I do not use any type of "cleaners" like CCleaner, etc. and most of us don't use. That or similar programs could be the cause. I have several computers of my own as well as friends and family computers and some work computers that run it and none of them experience this issue.

Many computers, and many updates, both over the top as well as clean, fresh installs and I've not run into this issue myself. Yes, we do see the issue every once in a while, but my take is that it's something in the object verb namespace of the computer causing it.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.