Jump to content

Web and Malware protection can't be turned on after reboot


Recommended Posts

Web protection and Malware protection can't be turned on after reboot on Windows 8.1 Pro 64-bit, MalwareBytes 3.4.5.2467.  When I reboot one of my systems, it boots up with Web protection and Malware protection turned off.  When I try to turn them on from settings , in the MalwareBytes app UI, or from the service tray, they won't turn on.  I tried to change them by restoring defaults but that seems to make no changes.  I have rebooted this system a couple of times.  I also tried updating the MalwareBytes app itself but I already have the latest. Also, before I rebooted, these were turned on and working. What can be done to fix this?  Do I need to uninstall/reinstall or is there a shorter/safer way to fix this issue? 

Cant turn web protection on in v3.4.5.2467.jpg

Edited by sshier
Link to post
Share on other sites

  • Staff

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes 3 Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Download Malwarebytes Support Tool
  • Once the file is downloaded, open your Downloads folder/location of the downloaded file
  • Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  • Place a checkmark next to Accept License Agreement and click Next
  • You will be presented with a page stating, "Welcome to the Malwarebytes Support Tool!"
  • Click the Advanced Options link
    welcome mbst.png
  • Click the Gather Logs button
    gatherlogs.png
  • A progress bar will appear and the program will proceed to gather troubleshooting information from your computer
  • Upon completion, click OK
  • A file named mbst-grab-results.zip will be saved to your Desktop
  • Please attach the file in your next reply. Click "Reveal Hidden Contents" below for details on how to attach a file:
    Spoiler

    To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

    _mb_attach.jpg.a0465aaafd6cae688aa38ab16

     

    After posting your new post, make sure you click the Follow button near the top right of this page, and select the option "An email when new content is posted Change how the notification is sent" so that you're alerted by email when someone has replied to your post.

    _mb_follow.jpg.7868cc281f66ac22e919c2c48

    _mb_follow_options.jpg.dcb79fc10aa35beb0

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites

Greetings and welcome,

I'm sorry for the issues you're experiencing with Malwarebytes.  Hopefully we'll be able to get it back up and running normally again for you with all protection enabled promptly.

To start with, please do the following:

Right-click on the Malwarebytes tray icon and select Quit Malwarebytes and click Yes to the User Account Control prompt
Next, click on START and type cmd in the search box and once you see cmd.exe listed at the top, right-click on it and select Run as administrator.  This should open up a command prompt.
In the command prompt, enter the following lines one at a time and press Enter after each one:

SC DELETE MBAMWebProtection
SC DELETE MBAMProtection

Once that is done, open Malwarebytes again and Web Protection and Malware Protection should work.  Also check to make sure that all of the other protection components are turned on as they may have been disabled when you deleted those items, but you should be able to turn all of them back on and they should all be functioning normally after that.  Please let us know if it does not resolve the issue or if there are any additional problems.

Link to post
Share on other sites

When I run these 2 commands from an admin prompt, I get the following response for both commands:

   [SC] OpenService FAILED 1060:

   The specified service does not exist as an installed service.

 

Next I will uninstall/reinstall unless you have another option.

 

Steve

Link to post
Share on other sites

I uninstalled, rebooted and reinstalled (v 3.4.5.2467) and entered my lifetime license info and it seemed fine.  I then rebooted and I want back to the original problem described above.  I cannot turn on web or malware protection.  Also, the Malwarebytes icon does not show in the service tray. The Malwarebytes service is automatic and running.  I tried the 2 commands you provided (SC DELETE MBAMWebProtection and SC DELETE MBAMProtection) and got the same error message:

   [SC] OpenService FAILED 1060:

   The specified service does not exist as an installed service.

This is a very serious flaw in what has been a good tool for me in the past. What else can I do to solve this problem?

 

Thanks,

 

Steve

Link to post
Share on other sites

Lets get some logs please so that we can take a look at what's going on with the installation.  Hopefully it will reveal why this is happening:

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced Options on the main page (not Get Started)
  3. Click the Gather Logs button, and once it completes, attach the zip file it creates on your desktop to your next reply

Thanks

Link to post
Share on other sites

Actually, if privacy is a concern then I'd suggest contacting the Support team directly via one of the options on this page and a member of the team will work with you directly, in private that way you don't have to post any of your logs or information publicly.

They offer email support as well as instant chat (during business hours) and can work with you one-on-one to resolve the issues you're having with protection.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.