Jump to content
Due to inclement weather in Southwest Florida, our Clearwater support team is offline. Our other offices are available to assist you, however their responses may be delayed. We appreciate your patience and understanding during this time. ×

Says it is out of date but I have the latest version

Recommended Posts

While we're waiting, please do the following.  It may reveal what's going on with the program:

Create a Process Monitor Log:

  • Create a new folder on your desktop called Logs
  • Please download Process Monitor from here and save it to your desktop
  • Double-click on Procmon.exe to run it
  • In Process Monitor, click on File at the top and select Backing Files...
  • Click the circle to the left of Use file named: and click the ... button
  • Browse to the Logs folder you just created and type MB3 Log in the File name: box and click Save
  • Exit Process Monitor and open it again so that it starts creating the logs
  • Open Malwarebytes and check for updates via the button on the Dashboard.  Once it finishes updating (assuming it finds any new databases) and reverts to showing that it is out of date on the Dashboard, go ahead and close the MB3 main UI/window.
  • Close Process Monitor
  • Right-click on the Logs folder on your desktop and hover your mouse over Send To and select Compressed (zipped) Folder
  • Please attach the Logs.zip file you just created to your next reply, or if it is too large, please upload it to WeTransfer and provide us with the link to the file

Link to post
Share on other sites

I have the log files you requested but it looks like they won't be needed.

Here is the link to the logs - https://we.tl/uy7sN6ClVb

Following your suggestion to check my date and time settings I did the following

Opened date and time settings - both date and time were correct

Went to internet time

Selected change settings

Clicked update now and it said it was successfully synchronised with time.windows.com

When I check Malwarebytes it told it it was the current build.

I clicked to the word current to check for updates and everything was fine. It didn't change to say I was out of date.

Just to play safe I shut down and restarted my laptop and when I checked Malwarebytes it was still working fine.

So it looks like it was the time settings that messed things up, I'll keep and eye on it in case anything changes but for now things seem to be ok again.

Thanks again for taking the time to help me with this odd issue and for providing very easy to follow steps.

Link to post
Share on other sites

Wow, go figure.  All that troubleshooting and it turns out to be pretty much the most basic thing possible.

This does give me a good idea for a new feature though.  I'll be requesting that Malwarebytes ignores the local computer date/time settings from now on and instead checks the database/update values and time etc. from the update servers, because relying on the system clock alone is just silly in my opinion, especially since malware could easily modify the computer's data/time setting (a measure they've in fact used in the past to disable AVs and create other havoc by forcing software to believe it was expired etc.).

Link to post
Share on other sites

  • 1 month later...

I am having this same problem as well. 

I have done the following:

  • Manually installed the update
  • restarted my computer after the update
  • clean install (Used Geek Uninstaller to remove all traces) and then restarted and re-installed
  • Went through the registry settings like you stated above

Nothing has worked for me so far...


Scratch that, I did not see the post about the time... Having Windows re-sync the time worked for me as well.

Edited by lildiabetic
Did not see "time" post
Link to post
Share on other sites

There was maintenance being performed on the update servers earlier which is why this occurred, it wasn't just you who experienced the issue.  It happened on my own system as well, along with pretty much every other Malwarebytes user while the servers were down, but they're back up and running now so the issue should be gone.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.