Jump to content

Says it is out of date but I have the latest version

Recommended Posts

Today my Malwarebytes said it needed to update but whenever I tried clicking "check for updates" it wouldn't find and download the latest version.

So I first tried simply uninstalling it, going to the web site and downloading it again so I have the latest version.

I should note that it took a few attempts to download as it kept failing and I had to hit retry so the download would continue where it left off till it eventually finished.

After it had downloaded I activated my premium account and at first that seem to work but about five minutes later it told me it was out of date again.

So I tried uninstalling it again this time using the MB-check tool provided here

It uninstalled Malwarebytes, restarted my PC but then kept failing to download the latest version of the Malwarebytes.

So I had to go back to the website and download it from there which again required me to click retry a few times.

Once it had installed and reactivated my premium account (thanks to MB-check doing it automatically) that seem to do the trick.

However after a few minutes I checked it and it says I'm out of date again.

I don't believe it's my internet connection that's stopping me downloading the latest version as I had no trouble downloading the MB-check.

I also loaded up my Steam Client, connected online to my account and updated three games without any issues.

So, is there a bug in the most recent version that is either:

A) Mistakenly thinking it's out of date?

B) Not letting us downloading it?

If you need any extra info just let me know and I'll try my best to answer any questions.


Link to post
Share on other sites

  • Staff

***This is an automated reply***


Thanks for posting in the Malwarebytes 3 Help forum.


If you are having technical issues with our Windows product, please do the following: 


If you haven't done so already, please run these two tools and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Farbar Recovery Scan Tool (FRST)
    1. Download FRST and save it to your desktop
      Note: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
    2. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
    3. Press the "Scan" button
    4. This will produce two files in the same location (directory) as FRST: FRST.txt and Addition.txt
      • Leave the log files in the current location, they will be automatically collected by mb-check once you complete the next set of instructions
  • MB-Check
    1. Download MB-Check and save to your desktop
    2. Double-click to run MB-Check and within a few second the command window will open, press "Enter" to accept the EULA then click "OK" 
    3. This will produce one log file on your desktop: mb-check-results.zip
      • This file will include the FRST logs generated from the previous set of instructions
      • Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area

One of our experts will be able to assist you shortly.


If you are having licensing issues, please do the following: 


For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 


Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites

As the auto reply above has requested I will attach the result file that MB-check generated when it finished uninstalling Malwayebtes and restarting my laptop.
(I said PC in my original post by mistake just in case you were wondering)

Also I should note that the .exe for the version of Malwarebytes I downloaded from the website said this was it's version number



Edited by Caboos15
Link to post
Share on other sites

3.4.5 is the latest version, it sounds like you're getting a message that your database is out of date, not necessarily the program version. The logs requested above will be extremely helpful in troubleshooting this issue. You could also try going to https://sirius.mwbsys.com in your web browser and letting us know what the page says, this will give us an idea if you're having trouble reaching our update server

Link to post
Share on other sites

Thank you for taking the time to reply to my issue.

When I clicked the link you provided the only word that appeared was word "OK" in the top left corner of the screen.

I went back I followed the instructions of downloading that FIRST program the auto reply mentioned and re-did MB-check.

I'll attach the files they generated in a zip folder.

Let me know if there is any more info I can provide that may help with narrowing down what might be wrong.

mb-check files.zip

Link to post
Share on other sites

Hmm... it looks like we're missing quite a bit of information here. Can you try gathering logs using this new tool and upload this zip file?

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced Options
  3. Choose Gather Logs, and once it's done, upload the zip file it creates on your desktop (mbst-grab-results.zip)
Link to post
Share on other sites

Here are the messages I see whenever Malwarebytes checks for updates or when I check manually.

If I click check for updates or the update now from the message that pops up from my tool bar nothing happens.

If I shut down and restart my laptop the message on the main screen changes back to telling me it's the current version until it checks for updates and changes again.

Are there any settings I could alter?
I've tried selecting install application updates but it tells me there are none available.

malwarebytes - your updates are not current.jpg

malwarebytes - your updates are not current - tool bar message.jpg

Edited by Caboos15
Link to post
Share on other sites

Here is the scan result you requested.

I should note (though I'm not sure if it's important) that I had shut down since reading your team's last reply.

So once again when I launched malwarebytes after starting me laptop I was told I had the current version and after I finished the scan you requested, it told me I needed to update.




-Log Details-
Scan Date: 4/10/18
Scan Time: 7:44 PM
Log File: 38ad48e8-3cef-11e8-be83-28b2bd101ed0.json
Administrator: Yes

-Software Information-
Components Version: 1.0.342
Update Package Version: 1.0.4668
License: Premium

-System Information-
OS: Windows 8.1
CPU: x64
File System: NTFS
User: Caboos15\Michael

-Scan Summary-
Scan Type: Threat Scan
Scan Initiated By: Manual
Result: Completed
Objects Scanned: 274269
Threats Detected: 0
(No malicious items detected)
Threats Quarantined: 0
(No malicious items detected)
Time Elapsed: 0 min, 49 sec

-Scan Options-
Memory: Enabled
Startup: Enabled
Filesystem: Enabled
Archives: Enabled
Rootkits: Disabled
Heuristics: Enabled
PUP: Detect
PUM: Detect

-Scan Details-
Process: 0
(No malicious items detected)

Module: 0
(No malicious items detected)

Registry Key: 0
(No malicious items detected)

Registry Value: 0
(No malicious items detected)

Registry Data: 0
(No malicious items detected)

Data Stream: 0
(No malicious items detected)

Folder: 0
(No malicious items detected)

File: 0
(No malicious items detected)

Physical Sector: 0
(No malicious items detected)


Edited by Caboos15
Link to post
Share on other sites

Thanks, that scan log revealed what I needed to know.  It shows that all components, including your database, are up to date.  This means it must be an issue with the configuration file that tells Malwarebytes when it is out of date.

Please go to C:\ProgramData\Malwarebytes\MBAMService\config and open the file UpdateControllerConfig.JSON with notepad and copy/paste its contents into your next reply.

Link to post
Share on other sites

Thank you for the quick reply :)

I followed the file location as you instructed and here is the information you asked for.




   "ae_dynconfig_version" : "0.0.1",
   "ae_exclusions_version" : "0.0.1",
   "auto_update_interval" : 60,
   "beta_opt_in" : false,
   "channel" : "release",
   "controllers_version" : "1.0.342",
   "db_pub_date" : "1523302410",
   "db_update_time" : "2018-04-10T20:49:25Z",
   "db_version" : "2018.04.09.04",
   "dbcls_pkg_version" : "1.0.4670",
   "enable_auto_update_dbcls" : true,
   "enable_auto_update_sdkctlr" : true,
   "force_full_update" : false,
   "installer_update_pending" : false,
   "installer_version" : "3.4.5",
   "max_incremental_updates" : 8,
   "messages" : [

   "pending_installer_path" : "",
   "pending_installer_version" : "",
   "pending_sdkctlr_path" : "",
   "pending_sdkctlr_version" : "",
   "prev_program_version" : "3.4.5",
   "sdkctlr_update_pending" : false,
   "use_staging" : false

Edited by Caboos15
Link to post
Share on other sites

Thanks, everything seems to check out there.  The only odd thing I noticed in your logs was this:

Pending File Rename Operations
C:\Program Files\Malwarebytes\Anti-Malware\  

I don't see how that would cause it, however it is odd that Malwarebytes program folder is listed there.  It must have been left over from when you installed the most recent version.

Please try restarting the system, then check the registry at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager to see if it still lists that folder, and if it does, please edit the registry data to remove the Malwarebytes folder, then reboot once more and see how things are.

edit: documentation on this registry key and its purpose may be found here

Edited by exile360
Link to post
Share on other sites

I went to the registry that you mentioned, found the old malwarebytes file and removed it as per your instructions.

I then shut down, restarted my laptop and sadly nothing has changed, it still tells me I'm out of date and I need to check for updates.

Should I try performing another clean uninstall and reinstall of malwarebytes now that file is gone?

Could there be any other old files left over that I should find and remove?

I'll also attach a new scan result and a new UpdateControllerConfig.JSON file copy in case you need them.

malwarebytes - scan results.txt

updatecontrolconfig copy.txt

Link to post
Share on other sites

Yes, another clean install is worth a shot.  Hopefully it will correct whatever it is that's going on here.

By the way, do you use any kind of software that backs up/restores your system automatically and have you configured AVG to exclude Malwarebytes?  I'm just thinking that it's possible that something is blocking Malwarebytes from reading and/or modifying one or more of its config files or something and that could be the cause, or that perhaps something on the system is rolling something back that makes Malwarebytes believe it hasn't been updated.  We can dig into that further once you do another clean install though; lets see if that corrects it first.

Link to post
Share on other sites

I tried a clean uninstall and I'm sorry to say it didn't help.

I also tried the suggestion of switching off the self protection module in the settings but that didn't work either.

I also tried switching the setting off and turning my laptop off then on again just to be sure.

I used MB-clean again and it uninstalled and generated the result file but it failed to download the latest version.

So I had to use the .exe I downloaded the other day from the website when this all started.

In answer to your questions regarding if I use any software to back up/restore my system.

The only restore software I use is the one that comes with windows 8.1, I don't use any third party stuff.

Same goes for file history which is done daily and only backs up documents, music, pictures, videos, contacts, favourites and desktop

As for AVG, I haven't configured that in any way to exclude Malwarebytes.

The only time I had to alter something was on Malwarebytes last year after AVG had a update that made it not longer fully compatible with Malwarebytes.

So I looked online and found a suggestion (I believe on this site I can't remember) which said to go into settings and change it so Malwarebytes didn't register with windows action center.

That fixed the problem and I didn't have any issues with either programs since then. I can't imagine that being the issue however as uninstalling and reinstalling Malwarebytes would switch that setting back to it's original default mode.

Should I try changing/checking something in AVG?

I'll also attach all the files you requested in previous posts

The two FIRST files

The MB-Check stuff

The MB-Clean file

Scan results



malwarebytes - scan results 11-04-18.txt




Link to post
Share on other sites

Yes I do get a message on dashboard page, it's the one I attached a screen shot of in my previous post alongside the message the pops up my tool bar.

I should note that it only does the tool bar pop up when I first start my laptop, start a scan/check for update, then open a different application and when it's done scanning/checking it gives me the pop up while I'm using the other application.

Something I did notice today was when I loaded malwarebytes and a scheduled scan started.

This was probably because it's still has the timer set to the installed default after being reinstalled.

Anyway, as it was checking for updates I clicked to view the dashboard to see if it was making any progress.

Under scan status and next to update it said it was applying the update.

However after it had finished saying that, it changed to say check for updates and the dashboard changed to say that I was out of date again.

Was there a new version that was released today?


Link to post
Share on other sites

I can confirm that if I click the check for updates button on my dashboard it still says I'm out of date.

I do not get any other notification.

I made a recording of what happens when I click the button, I couldn't upload the mp4 file here so I just uploaded it as a unlisted video on youtube.

Also I'm not sure how useful this info will be but I can also confirm that I did indeed successfully install the latest update package from version 1.0.4646 to version 1.0.4700 as shown in the end of the video.


Edited by Caboos15
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.