Jump to content
KaidensMommy

Windows Security Alert? Not sure what to do?

Recommended Posts

Hello. I just restarted my computer and I had a Windows Security Alert Come up:

image.png.2897f90ed89aa34691c24143e249ab12.png

I have never had this come up before. I'm not sure what to do. I checked my settings in Windows Defender and it has "Firewall is on" for Domain network, private network, and public network. The only time I use this computer is at my own place using my own wi-fi. I never take it anywhere so never use public wi-fi? I'm not sure what is making this alert come up when it never has before?

Any help would be greatly appreciated!!

Share this post


Link to post
Share on other sites

Ok! Great! I have just had it sitting here not sure what to click! I didn't want to click to allow it and regret it! Thanks for the response...again ;)!!

Share this post


Link to post
Share on other sites

You're welcome :)

Yep, it's just the Windows Firewall letting you know that the program wants to communicate with the web.  I'm not sure what caused it to come up now suddenly, but most likely it was something innocent like Firefox running its scheduled update check or checking for new versions of your installed plugins or something like that which resulted in it accessing the web in a different way than usual so the Windows Firewall spotted it and alerted you just to make sure you were aware and were OK with it.  Since we know that Firefox is a legitimate program that you use for browsing, it's perfectly fine to allow it access.

If there's anything else we can help with please don't hesitate to post and let us know.

Share this post


Link to post
Share on other sites

Ok! When I restarted the computer and opened Firefox, it did say Firefox was updating, so I guess that's why it did it now all of a sudden? But it's just weird it never did it before when Firefox updated. So, I wondered what made it do it now since I haven't made any changes to Firefox (other than whatever it just updated).

Share this post


Link to post
Share on other sites

Ah, that explains it.  I bet that Firefox updated to a new version and in the process, one or more of its files changed, and because of that, the Windows Firewall treated it like it was a new program.

Share this post


Link to post
Share on other sites

You should uncheck that Public Network box if you never take your computer out of your home.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.