Jump to content

Event 10016 DCOM triggered freeze

Recommended Posts

This has been a persistent problem for me. Four simultaneous event 10016 will cause my system to lock up, while doing intensive Cad work. I've tracked one of them to Malwarbytes. I've disabled it in hopes there's a fix in the works. 

Thank you.Freeze.JPG.3bd5dcb2f80a0a28f69e57dd38e14ed4.JPG

Link to post
Share on other sites

Hello @JasonWF and :welcome:


Please download the Malwarebytes Support Tool to assist us in helping you further with your issue.

It is a multi-purpose troubleshooting and repair utility, designed to assist with issues related to Malwarebytes for Windows. Our goal with the Malwarebytes Support Tool is to provide a simple and stress-free approach to troubleshooting issues with Malwarebytes products

** Download Malwarebytes Support Tool Here **

1. Please save the file where you can locate it.


2. Then close all browsers and locate the file you downloaded and double-click on it to install and run the program.


3. Place a checkmark on the "Accept License Agreement" checkbox and click the Next button.


4. Click on the "Advanced Options" link for Forum Support options


5. Click on the "Gather Logs" button


6. The program will run the FRST program in the background and gather some diagnostic logs and zip them up on your desktop as:  mbst-grab-results_zip


7. Close the Malwarebytes Support Tool and locate the file: mbst-grab-results_zip on your desktop and upload that as an attachment to your next reply.



For more information, please refer to the following links:

Malwarebytes Support Tool User Guide
Malwarebytes Support Tool FAQs




We do have an update to version 3.4.5 - not sure if that would help or not, but you could also try that and let us know.


Malwarebytes 3.4.5 - patch release

Direct download link. Install over the top of your current installation

Thank you



Link to post
Share on other sites

As I understand things it's a Windows 10 issue. One that that's existed since windows 7. Only now after the last big update, it's causing real issues. MS is just proposing regedit fixes that don't work. This isn't a unique problem. Since uninstalling malwarebytes, I'm only seeing three DCOM errors. I'll let you know if I have another crash. 

Link to post
Share on other sites

I have a few suggestions for DCOM issues, but would also like to see these reports:

Let's try looking at these 2 sets of reports:

Report Set #1)  Please run this report collecting tool (even though you may not be experiencing BSOD's) so that we can provide a complete analysis: (from the pinned topic at the top of the forum)  


If you have problems with it running it, there's an alternate tool here (direct download link):  https://github.com/blueelvis/BSOD-Inspector/releases/download/1.0.5/BSODInspector-1.0.5.exe

Please zip up the (.ZIP) files - do not use .RAR or other compression utilities. 
.ZIP is the type file that can be uploaded to the forums.

Report Set #2)  Please do the following:
- open Event Viewer (run eventvwr.msc from the "Run" dialog)
- expand the Custom Views category (left click on the > next to the words "Custom Views")
- right click on the "Administrative Events" heading
- select "Save all Events in Custom View as..."
- save the file as Admin.evtx
- zip up the file (right click on it, select "Send to", select "Compressed (zipped) folder")
- upload it with your next post (if it's too big, then upload it to a free file-hosting service and post a link here).

FYI - If we're looking for Event ID 41 errors (unexplained shutdowns), there's more info on that here:  http://support.microsoft.com/kb/2028504
The Event ID 41 error is simply Windows saying that it doesn't know why it shutdown.

While waiting for a reply, please monitor your temps with one of these free utilities: 
SpeedFan:  http://www.almico.com/sfdownload.php
HWMonitor:  https://www.cpuid.com/softwares/hwmonitor.html
HWInfo:  https://www.hwinfo.com/download.php

Link to post
Share on other sites

Had to split this into multiple posts as the forum software doesn't always handle nested quotes will

Here's my DCOM suggestion:

Please attempt to fix your DCOM errors by doing this:

Go to Start, and then to Run (or the Win and R keys)

Type in "dcomcnfg" (without the quotes) and press Enter

In the Component Services window that opens, go to the left hand pane and double click on:
- Component Services, then on
- Computers, then on
- My Computer, then on
- DCOM Config
If it asks you to register any of the components, click Yes
This may happen several times if there are several unregistered components

Once you're finished, close the window and reboot the computer.
Check to see if the problems are fixed.

NOTE:  This is a generic "fix" for DCOM errors.  If it does not fix your problems, please post back.


And here's another fix that might help:

Then please run the following DISM commands to see if there's any problems with the system (from an elevated (Run as administrator) Command Prompt).  Press Enter after each one:

Dism /Online /Cleanup-Image /RestoreHealth

From this article: http://technet.microsoft.com/en-us/library/hh824869.aspx

You can also run sfc.exe /scannow from an elevated (Run as administrator) Command Prompt to check for further corruption.  If it does find corruptions that it cannot repair, I would suggest zipping up and posting the CBS.log (from C:\Windows\Logs\CBS\CBS.log ) so that other experts can help with that (I can't read the CBS logs myself).


Link to post
Share on other sites

Finally, searching your system for the CLSID and the AppID may help to reveal the program associated with the freezes (and a test would be to uninstall them  temporarily to see if that stops the freezes)


Link to post
Share on other sites

I'm on a fresh install of Windows 10. With the latest Bios for spectre. Clean install of latest Invidia drivers. I've ruled out my RAM and Samsung 960 EVO. DSIM didn't discover any issues. 

I haven't had a lock up since uninstalling Malwarebytes. I'll keep you posted.

It appears to me that Malwarebytes does trigger at least one DCOM error. 


Link to post
Share on other sites

I think things are sorted now. I've reinstalled Malwarebytes and haven't had any issues. I believe something went wrong with my Bios update. I tried unsuccessfully to clear it (cmos button then jumper and battery removal). But it appears that fixed it. I noticed a 6 degree drop in temps afterwards. I still can't explain what went wrong initially. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.