Jump to content
tatreps

Malwarebytes Causing In-game Lag

Recommended Posts

I recently upgraded from 3.3 to 3.4 and have noticed lag in Borderlands 2 when the game autosaves at a checkpoint. I did not have this issue with the 3.3 version and it only appeared post upgrade to 3.4. It makes the game literally unplayable. I have found other people who recently, as in the last two weeks who are having the same issue.

https://steamcommunity.com/app/49520/discussions/0/1698293703772876529/

They also report the issue post 3.4 update considering the timing of the posts being March of this year.

They solved it by disabling Malwarebytes Real Time protections.

I can confirm that Malwarebytes is indeed the issue and when these protections are disabled the lag disappears.

Please fix this, as I don't want to disable my protection just to play a video game.

Edited by tatreps

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes 3 Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven't done so already, please run these two tools and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Farbar Recovery Scan Tool (FRST)
    1. Download FRST and save it to your desktop
      Note: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
    2. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
    3. Press the "Scan" button
    4. This will produce two files in the same location (directory) as FRST: FRST.txt and Addition.txt
      • Leave the log files in the current location, they will be automatically collected by mb-check once you complete the next set of instructions
  • MB-Check
    1. Download MB-Check and save to your desktop
    2. Double-click to run MB-Check and within a few second the command window will open, press "Enter" to accept the EULA then click "OK" 
    3. This will produce one log file on your desktop: mb-check-results.zip
      • This file will include the FRST logs generated from the previous set of instructions
      • Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Share this post


Link to post
Share on other sites

Greetings,

Which realtime protection components do you have to disable?  Is it any particular one, all of them, or do you have to exit Malwarebytes completely?

Share this post


Link to post
Share on other sites

Originally I disabled all the protection, then started up the game to see if it was fixed and it was.

I just started up the game to test, and found out that after I stopped playing and re-enabled all the protections the game worked fine. No lag on autosaves.

I then restarted my computer and started up Borderlands 2 with all of Malwarebytes protection starting on startup and found that the lagging on autosave was back.

I proceeded to check each option, one at a time, off while leaving the rest on, then turning it back on after turning it off didn't fix the lag.

I have found that disabling Ransomware Protection fixes the lag on autosaves.

Re-enabling the setting after disabling once, does NOT bring the lag on autosave back. I must restart my computer and have the protections begin on startup for the issue to reappear.

Share this post


Link to post
Share on other sites

Thanks for the additional info.  I'll report this information to the Product team and hopefully it will lead to a permanent fix in a future release.

Share this post


Link to post
Share on other sites

I wonder if borderlands2 is using openGL or directx?  my opengl program is seeing issues with massive lag when realtime protection is on too 

 

Share this post


Link to post
Share on other sites
1 hour ago, jinkee said:

I wonder if borderlands2 is using openGL or directx?  my opengl program is seeing issues with massive lag when realtime protection is on too 

 

According to a list of games that support OpenGL on Wikipedia, it does, however I also found references to it supporting DirectX on the Steam forums, so unless it is possible for it to support both simultaneously (which I didn't believe was possible, though admittedly I'm no expert on the subject), then I believe it is DirectX based, not OpenGL.

Edited by exile360

Share this post


Link to post
Share on other sites

Wouldn't be a problem if exclusions were actually excluded, and not treated as more of a suggestion to MB3.

Edited by Horonelius

Share this post


Link to post
Share on other sites
6 hours ago, Horonelius said:

Wouldn't be a problem if exclusions were actually excluded, and not treated as more of a suggestion to MB3.

It does exclude things properly, unfortunately it only actually excludes them from detection, not so much from monitoring hence the continued performance issues.

On the bright side, the Devs do have a build in testing right now which most likely will fix this.  It's due for release late this month if all goes as planned.  Keep an eye out for the beta if you're interested in testing it out to see if it works to resolve the issues.

Share this post


Link to post
Share on other sites
13 hours ago, exile360 said:

It does exclude things properly, unfortunately it only actually excludes them from detection, not so much from monitoring hence the continued performance issues.

On the bright side, the Devs do have a build in testing right now which most likely will fix this.  It's due for release late this month if all goes as planned.  Keep an eye out for the beta if you're interested in testing it out to see if it works to resolve the issues.

Excellent, I'll keep an eye out for that.

Share this post


Link to post
Share on other sites
On 3/20/2018 at 8:57 PM, exile360 said:

According to a list of games that support OpenGL on Wikipedia, it does, however I also found references to it supporting DirectX on the Steam forums, so unless it is possible for it to support both simultaneously (which I didn't believe was possible, though admittedly I'm no expert on the subject), then I believe it is DirectX based, not OpenGL.

It is Direct X 9 32-bit. At least that's what Windows 10 says it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.