Jump to content

Unable to connect to service / Error 1068


Recommended Posts

Hello

When I try to open Malware Bytes I get a 'unable to connect to service error'. I'm not sure how long this has been going on, at least a couple of weeks, but I hadn't tried to open MB for a while before that, so could be a few months.

I've tried a ton of things to fix it including uninstalling, running mbma-clean.exe, restarting and reinstalling the latest version. I've also got a free trial of CCleaner Pro and ran a registry scan, which found a ton of errors relating to MB but when I fix them and tried the mbma-clean.exe/uninstall/re-install it didn't help. During the reinstallation I temporary disabled my anti-virus, which is a paid version of ESET NOD32.

I saw in some videos to go to services.msc and set it to 'automatic' startup - it's already on this. When I click on properties and try to 'start' the process this is when I get the error 1068: the dependancy service or group failed to start. When I go into the dependancies tab I get the error message 'Win32: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. There are no listed services/system components in the 2 boxes titled:

This service depends on the following system components
The following system components depend on this service

I've ran FRST and mb-check and have attached the mb check results in hope that it might help someone show me how to fix this mess! Many thanks in advance

Dave

mb-check-results.zip

Link to post
Share on other sites

It looks like your Windows Management Instrumentation(WMI) service is not running. 

Could you make sure it is not disabled. 

  1. Click "Windows" + R keys to open the "Run" dialog
  2. Type in "services.msc"
  3. Look for Windows Management Instrumentation service
  4. Make sure to set it to "Automatic" if it's set to disabled 
    1. Right-click and go to "Properties"
    2. Change "Startup Type" to "Automatic"
    3. Hit "Apply"
  5. Make sure to start the service if start up needed to be changed
    1. Right-click and hit "Start"

 

If the above instructions don't work or the service is damaged, follow the following instructions to repair WIM:

  1. Download the Windows Repair (All in One) tool from here: Click Here
  2. When the tool opens look across the top and you'll see tabs.
  3. Click the Backup Tools tab and make sure you Backup the Registry and Create a Restore Point. The screen is very clear on how to do that – just click the related buttons.
  4. When those have completed, you're now ready to click the 'Repairs' tab.
  5. When that window opens, uncheck the "Automatically Do A Registry Backup checkbox and then click the 'Open Repairs' button. 
  6. Now you will see a list of all the things it can repair. Many (if not all)  will be automatically checked off – we do NOT want to repair everything!
  7. Uncheck the box at the very top next to 'All Repairs' and that will uncheck them all.
  8. Place a check in the following box:
    1. 05 - Repair WMI
  9. Click the Start Repairs button and give it some time. Do not use the computer while this is carrying out the repairs.
  10. Reboot when prompted.
Edited by vbarytskyy
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.