Jump to content

still being billed for anti-exploit


Recommended Posts

Hi. I'm not sure that this is the proper forum but here is my problem. Cleverbridge has notified me that they would be billing me next month for anti-exploit subscription. [Malwarebytes Anti-Exploit Premium order, Reference # 128305644]  but I have been using MBAM premium (ver 3.3.1.2182) ever since it was available. I understand that Anti-Exploit was rolled into MBAM with version 3 and that I would no longer need both programs together on the same machine. Is this correct? If so how can I straighten this out?. Thanks in advance. DavidB

Link to post
Share on other sites

Greetings and welcome :)

The most expedient means of getting assistance with any issues related to purchases, renewals and licensing would be to contact the Malwarebytes Support staff directly.  You may do so via the options on this page.  They offer support via email by filling out the form on that page or via live chat during business hours.  It may also be necessary to contact Cleverbridge so if that is required, please refer to the information in the knowledgebase article posted here.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.