Jump to content

Sudden MB3 Conflict Win 10 -- Cannot Download

Recommended Posts

I have had MB3/Win 10 64 bit, installed and running on my Asus g73jh since November, no problems until last Saturday (1-27).  I had a Windows 10 freeze up.  It took a couple RESTORE attempts and 5 or 6 reboots/shutdowns to stabilize the system.  In the meantime, Malwarebytes 3 suddenly became inaccessible, no matter how I approached it.  Desktop icon/tray icon didn't respond, going into Programs and launching there --- nope.  Windows Defender showed that attention was needed regarding MB3.

After scouring the forums, I finally decided to try an Uninstall-Install.  Now I cannot download and reinstall MB3 at all, even after running MB Clean.  Every time I tried opening "mb3-setup-consumer-x.x.x.xxxx.exe after, however, each time I receive the error message "ShellExecuteEx failed;  Code 2147746132.  Class not registered."

I was able to unzip an Windows-mb-installer and get it to run....for a few seconds before I got this error message:   

Class not registered, ClassID

I am about at the point where I say screw it and reformat with clean install of Windows and piece together the apps, like Civ V, GoPanda2, etc.  Do you have any suggested fixes that I haven't tried.  I am in no way a power user.    Thanks.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.