Jump to content

Recommended Posts


While using my computer today, my computer suddently froze. I had to power it down by holding the power button. When I rebooted, Real Time Protection on Malwarebytes wouldn't start properly (it just says "starting" and never completes). Also, in Task Manager, I'm noticing the process called MBAMService.exe is using multiple gigabytes of RAM, and keeps rising up. I've seen it up in 10GB RAM usage, but I always end the process before it gets any higher.

I tried running scans on Malwarebytes, Windows Defender and AVG, all being able to successfully perform the scan, but they do not detect anything. I uninstalled Malwarebytes and tried installing it again. After entering the MB License, causing the Real Time Protection to attempt starting, the high RAM usage starts happening again.

I then tried running mb-clean to re-install Malwarebytes. Doing this changed nothing. At this point I have Malwarebytes uninstalled until I have something else to try out.

I really do not notice any other oddities on my computer. With it uninstalled everything seems fine, but I obviously want MB up and running again, and also I'd like to find out if there is anything else strange happening on my PC. Please come with some suggestions or instructions on what else can be done or checked to resolve this. I can provide more info if it is requested.

Thanks in advance!

Link to post
Share on other sites

Hey! I fixed my computer by TURNING OFF MALWAREBYTES!

Last time I had to install the latest version and I could get the protection i'm paying for but I can't tell if I have the latest version (3.1.1.) because MB is 'checking' and using so much RAM that my 12GB machine with almost NOTHING running can't even deal.


Link to post
Share on other sites

I'm using a Win 8 Surface with 4GB and  Malwarebytes Premium 3.3.1. Malwarebytes services has gotten as high 3013 MB. This just started around 11AM CST. For now, I've just turned it off. However, seeing as I'm paying for this product, this is unacceptable.

I'm glad I"m not the only one experiencing this issue.

Link to post
Share on other sites
  • Staff

We're sorry you had issues with our program today. We've addressed the issue and here's what you need to do to fix it.

*** How to resolve / verify you have the fixed update package ***

  • Update package version 1.0.3803 or higher contains the fix
  • To resolve, simply reboot your machine. In some cases, a second or even third reboot may be needed.
  • To verify you have this update, go to Settings ->  About -> Update package version: 1.0.3803

To learn more about what happened, please go here:

If you continued or new issues, please start a new thread and we'll happily look into that for you.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.