Jump to content

Recommended Posts

Ok. I am an unhappy cookie this morning.

Woke up to find that for some reason, the Malwarebytes service's memory usage keeps constantly increasing at an alarming rate (makes the PC unusable within 10 minutes of use, no joke) without there being any activity on my computer except me typing this in Notepad, because of the problem Malwarebytes is causing.

Memory use as seen in Process Hacker goes as high as 13 Gb of memory (this PC has 16 gb) before Windows (7, 64 bits) starts complaining that I'm low on memory and must quit some programs. I never have the time to actually do this because MBM is continuing to increase its craziness in the background and the PC blackscreens and I have to hard-reset.

I am having to type this in Notepad over several reboots + kills of the mbam service. It takes less than 8 minutes to end up in the same place with low system memory.

I have disabled self-protection in order to turn the service off via the services console (services.msc) but it refuses to comply completely, and simply turns itself back on every time, where it repeats the cycle of quickly consuming all available RAM.

I have disabled EVERY scan option, notification, check for updates etc. and yet memory usage continues to increase. In the time it took to type this message, it has gone up to 6gb so I'm killing it again.
I am somewhat a fast typist, by the way.

This obviously makes the computer unusable since I can't be expected to restart a ¦²¬²³¦ service every 6 minutes... I don't even think I have time enough between startup and it going insane to run the tools you've suggested to another user here.

Oh, and less important but also relevant, CPU usage sits at a constant 25% even though nothing is happening. No scan; nothing.

I am going to have to uninstall the program to use the PC at all, so please help fix this, quickly...!

 

Here's the progression in Process Hacker:

5a6caccb6038b_20180127_092856_1malwarebytesmisbehaving.thumb.jpg.93080956925d0dcd2368f2a38339a202.jpg

 

A few minutes later (meaning about 4, look at the Total CPU time)

 

5a6caccf6e246_20180127_093932_2keepsgoing.jpg.a93a920c5a1c4e1a3d363c5cf43392cf.jpg

And then antother 1-2 minutes (and I just had to kill the service again while typing this)

 

5a6cacce6911c_20180127_094056_3andagain.thumb.jpg.8286616bb29f63a3304af3aa11c9dbde.jpg

 

Keeps going

 

5a6cacccb3475_20180127_094154_4afewsecondslaterbeforeservicekill.jpg.89836c94fd48fa1f1c109023edf2d4aa.jpg

 

And this is what I get when I try to kill the service, it does kill the process but immediately restarts it despite my having set Startup to Manual and Service to Disabled...

 

 

5a6cac6623d42_20180127_094232_5cantfullystopserviceatleastitrestarts.jpg.65e0e21e526a956747387cc65614b6cd.jpg

Edited by ThreeCharactersLong
corrected some information

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes 3 Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven't done so already, please run these two tools and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Farbar Recovery Scan Tool (FRST)
    1. Download FRST and save it to your desktop
      Note: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
    2. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
    3. Press the "Scan" button
    4. This will produce two files in the same location (directory) as FRST: FRST.txt and Addition.txt
      • Leave the log files in the current location, they will be automatically collected by mb-check once you complete the next set of instructions
  • MB-Check
    1. Download MB-Check and save to your desktop
    2. Double-click to run MB-Check and within a few second the command window will open, press "Enter" to accept the EULA then click "OK" 
    3. This will produce one log file on your desktop: mb-check-results.zip
      • This file will include the FRST logs generated from the previous set of instructions
      • Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Share this post


Link to post
Share on other sites

Why in the world would I want to make all of my information public by attaching those logs IN PUBLIC?

Is there a private drop site where I can put these where only employees will have access?

Share this post


Link to post
Share on other sites

Please use the main topic for this that already has a ton of replies instead of starting a new one. Other than that, the post above yours was an automated post so please stop arguing with a Bot.

Share this post


Link to post
Share on other sites

No, I'm arguing with the support staff because they made the bot and they are going to read this.

It's unacceptable to not even have their tools password-protect the archives as a default measure.

Since you aren't support staff though: please mind your own business about that.

Share this post


Link to post
Share on other sites

I have experiencing the same behavior.  It keeps eating up about 20 meg of ram every second.  I have uninstalled and reinstalled as well.  Help!

Share this post


Link to post
Share on other sites

Same here, I thought it was a hardware issue at first until I found this thread. MWB was running wild processes all over the place prompting me that real time protection was turned off (apparently it did so by itself).

Only solution for me was to forcibly uninstall MWB through Revo Uninstaller, as I couldn't even uninstall it directly.

A shame that a program meant to protect you starts running wild with your PC. I'm a premium user, so hopefully they get this fixed soon. Always been happy with Malwarebytes, but this is a big fail here.

Share this post


Link to post
Share on other sites

I have the same issue also, suddenly it takes all the memory and my pc goes black screen and I need to restart my whole PC to temporary fix it, it was also mixed with cannot connect to license server and web protection got disabled  tried mbclean now I don't have the license server issue but still high memory usage I barely can use my pc

 

EDIT: never mind my web protection went off again and still eating my ram

Edited by TatesMan

Share this post


Link to post
Share on other sites

Same here...

Web protection turns itself off, and cannot be turned back on.

Malwarebytes is eating more and more RAM over about 15 minutes by which point it's using all of my 16GB (!) and my Laptop crashes...

Share this post


Link to post
Share on other sites

I created an account just to respond here. The same thing happened to me and it started today 01/27. I've spent about 3 hours on it thinking I got infected somehow.

I've done MBAM uninstall, reboot, restore points, re-install, reregister premium and have been at this crap for hours.

The second malwarebytes updated the malware bytes service in proccesses (Win 10) is literally expanding memory until all of memory is gone, 16GB of gaming memory, and both monitors go black and then windows beeps and I can't do jack except reboot.

For now ending the task on malwarebytes service fixes it but now I have no protection.

 

PLEASE SUPPORT STAFF NO CANNED RESPONSES. Also, web protection is off.

After a clean install, I'm running the latest download and everything was working so I updated the software itself in the mbam tray and then it started going crazy again!

Share this post


Link to post
Share on other sites

Same issue. Googled and found this happened. I'm hitting 11gb memory usage out of 16gb, so it's clearly a memory leak of sorts. Turning it on the disabled web protection results in the same behavior.

Share this post


Link to post
Share on other sites

Ditto blackbolt22.   I created this account just due to this error.  I have noticed the same thing:  the rampant memory consumption starts after an update.

 

This is utterly ridiculous.   

Share this post


Link to post
Share on other sites

Oh and I can guarantee you there are way more people having the issue then reporting it here. Don't you guys test these updates out first in a beta environment?

I'm going to install the version I downloaded and not update it and make sure it's ok.

Version right now is 3.3.1.2183.. about to uninstall and install the one I downloaded this morning after all this began -_-

 

P.S. guys this is called a memory leak and is the result of some code being out of place..

Edited by blackbolt22

Share this post


Link to post
Share on other sites

I am experiencing the same issue. If I had to guess I think your product has been compromised via DDoS via internal resources. I would suggest fixing this immediately. I have been a loyal customer for over 3 years now, and you risk losing a customer. From the posts I have seen here on your forum site,  just today I think I won't be the only customer you lose! ;--)

 

Share this post


Link to post
Share on other sites

Same problem.

  • Nothing wrong last night, came downstairs to a crashed PC.
  • Rebooted, system seemed fine.
  • Then slowdown started and Malwarebytes web protection turned off.
  • System started running slow and janky, opened task manager.
  • Malwarebytes was using 62% of system RAM and 28% of CPU. RAM usage was climbing by the second.
  • Malware bytes ran my system out of available memory, system crashed.
  • Rebooted, same issue: RAM usage climbs until system crashes.
  • Quitting Malwarebytes completely resolves the issue.

I am running an Intel Core i7-6770HQ processor (2.6 GHz) and 16GB of DDR4 RAM, with the OS and data on an M.2 SSD. Clean install of Win10 when I built the system two months ago.

It's not a problem with my system, it's a problem with Malwarebytes.

Share this post


Link to post
Share on other sites

Definitely a widespread problem, happened to me like 10 minutes ago, had to kill the Malwarebytes Service process twice and so far it seems to stay put. Reddit also went crazy, everybody seems to have the same problem, Free and Premium users (Premium user here).

Share this post


Link to post
Share on other sites

Premium User here-- I made an account just to post and say I'm having the same problem. My machine is practically unusable. Absolute insanity. 

Share this post


Link to post
Share on other sites
6 minutes ago, Cardinal65 said:

I cannot turn off Service or Process.  It keeps restarting.

type services.msc in the search bar and run that. Look for the service you want and then right click->properties->startup type->manual. Then STOP it. It shouldn't restart.

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.