Jump to content

Cannot "Allow" MalwareBytes system extension with 10.13 (High Sierra)

Recommended Posts

In attempt to resolve the "Cannot "Allow" MalwareBytes system extension with 10.13 (High Sierra) issue I disconnected my TeamViewer session and had the client click on Allow.  Then took another remote session.  The Security setting was allowed and the installer completed successfully. 

Then I restarted.  The iMac no longer starts up.  Apple Logo, progress bar slowly moves toward 100% but never completes.  I tried having her boot into Safe Mode but that didn't work either.

Even if it is Apple's fault.  The computer was not having problems prior to installing Malwarebytes for Mac.  This is terrible behavior for Malwarebytes and makes me look bad.  I mean I'm a Malwarebytes partner and I recommended installing this application.  Now I cannot charge for the hours of support.  

This client is also a friend and she is 265 miles from my office.  So I either have to walk this 80 years-of-age woman  through booting the iMac into Recovery mode and restoring her computer from her Time Machine backup, or I have to drive up there to fix this.  This is the last time I install Malwarebytes remotely.  

I am hoping someone has seen this and has a simple fix, fingers crossed!

Link to post
Share on other sites

  • Staff

I can't imagine what Malwarebytes for Mac could have done to cause such a problem. Since the computer also doesn't start up in safe mode, that's definitive proof that having Malwarebytes for Mac installed isn't causing the problem, since safe mode disables all of the Malwarebytes for Mac components. Had you run a scan with Malwarebytes yet, or just installed it?

Unfortunately, this sort of problem pretty much never has a simple fix. This sort of problem is usually caused by a damaged system. Worse, if she has an older machine with the original rotational hard drive, it may be a drive failure.

Link to post
Share on other sites

Thanks for getting back to us.  However, I can see how this happened.  For whatever reason, the computer stopped loading the GUI upon installing Malwarebytes and restarting.  Therefore it only makes sense that something related to the installation caused a problem.  Also, her computer is a late 2015 iMac with a 1TB flash card and 32GB of ram.  It's not old by any means.

The computer may not have been booting up into Safe mode.  I tried booting my iMac into safe mode and I have a bluetooth keyboard and it would not boot into safe mode.  So I am thinking to try a wired keyboard to boot into safe mode.

If you think of anything else, please keep us posted.

Link to post
Share on other sites

  • Staff

Have her try rebooting in safe mode again, and be sure that the machine is actually in safe mode by following the instructions in "How to tell if your Mac is started in safe mode" on this page:


If she's having trouble getting into safe mode, you can force it if you have remote shell access, by using the information in the section at the bottom of the page titled "If your Mac doesn't have a keyboard to start up in safe mode or if you can't use the Shift key."

Let me know if that changes anything.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.