Jump to content

Recommended Posts

I'm trying to install a namaged client on an old win XP box.

It fails when I try to deploy fromthe management console, saying windows installer 4.0 is missing. Installing windows installer 4.0 doesn't change anything.

I can export an installation package which installs ok but doesn't seem to update from either the MWB server or the internet.

Has anyone had any success with XP and managed clients?

Link to post
Share on other sites

I've never been able to get the cloud to deploy anything to any operating system, XP 7 or 10.

 

For my XP machines I had to get the Windows XP installer off the management console and manually install it on the XP machine. After it installs the .net framework you will need to reboot to get MBEP to start working. You won't have an icon in the system tray but you will see it in the cloud console.

Link to post
Share on other sites
3 minutes ago, djacobson said:

@kev On the client go to C:\Program Files (x86)\Malwarebytes' Managed Client and run the tool CollectClientLog.exe as local admin. Attach the folder it generates.
 

@IT_Guy wrong product.

Did this post just get moved? I don't browse the other forums on here and I swear this was posted under Endpoint Protection.

Link to post
Share on other sites

@IT_Guy I did move it, the OP opened it under the incorrect topic header, which is common because of our naming scheme's redundancy. The keywords in this post are; "management console", "managed client", "export an installation package" and "update from either the MWB server or the internet". These are the on-prem product's pieces and behavior.

Link to post
Share on other sites

@IT_Guy problems with the D&D tool for the cloud product and its deployment attempts are much easier to diagnose, the logging is better and that tool also uses more deployment functions than just Netbios, RPC and WMI.

XP (and other OS) deployment failures on both product versions usually revolves around account permissions due to some lockdown of RPC, WMI and/or DCOM. Even domain admin accounts can fail to have the needed permissions, that is something a lot of folks have trouble with understanding and is just the nature of Windows and its changes since the full admin access of Win 2k and below days.

Some settings that can change these pieces can get really obscure and it can become a major hassle, needle/haystack situation, to go through every single aspect of someone's domain policy to find out what setting it could be, especially when all the major typical ones have been modified in preparation to deploy. It is usually a better practice in that case to temporarily enable the local admin account (if it is not already enabled), give it a password (blank passwords are not accepted), then use that as the credential for pushing over using using domain creds of any kind.

If local admin fails, then you are looking at;

  • a machine with a home consumer free/trial install already in place, preventing the install since it is already "installed". This is more typical for MBMC product deployments since that product version's installer has no ability to perform a cleanup of pre-existing MB installs.
  • a pre-existing infection preventing installation of security programs (not just us, you'll have infections like this targeting many vendors).
  • a broken Windows installation itself, an sfc /scannow can help but sometimes, that's gonna be a reinstall/reimage.
  • a failing hard drive.
  • network level issues with the ports and protocol required.
Link to post
Share on other sites

Yeah our work computer environment is an IT nightmare. I won't go into details for obvious security reasons, but we have multiple OS's, no domain server, inconsistent credentials and permissions etc. etc. Absolutely nothing deploys properly on our network so I wasn't overly surprised this didn't either.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.