Jump to content

Recommended Posts

Recently my purchased version of the latest version of Malware-bytes  will not open.  I have uninstalled and reinstalled to no avail.  I have scanned for viruses with other software but none found.  I have searched forums for a solution but none have worked.  I ran the mb-check program and have attached the resulting zip file.

 

Please advise.

 

 

mb-check-results.zip

Share this post


Link to post
Share on other sites

What happens when you try to open Malwarebytes?

Also can you please try booting into safe mode and check if you can open Malwarebytes?

Share this post


Link to post
Share on other sites

The window will not open.  I did "trick" it into opening while booting by continually clicking on the task bar icon.  The page opened and allowed me to input my registration number.  But after closing that window, I can not open the window again.  Now, as you can see in the image below, it seems I am protected and all is fine.  However if I click on the "Open Malwarebytes" line, no response, and no response if I click on the icon on the desktop.  Which executable actually opens that window?  Or what could be keeping the window from opening?

 

Thanks.

Paul

 

malwarbytes.PNG

Share this post


Link to post
Share on other sites

OK, good news.  I finally got Malwarebytes to open and ran a scan.  It discovered some rootkit problems and other registry problems.  I posted an image of the files found and eliminated successfully. 

malwarbytes2.PNG

Share this post


Link to post
Share on other sites

I'm new to the forum and had the same problem earlier.  mbam.exe would not run. Looking at the task manager,  the tray application was running though.  I found a fix which entailed renaming mbam.exe as "explorer.exe" and this allowed the program to run using the same shortcut. After scanning, I found 5 infections, attached file.  Also Rootkit Fileless.  I quarantined them and deleted.  I believe they are gone.  I suspect that a file I ran by mistake may have caused the problem.  I saw a little popup advising me to run "firefox patch.js".  Unfortunately I did so without thinking.  Is this the known cause of the rootkit infection?  Hope this helps kushp.

I have been very pleased with Malwarebytes generally over the years. 

MBytes scan results 1.PNG

Share this post


Link to post
Share on other sites

Yes, by clicking on the shortcut which still is set to run mbam.exe, Malwarebytes runs and works perfectly.  After renaming mbam.exe to explorer.exe, the shortcut icon does not have the MB logo any more but still runs mbam.exe.  To be sure, I just now did a scan after rebooting my computer, and there are no infections.  Scan log is attached.  Next test will be to see if I am able to rename "explorer.exe" back to to "mbam.exe" and see if that works.  If not, I will uninstall Malwarebytes and reinstall and let you know what happens. 

Malwarebytes scan 11-10-17.txt

The source of information for my renaming of the mbam.exe file is in the following link:  https://www.bleepingcomputer.com/forums/t/267354/for-those-having-trouble-running-malwarebytes-anti-malware/

Note the attached images.  1) The renamed file "explorer.exe" and the shortcut which still points to "mbam.exe".  Apparently, the displayed name is only superficial. 

I'm still getting used to this forum software, so sorry if my post doesn't display properly.

 

5a05c9db39c4b_Renamedmbam.PNG.3e06b0e2a4047458de61ac017209dd7a.PNG5a05c9ed2807f_mbamrename2.PNG.4d1967355ff85815749492a78fca44dc.PNG

 

 

Share this post


Link to post
Share on other sites
8 hours ago, nikhils said:

Hi @Olowkow

So after you cleaned up the infections were you able to open up MB 3.x without any issues?

Forgot to quote your post, sorry.  See my previous post.

Share this post


Link to post
Share on other sites

Update:  I attempted to rename "explorer.exe" back to "mbam.exe" but kept getting notification that I "need administrative permission" to rename.  Incidentally, when initially renaming this file, I was unable to rename it with just any random name such as "xmbam.exe".  It had to be "explorer.exe".  I didn't bother to try renaming it to "wuauclt.exe or winlogon.exe" as suggested in the forum article ( For those having trouble running Malwarebytes Anti-Malware - Am I infected? What do I do? ).

So I uninstalled Malwarebytes from the control panel, ran MB-Clean-3.10.1031, and reinstalled the latest version.  I noticed that MB Clean was unable to remove the renamed file "explorer.exe" from the Malwarebytes directory, so I deleted it manually with no problems. The MB logo is now back to normal on the shortcut. I enabled "Scan for Rootkits" and did a scan.  No infections.  Scan log is below.

Malwarebytes scan.txt

I believe the rootkit infections are gone.  Fingers crossed. Hope this helps the OP with his problem. 

 

P.S. off topic: I have another problem that is just an annoyance.  I keep getting informed that Bitdefender "threatscanner" has a problem every time I reboot.  I deleted the .dmp file in C:\windows\TEMP directory but it keeps coming back.  I've tried some of the "fixes" found on the web, to no avail.  I get the impression it is related to having more than one virus program. I use Webroot also.  I did notice, though, that this error message occurred even after I had uninstalled Malwarebytes.  I may start a thread on this. 

Share this post


Link to post
Share on other sites

Hello @Olowkow

Glad to know that after your scan and quarantine and clean up everything is working fine now.

Please open another topic for the other issue you mentioned.

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.