Jump to content & 32 bit XP

Recommended Posts

Can anyone tell me with a high degree of certainty whether the 11/2/17 release is 100% compatible with XP before I install? I'm currently on 3.1.2, the last version that didn't crash programs on my XP boxes.

Also, can I install over the top? If not, do I just do a standard uninstall or does the version skip require MBAMClean?


Link to post
Share on other sites

You should have no issues running it on your XP box, similar to what 3.1.2 was running.  There was some bug fixes applied to the latest version where protection modules were not starting properly for some folks.

You can simply download the latest version and install right over the top of your existing version.

Download Latest MB3 v3.3.1.2183 CU 1.0.236 ->>RIGHT HERE<<-

Link to post
Share on other sites

I tried your suggestion. It worked for a few hours, until I tried to open a pdf. Now Firefox, Foxit PDF, & Word 2010 are back to the same behaviors as 3.2. (Won't open, taskmanager shows the programs frozen with 0 cpu use & very little memory use).

Also, I tried shutting down MBAM, to see if that would solve it. It didn't, & it also won't start back up. I get a message that it can't connect to the service.

HOPEFULLY, I'll be able to go back to 3.1 without issue.

I really appreciate that MBAM is still supporting XP, & I hope you get this fixed!


Link to post
Share on other sites

In case any MBAM support is up at this hour...........

First I uninstalled 3.3. When installing I got the following error message:

"Unable to register the DLL/OCX: RegSvr32 failed with exit code 0x5"

This has never happened before.

I rebooted. Same result. I ran MBAMCLEAN & rebooted. Folder was still there & same result.

I searched & regsvr32.exe is still in windows. I am logged on as an administrator. Am currently running SFC /scannow.

Not sure if that's even a good idea, but assuming it doesn't fix the issue, where do I go from here?

Again, there were no issues until I uninstalled 3.3.x

The only other thing I can think of is to try a system restore; I'm afraid if I do the machine may hose on boot as the latest restore point would show Mbam 3.1 being on the system.





Edited by moo4x
Link to post
Share on other sites

Another update:

I was able to reinstall v3.3.1.2183 CU 1.0.236; but I still can't reinstall 3.1.

Also the system restore component of Greatis Regrun no longer works; & I think the system no longer sees my user account as an administrator.

All of this started the instant I uninstalled I don't believe it's a Malware issue; my guess is the new version somehow locked parts of the registry.

So right now, I'm either stuck with no Malwarebytes, or if I leave the new version installed, numerous programs don't work.





Edited by moo4x
Link to post
Share on other sites

Let's try and get some logs first so the team can review them and see if they can tell what may be causing your issues....

  1. FIRST: Create and obtain Farbar Recovery Scan Tool (FRST) logs
  2. Download FRST and save it to your desktop
    Note: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
  3. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
  4. Press the "Scan" button
  5. This will product two files in the same location (directory) as FRST: FRST.txt and Addition.txt
    • Leave the log files in the current location, they will be automatically collected by mb-check once you complete the next set of instructions
  6. NEXT: Create and obtain an mb-check log
  7. Download MB-Check and save to your desktop
  8. Double-click to run MB-Check and within a few second the command window will open, press "Enter" to accept the EULA then click "OK"
  9. This will produce one log file on your desktop: mb-check-results.zip
    • This file will include the FRST logs generated from the previous set of instructions
    • Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area


Link to post
Share on other sites

Logs coming up in a moment. I really do believe the issue is the new version.

A couple other pieces of info; I just found around 20 versions of Mbam assistant running in Task Manager.

I also somehow had a lifetime license permanently deactivated last night when I ran Mbam clean. I still have the license info, the program just won't take it. I fortunately had 1 unused lifetime license I purchased & wasn't using, which is what you'll see in the logs; but I would appreciate getting the one I was using reactivated after the rest of this is solved. I think my ideal solution would be if we can find a way for me to go back to 3.1.

Edited by moo4x
Link to post
Share on other sites

Can you please try disabling the Exploit Protection module under Settings -> Protection. Then reboot and see if the issues are resolved.

On another note, the only parts of the registry that MB3 locks are it's own keys when self-protection is enabled, this is to make sure other programs (like malware) don't impact our software

Link to post
Share on other sites

Interesting, can you please grab a memory dump using the instructions below:

  1. Download Procdump.zip from the following URL: https://malwarebytes.box.com/s/7gdfv6it0xsgu1mzbt3dbbyjcg7kguep
  2. Extract the zip file
  3. With malwarebytes_assistant.exe running in Task Manager, run 8 - mbamtray_memory.bat
  4. This should create at least one .dmp file the same folder, if not more
  5. Please zip up these files and either upload them here, or use wetransfer.com to send them to dcollins@malwarebytes.com 
Link to post
Share on other sites

Will do. I was able to run a zip program by turning off self protection, then turning off anti explot. Anti exploit only stayed off for a few seconds, though; it turned itself back on. New file coming asap.

Again, there are obvious compatibility issues between my pc & 3.2 & 3.3. I'd really like to restore 3.1.


Link to post
Share on other sites

While I didn't use safe mode, I mention earlier in the thread that 3.1 won't reinstall AND a lifetime license is no longer recognized as valid. Do I have to do anything special regarding the license? Will safe mode solve the regserv32 problem (which only occurs  going from 3.3 back to 3.1?)

Hopefully I'll have your dmp file in a minute. This is really frustrating; the pc was functioning perfectly until i installed 3.3.

Edited by moo4x
Link to post
Share on other sites

I've got it. Unfortunately, to get Mbam assistant to show up, I had to enable Exploit protection. That aso freezes the command prompt that the dmp software uses. Currently I am unable to turn Exploit protection off. I will keep trying.

I really wish Firefox had not told me that this update was safe for XP (Post 2).

Link to post
Share on other sites

I was finally able to kill Exploit protection. Unfortunately, that also killed all the instances of MBAM Assistant (see screen cap).

Here's what I'd like to do. Can you help me? I need to make sure we DO NOT hose this pc, as I can not recreate all the pulled patches (the machine is 100% patched including this year's 0 day patches).

1. Uninstall 3.3 WITHOUT invalidating my license (Which happened on my last attempt).
2. Reinstall 3.1 (remember the regserv32 problem that happened last time I tried this).
3. Get Mbam to reactivate the now useless lifetime license. It came years ago with a retail box. I have the license & key; unfortunately after I ran Mbam Clean new installs of Mbam now say that license is invalid.

I would be extremely grateful if we can just get a fully working 3.1 reinstalled & without losing any licenses that I have paid for (I'm afraid to try mbam clean again for obvious reasons).



Edited by moo4x
Link to post
Share on other sites

Ok, here's what you want to do:

  1. Open Malwarebytes
  2. Go to Settings -> My Account
  3. Copy your key and save it
  4. Choose Deactivate
  5. Once deactivated, download mb-clean from https://downloads.malwarebytes.com/file/mb_clean
  6. Reboot to Safe Mode
  7. Run mb-clean
  8. Once mb-clean is done and your computer reboots, do not re-install using mb-clean (this will install MB3.3)
  9. Now you can install Malwarebytes 3.1
Link to post
Share on other sites

I followed your instructions exactly. When trying to reinstall I got the message:

"Unable to register the DLL/OCX: RegSVR Failed With Exit Code 0x5"

HOWEVER, I was once again able to install without issue.

All security was turned off during the install attempt.

I am attaching the mbamclean log. My goals are still:

1. Reinstall
2. Recover the ability to activate the license that I didn't know I needed to deactivate a couple days ago.


Link to post
Share on other sites

Do you think a future version will restore MBAE functionality for XP? There is no question that the Anti-Exploit module caused no problems with 3.1; but has been incompatible with XP in both versions since.

That's why I asked before installing the current version. And that's why I am angry & frustrated. I have an awful lot of time into this; & a dead license that I paid for.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.