Jump to content

Jasc Paint Shop Photo Album 2003

Recommended Posts


I've been using Jasc Paint Shop Photo Album since 2003 without any problems. Yesterday evening while working on a new photo file MWB suddenly came up with pop-ups stating pspa was ransom ware and had been quarantined and that I needed to restart my PC. I tried to get out of this as I knew pspa was not ransomware but nothing seemed to work and I had to restart my PC. From then on things went from bad to worse, so bad I ended up uninstalling the program and running CCleaner to remove traces from the registry.

I have reinstalled the program but am unable to install the subsequent pspa patch I have that has always installed previously, through win 98 to win 10 64. Worked fine in Win 10 for about 2+ years. When attempting install the patch it advises the program in not installed or the patch is wrong for the program. The program is installed in the same 'program files (x86)' as it was before so don't understand why the patch cannot find it.

The program now allows me to access my photo files but am unable to save any changes, the 'save' and 'save as' or both greyed out, I can change and rotate photos but not save them. I am not sure what has gone wrong and being a pensioner not too hot on these subjects. I can only guess that somewhere along the screw up a setting has changed. I have checked the security tab of the files and this seems to show full access for all users, but hey guys I am just poking and hoping I stumble across something that might sort it.

14 years without a problem in all incarnations of Windows then MWB comes along and ...............!! This is very annoying as I was working on a set of photos just back from a cruise and pray that the files are not corrupted after the false ransomware error.:(

Hopefully someone will be able to give me some idea as to what may be the problem and more importantly, how to fix it.:D

Thanks for any help.


MWB Log for pspa.txt

Link to post
Share on other sites

  • Staff

Not sure why the hidden folders option would happen as we dont touch it.

This file is whitelisted now so should no longer be detected.

Were you able to get JASC fixed?

A quick google search suggests that maybe its not registered/key entered?


If not you can open a ticket with our helpdesk and they can assist you.



In the future if we quarantine something and you suspect its a false positive, reboot the computer after the file was quarantined.

You  will then be able to restore it from our quarantine and the app should start working again. No need to uninstall the rest of the app.




Link to post
Share on other sites


Not been able to find a fix so far but will keep trying. If all else fails I can always download a different photo album app. PSPA is around 14 years old and it has always installed without the need for registration or had a license key to enter. Those were the days eh?! I'm used to it so didn't want the usual hassle of learning a new program.

Thanks for the tip, I will know for next time, pity I did not know before.


Best regards



Link to post
Share on other sites

Been playing with this for most of the evening, I have a lot of photo folders on my 'I' drive and it seems none of the photos in any of the sub folders can be modified, every one reports that the file cannot be modified as it may be 'read only'. I downloaded and installed the program Faststone Image Viewer and that gave the same result on the same folders.

I copied 'My Pictures' and all sub folders to another drive and tried again. PSPA again had save and save as greyed out but I could modify the photos ( just used rotate to test it out) and after closing the changes remained when the folder was re-opened.

Faststone allowed changes and saving with no problems.

From this I can only assume - rightly or wrongly-  that something went badly wrong when MWB closed off PSPA suddenly and somehow my 'My Pictures' structure got screwed up some how. I had been using it to mod a new set of holiday photos and had been working with PSPA for about half an hour before the ransomware problem.

The only way I can think of sorting it out is to delete 'My Pictures' folder and all sub folders from 'I' then copy them back from the second drive I have just copied them to. If they still have a problem I suppose I could just use the other drive, but that is mainly a back up drive and not used for main files. It would be best to get back to where I was before the problem occurred.

Edited by ajw1100
Link to post
Share on other sites

Thank you for your help. I only hope I get this right.

The folder is on a WD Drive I:

I:\My Pictures

I have downloaded the program above, the result is a text file which I have attached below.

I opened the program within my User folder and clicked 'Scan' the directory shown was 'Windows'

If I get it wrong I will try again.

Yip, I got it wrong...... numpty :(



Edited by ajw1100
Deleting incorrect scan document
Link to post
Share on other sites

  • Staff

ok yeah it must not be recursive down. Permissions look ok so this is most likely a hidden flag issue.

open a command window as admin

link below on how too:



and type the following command at the prompt:

attrib -h I:\My Pictures /s /d

hit enter

then try to use jasc to access the files in that folder you had issues accessing before.



Edited by shadowwar
Link to post
Share on other sites

Somethings not quite right.

Ctrl C'd your text across to Admin Command Prompt:

Showed the following:

Microsoft Windows [Version 10.0.15063]
(c) 2017 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>attrib -h I:\My Pictures /s /d
Parameter format not correct -


PSPA is sort of working, I can access the photos but 'Save' and 'Save as' are still greyed out and I am still unable to update as the update program cannot find the program itself, even though it is installed where it should be and always has been. C:\Program Files (x86)\Jasc Software Inc\Paint Shop Photo Album.

The update program on a separate CD has previously found and updated without any problem.

Edited by ajw1100
Link to post
Share on other sites

That seemed to have been accepted as no error reported. Thanks for the corrected text.

However it has not made any difference to Save or Save As in PSPA they are both still greyed out. I need both so that I can mod a photo and 'Save As' and still keep the original. if it's just a rotate then a quick 'Save' and get on to the next one. I tried on my latest cruise photo folder and one from years ago to see if the problem is only on the folder at the time of the false detection, both folders are having the same save problem.

I use PSPA on this PC, my laptop and my wife's laptop so obviously wish to keep the same program across all, PSPA is not complicated and so easier to use for the wife, I have tried Finestone Image Viewer but that has more knobs and buttons so she will most likely not want to use it.


Where to now?:unsure:

Edited by ajw1100
Link to post
Share on other sites

Will do.

I am in the UK and I assume you are not so time differences come into play, we are on GMT so no idea what our times would be to match yours.

Strange thing is I have been using MWB Premium for around a year and during that time have run PSPA without any intrusion from MWB. Indeed I was using PSPA for around 30 min when MWB jumped in.


I hope there is a simple and straightforward remedy, I am not very knowledgeable with computer sorting, although I did build this PC some time ago. I may, if things get too complicated just forget PSPA and use another photo program. However I do think it's down to the false positive by MWB that has caused this problem so hopefully MWB can fix it.

Link to post
Share on other sites

Here goes:

ticket 2131851

I have kept things simple and given a link to this thread, I hope that that will be sufficient for them. I did select the dropdown regarding ransomware but that linked to me emailing some logs and to do that it took me to a webpage 'GURU' which required me to register, which I thought was odd, surely MWB can sort its own problems out.

I will be quite busy today, my 92 year old Mother-in Law was taken into hospital late last night so our plans for the next few days have gone out the window.

Link to post
Share on other sites

Well, good news and not so good news.

After uninstalling, CCleaning, Reg' cleaning and re-installing I got PSPA up and running again, and seemed to be functioning as before, except the update program could still not find the program. So I continued to work on my cruise folder.

After about 20+ minutes, you guessed it...........

As the snippets below show, MWB killed PSPA in its tracks and again no choice other than a reboot. This time I selected restore! I will see how things go with the program which is now in the excluded list.

Thinking about the two instances of program death, I was doing the same operation.

There were some thumbnails that were shown as 90 degrees out, these needed to be rotated to the right by 90 degrees, early on in the folder there were batches on 3~5 that needed to be rotated, using Ctrl I selected each one then hit Ctrl +R, they then rotated as needed. Then I found a about a dozen or so and selected them all using shift on first and last, then Ctrl +R- exactly as I had last time - I watched as the thumbnails rotated, about half way through MWB Struck as below. It could be coincidence or perhaps MWB thinks repetition of the same command constitutes a ransomware threat? That's not based on any logical reason other than the same problem at roughly the same point. This does not explain why its not occurred during the last year or so or why I can no longer install the update file.



PSPA Quarantined.JPG

Link to post
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.