Jump to content

MB3, LibreOffice on W10 FCU errors

Recommended Posts

I am running MB3 (lifetime license) plus LibreOffice 5.3.6 X64 on a WIn 10 Fall Creators Update X64 machine.
It is a clean installation of the OS and all applications.

When I launch LibreOffice it takes a long time for the program to become accessible, and in the Windows logs I find a bunch of soffice.bin Stopped working errors.

When I deselect LibreOffice in the MB3 Protected Applications windows things work again as they should.

As far as I can tell this behavior is introduced in the Fall Creators Update of this week, before in the spring Creators Update things worked just fine.

I tried to enter a ticket for this bug, but the ticket system does not like the Edge browser and I don't want to install another browser just for reporting this bug.

Please advise,

Best regards,



Edited by hp-mb
Link to post
Share on other sites

Same errors here in the Windows logs (same MB and Windows version as you, LO 5.4.2 x64).

I made an in-place upgrade from 1703 (with an ISO) and did not uninstall MB (just "Quit" on the systray icon) before the upgrade.

Edited by throkr
added infos about MB uninstallation
Link to post
Share on other sites


I upgraded my main PC on Saturday. Same OS, same version of MB and LO as on my machine which produced the error in the opening post.

This time I made an in-place grade using the MS upgrade advisor, did not uninstall nor quit MB before the upgrade (I was not aware yet of a need to do so....).

To my surprise everything worked immediately as advertised, no errors when launching LO, no need to deselect LO from the Protected Applications in MB.

On OS and application level both machines are identical, the hardware and drivers are different.

Beats me......

Link to post
Share on other sites

28 minutes ago, mightaswell said:

Internet Explorer is available under Windows > Accessories of the start menu program list (Win 10) . No need to install.

Thank you for your suggestion.

Just tried to submit a ticket using IE.
Unfortunately I get the same error as when using Edge, the system keeps asking for a valid mail address (which I entered of course).

Hopefully someone from Malwarebytes monitors the forum.....

Link to post
Share on other sites

1 hour ago, dcollins said:

Can you please grab the following logs from both machines (the one having issues and the one not having issues)?

Thank you for chiming in.

Log files from both machines are attached, I guess the file names are self explaining.

Where I said in message #3 of this topic On OS and application level both machines are identical I should have said that the machine having issues has a subset of the applications of the one having no issues. It is a Surface tablet having issues, a full-blown PC having no issues.



Link to post
Share on other sites


I uninstalled and reinstalled MB but this didn't change anything : errors are still listed in the Windows logs.

Additional info : I noticed that this issue happens only once after a reboot /shutdown. After the first launch of LO, the problem doesn't show up again in the same Windows session.  

Requested log files are attached.

Update : even after uninstalling & reinstalling MB and LO, the issue is still present. I also attached a screenshot of the problem listed in the Windows logs.





Windows logs.zip

Edited by throkr
Link to post
Share on other sites

  • 4 weeks later...


Good news to share : out of curiosity, I tested LO again with the preselected settings (soffice.bin) and , see there, it works like a charm ! (MB - 1.0.236 /LO 5.4.3 x64 /Win10 1709 Build 16299.64).

Now, I would like to have your advice : which setting is the best/safest to keep ( preselected on .bin or personal on .exe) ?

Thanks ! :)

Edited by throkr
Link to post
Share on other sites

@throkr I am glad for you that it works now as advertised on your system!

Having the same MB version installed as you have I tried my luck.

Using LO 5.3.6 I still see the same events in the Windows log.

Next I upgraded LO to 5.4.3

That changes something: now I get an error window from LO that it could not start properly or something like that..... :o

Rebooted the system, same thing happened.

But, looking in the Windows log, I see that a different module crashes this time:

Faulting module name: shcore.dll, version: 10.0.16299.15

This DLL failing is new, don't know what the meaning is though.

Oh well, just toggled the soffice.bin switch on MB to OFF again so that things work again.

Obviously there is some other variable involved here, not just the MB and LO versions.


Link to post
Share on other sites

6 hours ago, hp-mb said:

Obviously there is some other variable involved here, not just the MB and LO versions.


Sorry to hear that you're still having problems ...

The mentioned failing DLL (located in the System32, Win SxS and SysWOW64 folders) seems to be directly related to the OS.

Why don't you try my (temporary) approved  workaround described in post #9 ? If this one also works for you, you would have LO at least protected until the staff can help you out.

Additionally, should it work (or not), it would give them even more information about your issue (remember to attach the requested logs). The more indications they have, the better they can help ...;)


At the moment, I'm waiting for their advice ( see post #10). :rolleyes:


Edited by throkr
Link to post
Share on other sites

11 minutes ago, dcollins said:

The recommended default is going to the best setting.

Any chance you can try running Malwarebytes Anti-Exploit standalone and see if the issue goes away? If so, this should be fixed in our next MB3 release

Thanks for your advice, I'll keep the default setting.

As for MBAE standalone, I can test it and report here. I never used this software, so I suppose that I will have to remove MB first, correct ?

Link to post
Share on other sites


Here are my test results  : strictly no problem ! I even ran the MBAE Test.  :P  - see screenshot -  (MBAE / LO 5.4.3 x64 / Win10 1709 Build 16299.64)

By the way, I also have good news for your team concerning another still pending exploit issue. As you were also involved in this discussion, please have a quick look at this topic :



Edited by throkr
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.