Jump to content

WebProtection, Malware Protection, and Ransomware Protection not starting

Recommended Posts

Since Upgrading to Malwarebytes version 3.2 Web Protection, Malware Protection, and Ransomware Protection are not starting at cold starts or computer restarts. Occasionally they all start, but most of the time they do not and none of these protections will start manually. The weird thing is that if I quit Malwarebytes and then restart it all of the protections start just fine. I have made exceptions in Windows Defender for all of the Malwarebytes executables and also for the recommended drivers. I did not have this issue before upgrading to the 3.2 version. I have contacted support and they had me run the MB Clean to uninstall and re-install malwarebytes and send them the file created, but I have not heard back from them and the problem still exists. I'm leaving town on Monday for 9 or 10 days and would like to get this resolved before I leave if possible. I have ran FRST and MB-Check and attached the mb-check-results.zip file and I have also attached the mb-clean-results.txt file from the uninstall and re-install. My Malwarebytes version is, the Component package version is 1.0.212, and the Update package version is 1.0.3002. Any help is appreciated.



Link to post
Share on other sites

Thanks for those logs.... while we wait for staff to review them, why not try a clean reinstall to see if that fixes your issues...

Let's try this first.... (Malwarebytes clean removal tool will backup your license information and then re-enter the license to the new install)

  1. Please follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - Malwarebytes mb-clean tool (NOTE: After uninstalling with the mb-clean tool you will be asked to reboot. Once you reboot it will ask you if you want to re-install Malwarebytes, you can select YES (it will download the latest version) or you can download the latest version manually (currently v3.2.2.2029 CU 1.0.212) to re-install from HERE)
  2. NOTE: More info about the latest Malwarebytes 3.2.2 HERE; MB 3 User Guide ONLINE; MB 3 User Guide PDF; MB 3 FAQ: Malwarebytes 3.0 - Frequently Asked Questions

Please let us know how it goes.

Thank You,


Link to post
Share on other sites

I apologize for the late reply. Thank you for your replies. I have done another uninstall and re-install using the mb-clean tool and the problem of Web Protection, Malware Protection, and Ransomware Protection not starting on computer cold starts or restarts is still happening. This issue does not happen on every cold start or restart, but it does happen the majority of the time. I said in my original post if I quit Malwarebytes and then manually open it all protections are starting, but I'm concerned that I'm not being fully protected. I have attached the mb-clean-results.txt file from this last uninstall and re-install using the mb-clean tool. I did not have this issue with the previous version of Malwarebytes.

Thank you!


Edited by TD351
Link to post
Share on other sites

  • Root Admin

Please open Malwarebytes and go to Settings -> Protection -> click on the "enable self-protection module" and disable it.

Then let me have you run a full disk check.


Please follow the directions below to get into Windows 10 Safe Mode at a Command Prompt

If needed, here is another link with 7 ways to boot into Safe Mode in Windows 10

Please print out these instructions, or view them from another computer.

On the affected computer please log off by right click over the Start button and select Log Off.

Then, at the Login screen press and hold the shift key on the keyboard and click the power button on screen and select Restart. Do not let go of the Shift key until it reboots


After the Restart it will come up with a screen as shown below. Click on the Troubleshoot button.


Then you'll have another menu like below. Click on the Advance options button.


Now click on the Command Prompt button



You should probably see a screen similar to below, getting the command prompt ready.


Select your Account


Type in your Password


Now, type in NOTEPAD and press the Enter key


Click File - Open inside of Notepad to see what drive Windows is on.





Now type in CHKDSK  C: /R  {make sure you use your disk letter, which may be D: or E: etc.}


The disk check should run and look similar to below. From this Safe Mode the drive cannot be locked and should not ask for any reboot. It should just run like shown below.


Please try that and if you have issue, take some pictures with your phone and post them back so we can see what's going on.

Then run the following.

Please Run TFC by OldTimer to clear temporary files:

  • Download TFC from here and save it to your desktop.
  • http://oldtimer.geekstogo.com/TFC.exe
  • Close any open programs and Internet browsers.
  • Double click TFC.exe to run it on XP (for Vista and Windows 7 right click and choose "Run as administrator") and once it opens click on the Start button on the lower left of the program to allow it to begin cleaning.
  • Please be patient as clearing out temp files may take a while.
  • Once it completes you may be prompted to restart your computer, please do so.
  • Once it's finished you may delete TFC.exe from your desktop or save it for later use for the cleaning of temporary files.


Thank you




Link to post
Share on other sites

Hi Ron,

Thanks for the reply. I disabled the self-protection module and ran a custom scan on all hard drives(2 internal and 1 external) and Malwarebytes did not find anything. I also entered safe mode - command prompt and the chkdsk c: /r and it completed with no issues and stated "Windows has scanned the file system and found no problems".  It did have a message "Failed to transfer logged messages to the event log with status 50" which I think is because the C: drive is not mounted for that checkdisk or it might be because I have the swap file size too small for the C: drive. My Windows drive (C:) is a ssd and I have the main swap file on my D: drive. Regardless, I don't really think that is an issue. I did download TFC, but I did not run it because on the download page it states "Please note TFC is not suitable for use on Windows 8.1 or 10" and I'm running Windows 10 Pro 64 bit(I probably should have mentioned that earlier). I did run the Windows Disk Cleanup though. If you know of another program for temp file clearing please let me know. I have rebooted the PC and the issue is still happening. Other than Windows Defender I'm not running any other virus software and I have made exceptions for the two Malwarebytes folders and the drivers as suggested in the forum. I am running the free version of Zone Alarm, but have been using that for quite awhile with no issues with previous Malwarebytes versions.

Link to post
Share on other sites

  • Root Admin

Yes, TFC has not been updated for Windows 8 or 10 - though I've not done any forensic analysis, I have run it on these operating systems and did not notice any obvious issues (though,  yes it's possible).

You can run the built-in Windows cleanup to clean up the system.


Give that a try and let me know if the modules continue to have an issue loading. You could try enabling the "Delay Real-Time Protection when Malwarebytes starts" in the Settings, Protection area and see if that helps too.

let me know




Link to post
Share on other sites

I have set the "Delay Real-Time Protection when Malwarebytes starts" to 30 seconds and the same three real time protections are not starting at cold starts or restarts. Another issue has surfaced as well. Sometimes when I restart the PC Malwarebytes automatically starts a threat scan even though one is not scheduled. I have turned off recover task in the scan schedule settings, so maybe that will take care of that issue. Even though I knew there weren't any issues with my PC other than this issue with Malwarebytes I've ran the checkdisks, full hard drives scans, and multiple clean uninstalls and re-installs to show that the issue is not my PC. This computer is well maintained and is actually a recent clean install of Windows. I also take care of a family members laptop(which is an extremely slow piece of crap) and the Malwarebytes upgrade seems to be working fine on it. Don't get me wrong, my PC is not a high end PC by any means, but it is much better than the laptop that I mentioned and the update to the new version of Malwarebytes is the only issue that I'm having. And I didn't have this issue until this latest update to 3.2.2. I also know that I'm not the only person that is having these kind of issues. I'm leaving town tomorrow early tomorrow afternoon and won't have access to this desktop with the issues for about 10 days and I'm worried the ticket I submitted will be cancelled because I can't work on this issue. Malwarebytes is a great product, but I'm concerned my PC is not being fully protected. This is becoming increasingly frustrating.

Link to post
Share on other sites

Hi Ron,

Thanks for the reply again. I have attached the mb-check-results.zip for your review. I do appreciate your time and help. I wasn't sure if you wanted me to do another mb-clean uninstall, so I didn't run that. I don't feel like it would make a difference, but if you think it's necessary I'll try to do that before I leave tomorrow.


Thanks again,




Link to post
Share on other sites

  • 2 weeks later...

I have received an email about my ticket while I was out of town that suggested that Zone Alarm Free Firewall was causing the issue. Because of this I completely uninstalled Zone Alarm and then restarted the PC. After restart I ran the MB-Clean tool to cleanly uninstall and re-install Malwarebytes again. Everything seemed okay for about a day, so I re-installed Zone Alarm and everything seemed to be working good until today. The problem with one or more real time protections not starting has returned for me.

Nikhil replied earlier that they believe they have identified the issue and that it will be addressed in a future update, but doesn't say what the issue is. Support from submitting a ticket states that Zone Alarm is causing the issue. Which answer is correct? I did not have any issues at all until the update to Malwarebytes 3.2.2 and to me that shows that the issue is with this latest Malwarebytes update.

It's been three weeks now and I still don't know if I'm being fully protected or  not. This is ridiculous.

Link to post
Share on other sites

It will probably be famous last words but I am hoping that I am now fully protected.

To begin with the Realtime Protection kept switching off so I tried delaying it by 15 seconds.  This worked for a while but after a couple of days (and after MB supposed to be fixed) I found other things were being switched off (ransomware for example).  Looking through old threads I found someone who switched on both Enable Self Protection Module and Enable Self Protection Early Start and so far it is stable.  I don't know what MB has done with this 3.2.2 update but it seems that each time they fix a glitch it creates another. I've never had a problem with Zone Alarm.

Link to post
Share on other sites

It's the web protection module and it doesn't happen at every boot or reboot for some reason. I think there was one time that more than one module didn't start, but I can't remember for sure. I will start taking some screenshots when this happens so that I can be sure. Also, as a just in case measure I completely uninstalled Zone Alarm Free Firewall earlier today to see if that makes a difference. I had made exclusions in Zone Alarm for all of the recommended Malwarebytes executables. This had been suggested in one of the emails that I received. They also wanted me to make exclusions for the drivers, but I could not find a way to make exclusions for those. If I look in file explorer I can find those drivers, but when I try to make an exclusion for them inside of Zone Alarm they don't show up. I've been meaning to check out Zone Alarms forums and FAQ's to find out how to make those exclusions, but haven't got around to it yet. Thank you!


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.