Jump to content

Windows 10 updates remove all traces of Malwarebytes


Recommended Posts

Something is (occasionally) removing my Malwarebytes (Program file directory contents, etc.).  I seem to notice this after Windows 10 updates.  I am not sure that is the real problem.  It is a pain to download and reinstall.  I run SuperAntiSpyware and MalwareBytes on my PCs (typically I disable MS security).   Anyone else experience this problem or something similar?

 

Thanks!

Link to post
Share on other sites

Hello and Welcome....

I have not heard this happening to anyone else at the moment... would you be willing to share some logs so we can review them?

Let's try and get some logs first so the team can review them and see if they can tell what may be causing your issues....

  1. FIRST: Create and obtain Farbar Recovery Scan Tool (FRST) logs
  2. Download FRST and save it to your desktop
    NOTE: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
  3. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
  4. Press the "Scan" button
  5. This will product two files in the same location (directory) as FRST: FRST.txt and Addition.txt
    NOTE: These two files will be collected by the MB-Check Tool and added to the zip file for you
  6. NEXT: Create and obtain an mb-check log
  7. Download MB-Check and save to your desktop
  8. Double-click to run MB-Check and within a few second the command window will open, then click "OK"
  9. This will produce one log file on your desktop: mb-check-results.zip
  10. Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area

Thank You,

Firefox

Link to post
Share on other sites
  • Staff

Your current logs show that MB3 is installed. Unfortunately this won't help us figure out what's removing it in the first place. If you see this again, can you please run FRST and mb-check before re-installing Malwarebytes?

Link to post
Share on other sites

It has happened to me as well. It just forced an update two days ago. Today, a bad script from an ad popped up so I was going to run Malwarebytes and yet again it had been removed. I have already reinstalled so I won't be able to log for you.

Edited by boredztiff
Link to post
Share on other sites
  • 2 weeks later...
  • Staff

Thanks @avdeur. Can you please follow the instructions below to gather your windows update logs?

  1. Press Windows Key + R to bring up a run dialog
  2. In the box, type powershell and click Ok
  3. In the blue box that comes up, type Get-WindowsUpdateLog
  4. Once this finishes, it should create a file on your desktop named WindowsUpdate.log, please attach that file to your response (you may have to zip it up first)
Link to post
Share on other sites

Hi Devin, Thanks coming back.Plse find the requested file attached. Also notre that I , since I did the forced update to WIN10 Pro V 17.09 OS 1629919 I have more problems.

Lost my email account (got this restored , this was a PDS location issue) and I have lost the Settings screen for unknown reasons. All in all very unhappy with this upgrade you can imagen. 

Look forwards hearing from you. regards Albert

WindowsUpdate.log

Link to post
Share on other sites
  • 1 month later...

I just reinstalled the original program amd all back to normal again. Assume all this has to do with the Win10 Creators Fall Updat that is causing me a lot of problems (and similar problems with other not yet solved by Microsoft. Regards Albert

Link to post
Share on other sites

I had a similar experience.  I was updating two laptops of family members that are nearly identical.  Both Windows 8.1.  Both have/had Malwarebytes Premium, lifetime license.

Laptop 1, had MB 3.1.2 installed, then updated MS Quality Rollup 2017-10 & 2017-11 & Adobe FlashPlayer Update today, 11/26/17.  Did not update Malicious Software Removal Tool yet, it shows as install failed.  Malwarebytes seems just fine, no issues, opens & scans fine.

Laptop 2, I want to say it failed a Malwarebytes update in the past, and was not up to date yet.  No idea what version it was.  MS Quality Rollup 2017-10 & 2017-11 & Adobe FlashPlayer Update were done on 11/18. Doing updates today and Malwarebytes prompted for an update.  I chose Advanced and it showed a list of what was updated/fixed with the latest release, and the button was something like 'Accept Agreement & Install' or something like that.  Thought that was odd since there was really nothing to 'Agree' to?  After clicking the button, it showed a progress bar, that never really progressed past zero.  After a period of time, the window disappeared.  At that point, I think Malwarebytes was gone completely.  I don't recall having to reboot.  Have not re-installed yet.

6 files attached below, 3 from each machine, as requested.

While it sounds like people are having success re-installing (good news), that will be a pain.  Because I have to find the license code and figure which of 4 went with laptop 2...  I disabled Windows auto update on Laptop 1 for now.

Hope the difference and maybe catching it at the right time helps figure out the problem.

FRST_Laptop 2.txt

Addition_Laptop 2.txt

mb-check-results_Laptop 2.zip

mb-check-results_Laptop 1.zip

Addition_Laptop 1.txt

FRST_Laptop 1.txt

Link to post
Share on other sites
2 minutes ago, GearGuy said:

mb-check-results_Laptop 1.zip

Do this on both laptops.

I would like you to add these files to your Anti-Virus exclusions list as mentioned in this FAQ HERE (my list below includes the exe files as well)
 

  • C:\Program Files\Malwarebytes\Anti-Malware\assistant.exe
  • C:\Program Files\Malwarebytes\Anti-Malware\malwarebytes_assistant.exe
  • C:\Program Files\Malwarebytes\Anti-Malware\mbam.exe
  • C:\Program Files\Malwarebytes\Anti-Malware\MbamPt.exe
  • C:\Program Files\Malwarebytes\Anti-Malware\MBAMService.exe
  • C:\Program Files\Malwarebytes\Anti-Malware\mbamtray.exe
  • C:\Program Files\Malwarebytes\Anti-Malware\MBAMWsc.exe
  • C:\Windows\system32\Drivers\farflt.sys
  • C:\Windows\System32\drivers\mbae64.sys
  • C:\Windows\System32\drivers\mbam.sys
  • C:\Windows\System32\drivers\MBAMChameleon.sys
  • C:\Windows\System32\drivers\MBAMSwissArmy.sys
  • C:\Windows\System32\drivers\mwac.sys

 

Also please exclude the following folders too: (The complete folder)

  • C:\Program Files\Malwarebytes\Anti-Malware
  • C:\ProgramData\Malwarebytes\MBAMService

Also

Let us get a clean install of the current version. 3.3.1

 

We have another tool called MB-Clean which will automate the whole process for you.

 Tool can be found at https://downloads.malwarebytes.com/file/mb_clean

 

1. After downloading the tool run the tool.

2. The tool will automatically clean up the older possibly damaged installation and will ask you for a restart.

3. Restart your system and then the MB-Clean tool will prompt you to re-install the latest product .

4. Click on "Yes" to reinstall MB 3.×.

5. Now you will have the latest product installed. If it does not offer the new install after the reboot you can download and install from here. 

https://downloads.malwarebytes.org/file/mb3

 Please let me know if you are still seeing issues after the latest product install.

Link to post
Share on other sites
49 minutes ago, Porthos said:

Please let me know if you are still seeing issues after the latest product install.

Ok, finished with Laptop 2.  All above exclusions entered.  The MB-Clean apparently could not find anything.  Results attached below.  So it did not prompt to install the new version.

I downloaded and installed.  The install screen was what I saw earlier today.  Looks like I was 'Agreeing' to where the file was being installed.  This time the progress bar actually moved and showed files being installed.  Install was successful and I was amazed to find that Premium was re-established!

So I guess either my antivirus blocked the update or the installer that was pushed to me had an issue?

Laptop 1, added the exclusions.  Will wait and see what the next update brings.  Had to hand it back to the 'owner'.

Thank you VERY MUCH for your help!

mb-clean-results.txt

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.