Jump to content

3.2.2 wiped my premium and installed as free

Recommended Posts

9 minutes ago, wpc09 said:

What do I need to do?

For licensing issues, you'll want to reach out to our online support at 



Usually, support will take 2/3 days or more since support is busier than normal at this time to get to your request.


Link to post
Share on other sites

Another option is to create a Malwarebytes Account using the following link: https://my.malwarebytes.com/en/register

If you have purchased the product through us, you can use the same email to register for the account.

Once you can login into your account you could deactivate on the device where your product was wiped off and reset your license key.

Let me know if that worked.

Link to post
Share on other sites

3 hours ago, wpc09 said:

I had Malwarebytes 3.1.2. I received a notice that a free update to 3.2.2 was available. It installed and overwrote 3.1.2 premium with 3.2.2 free.  It does not accept my activation codes, syaing that I have exceeded activations.

I have had the same issue, at the same time, as you have.  Malwarebytes continues to disappoint me ever since the move from Ver 2.x to 3.x, I have had nothing but one issue after the other. I now no longer recommend to clients, family & friends their products unless they have spare time on their hands to sort out the issues they may encounter. It would appear to me that they no longer conduct alpha and beta testing and just leave it to the end user to report the issues encountered and expect the end user to share their fixes in the community forums.

Anyway, back to our shared issue, I have had to do the follwing:

1) Download the free version (again).

2) Go searching for the original email/invoice from CleverBridge AG (who sold me the product) and locate and re-enter the original id key and licence key to the Subscription Details section in the 'My Account' tab of the Malwarebytes programme.

3) If you are reading this Malwarebytes, please test these upgrades/updates FIRST before releasing them onto the unsuspecting end user. Very disappointing that your processes appear to be getting worse rather than improving the end user experience.

I would like to say it was a pleasure in trying to assist this user, however it would have been unnecessary if you had bothered to check your processes first.


Link to post
Share on other sites

@wpc09... oops , I meant to add a step. There is a MalwareBytes uninstall cleanup programme available which you should run to cleanup the failed install first before trying a fresh installation. I also sometimes do a fresh reboot and run ccleaner to be sure, however on this occasion it was not necessary, although it would have been the next step had my previous process had failed to resolve the problem.


Anyway, that was my experience and my experience and I hope it may assist you.


Regards et tu Brute!

Link to post
Share on other sites

If you looking for help and info on a fresh re-install here it is...

Let's try this first.... (Malwarebytes clean removal tool will backup your license information and then re-enter the license to the new install)

  1. Please follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - Malwarebytes mb-clean tool (NOTE: After uninstalling with the mb-claen tool you will be asked to reboot. Once you reboot it will ask you if you want to re-install Malwarebytes, you can select YES (it will download the latest version) or you can download the latest version manually (currently v3.2.2.2029 CU 1.0.188) to re-install from HERE)
  2. If that does not correct the issue, then please read the following and attach to your next reply the requested logs - Diagnostic Logs (after you run all the tools requested, all the logs will be combined into one log file named: mb-check-results.zip located on your Desktop (which will include the FRST logs inside the zip file))
  3. NOTE: More info about the latest Malwarebytes 3.2.2 HERE; MB 3 User Guide ONLINE; MB 3 User Guide PDF; MB 3 FAQ: Malwarebytes 3.0 - Frequently Asked Questions

Please let us know how it goes.

Thank You,


Link to post
Share on other sites


I replied to this in another thread I just opened. I tried refreshing my free MB and got a Trial Premium. It appears you cannot get free MB - different situation - but after reading this I see V3 is creating problems. I find it interesting that MB takes your $$$ and then says it will be 2/3 days before they can help. Great way to lose business.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.