Jump to content

3.2.2 Protection keeps turning off in Windows 8.1


Recommended Posts

For more than a week now malware protection in Malwarebytes 3.2.2 keeps turning itself off. When I try to change the setting back to On, it says "Starting..." and then after maybe a second or two switches back to Off (please see screenshot below). On at least one occasion, malware protection was on, but scan for rootkits was off, so apparently it's not just the one setting that changes.

image.png.92e9a96569f86f133363d14fdd88a2a0.png

I've set the program to run as admin and that solved the issue for a while, but the malware protection setting has turned itself off multiple times since and I still have to reset it manually. Today I am unable to get it to turn back on. In searching for information about the problem, it appears that other people have had the same problem with earlier versions of the software, so presumably this is a known issue that has not yet been (successfully) addressed. Can someone please explain what is causing this and provide a solution that is permanent so that I don't have to fiddle with the settings every day and worry that my computer was infected while protection was turned off? I make a living with my computer, so it's important that it's protected properly.

If relevant, the version is 3.2.2.2029, premium edition, component package version 1.0.188, update package version is 1.0.2834. My updates are current as of Sept. 18, 10:09 Pacific time. I am running Windows 8.1.

Thank you!

Edited by Orrkid
Grammar
Link to post
Share on other sites

@Orrkid:welcome:

I did not see any mention in your post that you have tried a clean install with the clean install tool.

Let us get a clean install of the current version.

We have another tool called MB-Clean which will automate the whole process for you.

 Tool can be found at https://downloads.malwarebytes.com/file/mb_clean

1. After downloading the tool run the tool.

2. The tool will automatically clean up the older possibly damaged installation and will ask you for a restart.

3. Restart your system and then the MB-Clean tool will prompt you to re-install the latest product.

4. Click on "Yes" to reinstall MB 3.×.

5. Now you will have the latest product installed.

Please let me know if you are still seeing issues after the latest product install.

If that does not fix it please follow the following instructions

Create and obtain Farbar Recovery Scan Tool (FRST) logs

  1. Download FRST and save it to your desktop
    Note: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
  2. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
  3. Press the "Scan" button
  4. This will produce two files in the same location (directory) as FRST: FRST.txt and Addition.txt
    • Leave the log files in the current location, they will be automatically collected by mb-check once you complete the next set of instructions

·  Create and obtain an mb-check log

  1. Download MB-Check and save to your desktop
  2. Double-click to run MB-Check and within a few second the command window will open, press "Enter" to accept the EULA then click "OK" 
  3. This will produce one log file on your desktop: mb-check-results.zip
    • This file will include the FRST logs generated from the previous set of instructions
    • Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area
Link to post
Share on other sites
  • 2 weeks later...
  • Staff

I can see an error, let's try two things please.

Filters:

  1. Download the attached fixlist.txt file and save it to your desktop
  2. Download FRST from https://downloads.malwarebytes.com/file/frst64 and save it to your desktop
  3. Open FRST and click on Fix
  4. It should open a new text document named fixlog.txt on your desktop
  5. Please upload fixlog.txt in your reply

Debug Logging:

  1. Open Malwarebytes
  2. Navigate to Settings -> Application
  3. Turn on the option for "Event Log Data"
  4. Restart your computer
  5. Wait 5 minutes and verify that Malware Protection is still turned off
  6. Run mb-check from https://downloads.malwarebytes.com/file/mb3_check
  7. Upload the zip file it creates in your reply

 

fixlist.txt

Link to post
Share on other sites
  • Staff

According to those logs, everything is running, is that correct? If so, please wait until the error happens and then gather that data. Also, please make sure to follow these instructions to turn on Debug Logging before sending the logs next time

  1. Open Malwarebytes
  2. Navigate to Settings -> Application
  3. Turn on the option for "Event Log Data"
Link to post
Share on other sites
  • Staff

Can you please right click the Malwarebytes icon on the desktop, then choose Properties. Go to the Compatibility tab and uncheck all options, then click ok. Finally reboot and see if it properly shows as on. If not, please try to turn it on, and then run mb-check again and upload the results

Edited by dcollins
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.