Jump to content
Sign in to follow this  
jafea

Unable to install v3, (even after 9 months)

Recommended Posts

So anyway, after running for the last year on v2 since my abortive attempt to install v3 way back here, I decided to give it another go and downloaded 3.2.2.2029 ...

Same problem, fails to install:

2017-09-15 22:37:56.151   Log opened. (Time zone: UTC+10:00)
2017-09-15 22:37:56.151   Setup version: Inno Setup version 5.5.8 (u)
2017-09-15 22:37:56.151   Original Setup EXE: D:\Downloads\mb3-setup-consumer-3.2.2.2029.exe
2017-09-15 22:37:56.151   Setup command line: /SL5="$170EE2,67866746,119296,D:\Downloads\mb3-setup-consumer-3.2.2.2029.exe" /SPAWNWND=$300DC4 /NOTIFYWND=$200EBE 
2017-09-15 22:37:56.151   Windows version: 10.0.15063  (NT platform: Yes)
2017-09-15 22:37:56.151   64-bit Windows: Yes
2017-09-15 22:37:56.151   Processor architecture: x64
2017-09-15 22:37:56.151   User privileges: Administrative
2017-09-15 22:37:56.154   64-bit install mode: Yes
2017-09-15 22:37:58.598   Created temporary directory: K:\Temp\is-3B36G.tmp
2017-09-15 22:37:58.622   Extracting temporary file: K:\Temp\is-3B36G.tmp\suhlpr.dll
2017-09-15 22:37:58.795   InitializeSetup raised an exception (fatal).
2017-09-15 22:37:58.795   Exception message:
2017-09-15 22:37:58.795   Message box (OK):
                          Runtime Error (at 79:120):
                          
                          Could not call proc.
2017-09-15 22:38:46.535   User chose OK.
2017-09-15 22:38:46.535   Deinitializing Setup.
2017-09-15 22:38:46.550   Log closed.

Output of FRST64 attached again ... although it didn't seem to help last time.

2017-09-15 22_38_39.png

FRST.7z

Share this post


Link to post
Share on other sites

@jafea Welcome back.

You are still using a RAMDISK. MB 3 will not install with the temp files located on the ramdisk.  Known issue. Must relocate your temp files back to the default location.

Quote

 (RamDisk) (Fixed) (Total:6 GB) (Free:5.84 GB) exFAT

 

Edited by Porthos

Share this post


Link to post
Share on other sites

Thank you!

I have to wonder why nobody mentioned this in the last thread, I've been running TEMP in a RAM drive for more years than I can remember and I think this is the only program that has balked during install.

 

Thanks again.

Share this post


Link to post
Share on other sites
40 minutes ago, jafea said:

I have to wonder why nobody mentioned this in the last thread

It has been tested and figured out now but with no fix yet.

 

41 minutes ago, jafea said:

I think this is the only program that has balked during install.

Sorry, but it is what it is for now. You can go back to your old setup till the next new full version I believe.

Share this post


Link to post
Share on other sites

MBAM 3.3.1.2183 still has the same problem.

Just as a matter of interest other programs using the same version installer, (eg. DisplayFusion), have no trouble coping with a RAM drive.

Also, someone else who has a RAM drive, ( ImDisk Virtual Disk Driver - same as me), and installed MBAM 3 reported that just redirecting TEMP back to default location didn't work, they had to disable the RAM drive before it would install, (necessitating restarts).

Share this post


Link to post
Share on other sites

Thought I'd update this thread, just installed 3.5.1.2522 and it worked without a hitch.

The problem with installing while having a RAM disk appears to be fixed.

Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.