Jump to content
ChrisV

Background Service is Offline

Recommended Posts

By the way, out of curiosity.... of those of you affected by this issue, how many of you restored your whole system from Time Machine at some point?

Share this post


Link to post
Share on other sites

I have a macbook pro 2012 with ssd with filevault with macOS Sierra 10.12.6
I installed the malwarebytes 3.0 beta for mac and did not have any problems
When the official release was released I uninstalled the beta and installed the official one and I had no problem
When MalwareBytes notified the presence of an update I installed it on the previous version without making any uninstallation and even here no problem.
In the last release the only thing missing is the version of definitions for the rest is all ok.

Share this post


Link to post
Share on other sites

I recently was recommended, by an Apple Support team-member, to download Malwarebytes to solve some of the recent 3rd party pop-ups displaying onto my iMac desktop however,  when I open the Malwarebytes icon, the system states "Background service is offline" and advises me to contact support. Any suggestions on how to resolve this issue?

Share this post


Link to post
Share on other sites
18 hours ago, Pple_of_the_West said:

Any suggestions on how to resolve this issue?

Yes, I posted the solution on August 31, on the first page of this topic. However, I'll add some updated instructions here:

This problem is caused by a system keychain that has been inappropriately restricted at a level that even the system itself can't change it. We're still unsure what causes this, but initial data seems to indicate that migrating data from an older Mac or a Time Machine backup may be a possible cause. This will cause other problems with your system as well, such as an inability to store new wifi passwords.

To fix this problem, restart in recovery mode, by holding down command-R at startup. Once you're in recovery mode, go to the Utilities menu and choose Terminal. See the following screenshot:

59c14b7ea5eb6_openTerminalinrecoverymode.thumb.png.365d1d75ac2860a9757ac224047fb625.png

In the Terminal window that opens, enter the following command. Be sure to enter it precisely as shown.

chflags norestricted /Volumes/*/Library/Keychains/*

Press return to execute the command. If you see an error message saying something like "No such file or directory" or "command not found," you made an error in typing the command. Review these instructions again and be sure you're entering it exactly as shown.

Now restart the computer normally, and Malwarebytes should be working normally.

Share this post


Link to post
Share on other sites

Thank you. I followed the treed instructions from August 31 and Malwarebytes seems to open just fine now.

Per the terminal command, 

ls -alO /Library/Keychains/System.keychain

... the keychain was restricted. 

Booting in recovery mode on mac is Command+Option+R. Choose Terminal from Utilities menu.

Note that you'll have to remember the command or find another clever way to have this command line available.

chflags norestricted "/Volumes/Macintosh HD/Library/Keychains/System.keychain"

Before going into Recovery mode, maybe make a new text file with the command and save it to /Volumes/Macintosh HD/Library/Keychains/System.keychain. You'll have a sporting chance of viewing the file from Terminal using 

cat ./path/to/file.txt

Note that if you have already navigated to the "/Volumes/Macintosh HD/Library/Keychains/System.keychain" directory, no path is needed.

If you have to type the command, pay attention to the path.

To confirm the change of restriction, the command is EL ES space DASH A EL CAP-OH System.keychain

Once again, thank you for the instructions! The fix is likely not for the average Mac user. Maybe nice if there was a script that could recognize the issue and offer to resolve.

Share this post


Link to post
Share on other sites
7 hours ago, wi_pedaler said:

Maybe nice if there was a script that could recognize the issue and offer to resolve.

Because of the need to reboot in recovery mode, any kind of scripted resolution is not possible. However, we are going to release an update soon that no longer relies on the buggy System keychain.

Share this post


Link to post
Share on other sites

Hi

I had the same problem on my Mac 10.12.6, trying open 3.1.1 505 version

"Background service is offline", and my keychain was not restricted..

But i tried open Malwarebytes with the icon in the tool bar menu (up right)

Then i had the idea open Malwarebytes with double click in my application folder

and it works..!

So, i think there is something wrong in the tool bar malwarebytes menu..

Hope it will help..

Edited by jumera

Share this post


Link to post
Share on other sites
On 8/31/2017 at 10:54 AM, treed said:

I think that we may have found the root of the problem, although we're still not sure exactly what caused it.

It looks like folks have their system keychain set to an unusual "restricted" mode, which is related to the System Integrity Protection feature in macOS, and which should NOT be set for the system keychain.

That would be a negative. I've tried this and others with the latest build on 10.13.4 and it's not resolving. The only other issue causing might be the enduser has filevault enabled on the Macbook in question. I tried this as "root" (I know, I know) and still didn't elevate or address this issue. Gatekeeper isn't showing the "allow MW to do xyz", either.

Share this post


Link to post
Share on other sites

We're seeing a small portion of people running the latest version of the software at this time (3.3.22) having this issue. (It's not related to the issues described on this thread previously.) We think we've got the problem tracked down and will be releasing a fix as soon as we can.

Please note that the below advice is highly time-sensitive, and will only apply until a newer release than 3.3.22 is available!

For now, if you're affected, you can downgrade to 3.2 to get real-time protection (RTP) working again. To do that, uninstall 3.3 by opening the Malwarebytes app and choosing Uninstall from the Help menu. Then download & install 3.2 from here:

https://data-cdn.mbamupdates.com/web/mb3_mac/Malwarebytes-Mac-3.2.36.1163.pkg

You'll want to upgrade to 3.3 as soon as a version newer than 3.3.22 is available.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.