Jump to content

Issues on v3.1.2 update


Recommended Posts

Have been using MBAM since v1.75.xx and subsequently v2.2.1.xx.  Have had some issues upgrading to major version but once that's been taken care of, MBAM runs perfectly without issue.

Unfortunately the same cannot be said when updating from 2.2.1.xxx to 3.1.2.xx.  Recently updated the MBAM database when a pop-up message prompted me to update to 3.1.2.xx.  Installation froze towards the end and I had to do a manual shutdown and reboot.

Eventually the update works and does its job accordingly (or so it seems), but there are these issues and bugs:

a. Program takes much longer to launch: double-click icon and it would take 20-30 secs to complete.  Seems that the program has much more stuff to load during startup (as opposed to 2.2.1.xxx);  By contract, v2.2.1.xx starts swiftly, and that the taskbar icon almost always loads first, before the actual program dialog (thus mitigating the following issue);

b. Missing taskbar icon issue: the first few times v3.1.2.xx works without problem, and that the M icon always shows up each time program is started.  But subsequently the M icon is missing and fails to restore, even after system restart   And when this happens, shutting down MBAMservice under Task Manager won't work, as the process is being actively blocked (ie. a big red cross shows up; not the case with 2.2.1.xxx).  In other words, under such circumstances, a system restart is the only option in order to close both MBAM and its underlying service;

c. When closing MBAM from the task bar icon, there's no more confirmation message ("Do you want to quit MBAM" something like that).  Also the taskbar M icon does NOT show any database version any more;

d. Key authentication server (or whatever is called) issue: even though my PC is online (and that the network is not down), v3.1.2 often fails to connect accordingly, resulting in error messages.  During a fresh reinstall of v3.1.2 it took multiple times to activate the license key, prompting messages that the key might be bad (it's actually a genuine key in this case).  This issue has never happened with v2.2.1.xxx.

To summarize, I'm quite disappointed with v3.xx of MBAM (or whatever it's now renamed).  Takes longer to load, and then the infamous missing taskbar icon bug.  IMO for older PCs like mine (7yo desktop running on XP SP3 (x86)) MBAM v3.xx is just not a good idea..

Anyway can someone look into these issues please?

Edited by anon743
Link to post
Share on other sites

Hi @anon743, let me see what I can answer now and then we'll probably need logs to address the other issues:

Long Launch Time

While MB3  does take a little longer than MBAM2 to launch, 20-30 seconds does seem like a lot. I think this issue is actually related to your second issue, which I can address below

Missing Taskbar Icon

When you had MBAM2x installed, did you have self-protection turned on by chance? This is not normally on by default, but is a configurable option and we've seen that cause some issues. Let me know if you had it on, and we can work on getting it resolved.

Close Confirmation

There should be a UAC prompt when you attempt to quit Malwarebytes from the system tray. If you have UAC disabled, you are correct, you will not get a confirmation prompt to close MB3.

No Database Version on the tray

With how often databases are updated, it's more relevant to know if your databases are out of date rather than know the specific version you have. As such, you won't see your database information in the tray unless the database is out of date for some reason. At that point you'll get both a notification, as well as a little arrow on the system tray icon informing you that there's an issue. When you mouseover the tray icon at that point, you'll see another message about the database being out of date

Key Authentication Server

This is an interesting one. So you were unable to activate, but after some tries it finally worked?

For troubleshooting the first two and the last issue, can you please upload the logs mentioned in the thread below? This will give us a better idea of what's going on with your machine:

 

Link to post
Share on other sites

Missing Taskbar Icon: with MBAM 2.xx installed self-protection is NOT turned on

Close Confirmation: with MBAM 2.xx installed there is indeed close confirmation.  Not so with 3.xx

Key Authentication Server: probably intermittent connection problem.  So yes, after a few tries the key gets activated...
Seems like some other users have this problem as well, go check those threads for details

> For troubleshooting the first two and the last issue, can you please upload the logs mentioned in the thread below?
> This will give us a better idea of what's going on with your machine:

Sorry, have completely uninstalled v3.xx and reinstalled v 2.21.xxx
Since then, system was rolled back to a certain restore point (due to other program crashes) which has no reference to v3.xx whatsoever...
Sorry

On separate note, I've set this thread to receive email notifications upon any other replies etc., how come I didn't receive one?

Link to post
Share on other sites

I'm not certain why you aren't getting notifications, perhaps check your spam folder? Without logs, unfortunately there isn't much more we'll be able to troubleshoot unfortunately. If you do end up reinstalling and having issues, uploading the logs would be the next step in troubleshooting.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.