Jump to content

Error 13 mismatch type when trying to install MWB Anti-Malware PREMIUM

Recommended Posts


I am trying to install Malwarbytes ANTI-MALWARE PREMIUM (ver. 2.2.0 151104) from the CD that came with my ASUS computer.

Each time, a couple of second after entering the ID and KEY, I get an Error 13 Mismatch Type alert. Pressing OK exits the installation. No new program appears in program list.

I have cleaned the registry with Auslogics. To no avail.

Any advice would be appreciated.






Link to post
Share on other sites

Hello and Welcome!

Is there any reason you want to install an outdated version 2 instead of the latest version available MB3 v3.1.2?  The steps below will help you install the latest version, then you can activate it with the ID and KEY that you have (works on both versions of Malwarebytes.)

Let's try this first.... (It is recommended that you de-activate your Malwarebytes first before un-installing or using the clean removal tool - the tool can only backup the license info for MB3 so if you have MBAM v1 or v2 you have to de-activate it manually)

  1. Please follow the steps in this pinned topic to uninstall your current version of MBAM and reinstall the latest build - Malwarebytes mb-clean tool (NOTE: After uninstalling with the mb-claen tool you will be asked to reboot. Once you reboot it will ask you if you want to re-install Malwarebytes, you can select YES (it will download the latest version) or you can download the latest version manually (currently v3.1.2.1733 ) to re-install from HERE)
  2. If that does not correct the issue, then please read the following and attach to your next reply the 3 requested logs - Diagnostic Logs (the 3 logs are: mb-check-results.zip, FRST.txt, Addition.txt)
  3. NOTE: More info about the latest Malwarebytes 3.1.2 HERE; MB 3 User Guide ONLINE; MB 3 User Guide PDF; MB 3 FAQ: Malwarebytes 3.0 - Frequently Asked Questions

Please let us know how it goes.

Thank You,


Link to post
Share on other sites


I ran the Clean Tool. Never got the final alert, so assumed no program was ever installed before the Error 13 alert.

I downloaded MB3 and installed it with no Error 13. Ran a scan, which completed.

→ all is fine.

Thanks for your help.



Thanks for your message, but I don't understand you recommending "latest build for MBAM is" when Firefox advises installing latest : Furthermore, your link sends to a download of mbam-setup.exe, which does not show any version number. Problem solved anyway as indicated above.


Link to post
Share on other sites


No worries. I understand my original post may have been confusing. I don't know which acronyms is more appropriate (MB or MBAM). To me, it's all Malwarebytes Anti-Malware and I am happy to use the latest version, which I understand belongs to the MB species.

I still find it useful to have the name of the version included in the installer exe name though, for future reference and being able to keep different versions.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.