Jump to content

Protection keeps turning off... V3.1.2


Recommended Posts

  • Replies 703
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Posted Images

46 minutes ago, Plo83 said:

Hi ParrotSteve

I just checked haveibeenpwned with the email address associated with my malwarebytes premium and there is no issue there.  Do you have an antivirus?  Run a scan.  If you're not satisfied, check online.  You can do a free scan from a reputable antivirus like kaspersky or Bitdefender or microtend, etc...

It was longer ago than I remembered offhand. And, yes, I do have other protection: full versions of SUPERAntiSpyware, NIS and Zemana Anti-Logger. The only hassle is having to configure Norton to ignore the SAS and MBAM folders so that they don't conflict. You couldn't do that long ago, but Windows has improved in some ways. Also, every few weeks, I run a scan with the Sophos free tool, and, being ultra-paranoid, I do also occasionally take advantage of Trend Micro's free online system scan.

MBAM exploit pwnd site cropped.png

Edited by ParrotSlave
explanation; grammar
Link to post
Share on other sites

39 minutes ago, Plo83 said:

Hey Patham.  I just realized that MWB does NOT do phone support so whoever you called was a scam.  Glad you hung up.  For now, look a few posts above yours.  DUUUDE has posted a temporary solution until this is fixed.  It should give you a working version from May.

THIS IS NOT MY WORK CREDIT TO DUUUDE

 

OLLOWS:

dl latest MBAM https://de.malwarebytes.com/mwb-download/thankyou/

optionally these definitions (mbam-rules.exe from the archive is for mbam3 / mbam2-rules.exe is for mbam2) from one day later than the latest MBAM download: https://data-cdn.mbamupdates.com/v1/tools/mbam-rules/data/mbam-r 

cut internet

install

go to: Settings > And turn off automatic updates in the leftwise settings tab

reconnect to internet and check official post linked above.

You will have a working MBAM 3.0 from May 10th/11th 2017. When they have fixed it you can just turn auto updates on again

Haha, don't know where you got that but I never called anyone. Was simply stating that the chances of me upgrading to a paid version was disabled. You know, because of the problems today. :)

So now it appears these problems have been addressed and fixed. Kudos to them and now the chances of me upgrading to paid have been re-enabled. :)

Btw, I'm running this trial version on three Windows 10 PC's. On one of them the trial has reset and shows 13 days left. On the other two it shows 7 days left. :wub:

Link to post
Share on other sites

Problem solved. The was a major cock up with the update some 8 hours ago. Can be seen in C:\ProgramData\Malwarebytes\MBAMService\dbupdate.log file. Clearly states: 

Deflating DB files in staging area ...
Copying updated DB files.
Copying updated DLL files.
CopyDLLFiles - error: MBAMCore.dll : 32
Successfully scheduled file for copy on reboot
Calling FinishUpdate.
Error: MBAMShim FinishUpdate failed

Did reboot once, didn't help. Maybe watch this first the next time it happens. Before you started to uninstall, clean and reinstalled it again. Wasted time.

And MB? This update was poorly tested. The behavior was similar in January 2017. Anyway this thread exploded in hours. There is no way suddenly all programs failed at once on the same time. A faulty update is more likely. Glad that's solved though within a reasonable number of hours.

Link to post
Share on other sites

I was able to scan with MB so was hopeful that web protection for my W10 64 bit PC would work. It didnt. Bebooted after scan and now cant get MB to start. Went to MB website and DL'd the removal tool. Now that process is stuck. Glad I'm retired, have lots of time to troubleshoot MB.

Kind of a pain in the ...

Link to post
Share on other sites

17 minutes ago, Skwarkman said:

Yup : Back and happy.  : Just spare a thought for the bod who woke up to the day from hell - we have all (those coders amongst us) been there, and if it was not malicious or gross negligence then it is "stuff that happens" : I don't care if you are MS or a one person band Indy -  it happens... you try to prevent it .. but stuff happens.

Absolutely.  Trying to code against somebody trying to break your code has to be a pain.  And then "stuff that happens" takes over.  Thanks for resolving this as quickly as you did. 

Link to post
Share on other sites

2 minutes ago, Canuckchick said:

Same problem here, Web Protection turned off and when trying to turn it on, it just keeps saying starting and will not turn on.

To get things working normally again simply open Malwarebytes and click on "Current" next to where it says Updates in the Dashboard and it should download and install working databases.  If it is able to successfully update but protection still is not working, then please try right-clicking the Malwarebytes tray icon next to your system clock and select Quit Malwarebytes and then open Malwarebytes once again from your START>Programs menu or from the shortcut located on your Desktop.

If the issue persists, then please try restarting your PC.

If you have any further issues, please create a new topic and one of our team members will assist you.

Thank you again for all your patience, we really appreciate it and thank you for using Malwarebytes.

 

Edited by Porthos
Link to post
Share on other sites

Just now, Fish2161 said:

I am having the same problem.  In addition, when I try to run a scan it cancels and doesn't scan any files.  Any suggestions

Press manually on the Current button next to the Update line. will search for a new update. (Dashboard screen) Otherwise it will wait for the next update cycle.

Link to post
Share on other sites

1 minute ago, Porthos said:

To get things working normally again simply open Malwarebytes and click on "Current" next to where it says Updates in the Dashboard and it should download and install working databases.  If it is able to successfully update but protection still is not working, then please try right-clicking the Malwarebytes tray icon next to your system clock and select Quit Malwarebytes and then open Malwarebytes once again from your START>Programs menu or from the shortcut located on your Desktop.

If the issue persists, then please try restarting your PC.

If you have any further issues, please create a new topic and one of our team members will assist you.

Thank you again for all your patience, we really appreciate it and thank you for using Malwarebytes.

 

Thanks for your reply.  I have done the first paragraph and it came back on, but then it went off again after about a minute.  Updates are current. I will reboot and see what happens in a minute.

 

Link to post
Share on other sites

Just now, Canuckchick said:

I have done the first paragraph and it came back on, but then it went off again after about a minute.  Updates are current. I will reboot and see what happens in a minute.

If it does not work start a new topic and get us the following logs. 

  • Create and obtain an mb-check log
    1. Download MB-Check and save to your desktop
    2. Double-click to run MB-Check and within a few second the command window will open, then click "OK" 
    3. This will produce one log file on your desktop: mb-check-results.zip
      • Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area
  • Create and obtain Farbar Recovery Scan Tool (FRST) logs
    1. Download FRST and save it to your desktop
      Note: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
    2. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
    3. Press the "Scan" button
    4. This will product two files in the same location (directory) as FRST: FRST.txt and Addition.txt
      • Attach both of these logs to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the files to the attachment area

 

Link to post
Share on other sites

Same problem here, although (for the moment) Web Protection is on an running.  Using MalwareBytes 3.0.6.1469, Component Package 1.0.103, Update package version 1.0.1976.  Restart didn't solve problem which began this morning.  Honestly, I'm not sure why Web Protection finally stayed "On" - most of this morning it was stuck on "Starting".

mb-check-results.zip

FRST_19-05-2017 09.01.45.txt

Addition_19-05-2017 09.01.45.txt

Link to post
Share on other sites

3 minutes ago, CTauthor said:

Same problem here, although (for the moment) Web Protection is on an running.  Using MalwareBytes 3.0.6.1469, Component Package 1.0.103, Update package version 1.0.1976.  Restart didn't solve problem which began this morning.  Honestly, I'm not sure why Web Protection finally stayed "On" - most of this morning it was stuck on "Starting".

mb-check-results.zip

FRST_19-05-2017 09.01.45.txt

Addition_19-05-2017 09.01.45.txt

Cause? A faulty update this morning. Fixed now so don't worry.

Link to post
Share on other sites

7 minutes ago, CTauthor said:

Same problem here, although (for the moment) Web Protection is on an running.  Using MalwareBytes 3.0.6.1469, Component Package 1.0.103, Update package version 1.0.1976.  Restart didn't solve problem which began this morning.  Honestly, I'm not sure why Web Protection finally stayed "On" - most of this morning it was stuck on "Starting".

mb-check-results.zip

FRST_19-05-2017 09.01.45.txt

Addition_19-05-2017 09.01.45.txt

You are running an outdated version of MBAM update to 3.1.2 then it will work. https://www.malwarebytes.com/mwb-download/thankyou/

Link to post
Share on other sites

15 minutes ago, Porthos said:

If it does not work start a new topic and get us the following logs. 

  • Create and obtain an mb-check log
    1. Download MB-Check and save to your desktop
    2. Double-click to run MB-Check and within a few second the command window will open, then click "OK" 
    3. This will produce one log file on your desktop: mb-check-results.zip
      • Attach this file to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the file to the attachment area
  • Create and obtain Farbar Recovery Scan Tool (FRST) logs
    1. Download FRST and save it to your desktop
      Note: You need to run the version compatible with your system. You can check here if you're not sure if your computer is 32-bit or 64-bit
    2. Double-click to run FRST and when the tool opens click "Yes" to the disclaimer
    3. Press the "Scan" button
    4. This will product two files in the same location (directory) as FRST: FRST.txt and Addition.txt
      • Attach both of these logs to your forum post by clicking on the "Drag files here to attach, or choose files..." or simply drag the files to the attachment area

 

A reboot seems to have fixed the problem. Thanks

Link to post
Share on other sites

Malware bytes updates, stages the DB files, inflates DB files, applies delta updates, deflates and copies updated DB files, then fails to finish the update.

Quote

05/19/17    " 12:40:47.250"    397031    0e94    1538    ERROR    RuleParser    RuleParser::ParseThreatFile    "RuleParser.cpp"    96    "Cannot parse threat records. Unknown file version: 0."

stuff happens I guess, we're only human and we do make mistakes at times, no hard feelings.
Result: empty DBs and failing MBAMCore. MalwareBytes pretty much broken.

Lesson learned? A faulty update not fully checked before various changes are being being applied, resulting in not being able to internally revert and undo the damage done by said update.

I was patiently awaiting a fix, while checking the forums here. PATIENCE being key here, instead of making myself more vulnerable searching the web for solutions, fixes or alternatives (possibly shady).

 

Thanks for getting this issue fixed reasonably quick, truly appreciated.

Edited by DevilinPixy
Link to post
Share on other sites

6 minutes ago, GeorgeG said:

To "trusted adviser" Porthos: You must be joking, do I do all this on a new moon or a full moon?

Malware bytes customer service, Please prepare a new update and get out of the Malware BITES territory.

 

 

What are you referring to?

A new update was pushed out to correct today's issue. 

To get things working normally again simply open Malwarebytes and click on "Current" next to where it says Updates in the Dashboard and it should download and install working databases.  If it is able to successfully update but protection still is not working, then please try right-clicking the Malwarebytes tray icon next to your system clock and select Quit Malwarebytes and then open Malwarebytes once again from your START>Programs menu or from the shortcut located on your Desktop.

If the issue persists, then please try restarting your PC.

If you have any further issues, please create a new topic and one of our team members will assist you.

 

Link to post
Share on other sites

  • bdubrow locked and pinned this topic
  • bdubrow unpinned this topic
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.