Jump to content

Multiple Problems with Version 3

Recommended Posts

Windows 7 64 Pro SP1
Malwarebytes version Premium
Component Package 1.0.96


I've been having issues with the version 3 update. I'm sure some of these have been addressed elsewhere, so please point me in the right direction. I have searched, but there are many problems here and I don't know where to start. In no particular order:

  1. The system tray app occasionally fails to load on boot up (I'm waiting for it to happen again to get a screen grab for the error number).
  2. On boot up, usually one protection or other is off (it's not consistent which one). I try to start it manually but can't. Needs a reboot.
  3. I can't change any settings. They are not greyed out, but when I make a change it doesn't 'stick'; it reverts to the original value. I am an Administrator of this machine. Re-starting the front end as Adminstrator makes no difference.
  4. Malwarebytes seems to scan every time I start the machine, even though I don't have a scan schedule specified (and can't specify one anyway - see 3).
  5. My system has certainly slowed down overall since version 3 was installed.

In terms of other software, yes I am running MSE. I also run a Comodo firewall that recently updated itself to version 10, but the Malwarebytes problems began before that "upgrade".

Since version 3 was installed MSE detects something "mailicious or unwanted" during a scan, but shows nothing at the end of it.

Also SpyBot Anti-Beacon has configured policies to maximise my privacy and CryptoPrevent has been run at default settings. I don't think either runs as a background process.

I'd be grateful for any help. Normally I'd wait for a new version to solve my problems, but Malwarebytes is a primary defence and this version is unusable.

I attach the reqested files.






Link to post
Share on other sites

Hello @anotheralanc and :welcome:

Thank you kindly for the attached diagnostic files.  Please delete any/all possible prior Malwarebytes 3.0 setup executables.

As the system in question seemingly has reported a file issue via the MB-CheckResult.txt file, please follow @Firefox's procedure at https://forums.malwarebytes.com/topic/199081-real-time-protection-web-protection/?do=findComment&comment=1115645 to clean-install the release version.

Upon completion, please update with your results.  Thank you.

Link to post
Share on other sites

Thanks for your prompt reply and advice.

I deactivated my license, ran 'mb-clean' and rebooted, as suggested. I attach the log file. The paths it could not delete were in fact removed, I presume after the reboot.

I installed the latest version from the link, reactivated my license, turned on real-time protection, updated and scanned, all without problem.

Given that most of my issues show on booting, I did a hard reboot five times and watched the behaviour of the new Malwarebytes installation carefully. Here is what happened in the context of my 5 original issues:

  1. The system tray app loaded OK. This was an intermittent problem anyway and if it happens again I'll post a screen shot. It may be fixed.
  2. All real-time protections loaded on boot up, although a warning symbol appeared on the tray icon for a short time then disappeared during two boot-ups.
  3. I still can't change settings. More details below.
  4. The program no longer tries to scan on boot-up.
  5. I get the impression the system is less sluggish now, but no metrics to prove it unfortunately.

WRT settings, I tried changing 'Automatically download and install application component updates' and 'Anonymously help fight malware'. I didn't want to mess with
the protection settings in case I inadvertently turned them off permanently. If I change a setting, move to 'Dashboard' and back to 'Settings', my change
persists. If I change tab or close and reopen the program, my change has always reverted.

Interestingly I can add a new 'Scan Schedule', but I can't activate it!

Bottom line - the real time protection activation (2), tray app loading (1) and compulsive scanning (4) might well be fixed. The settings issue is not. It's not a
show stopper as the enforced configuration leaves me protected, but I do need a fix for this.

Thanks again,


Link to post
Share on other sites


The 'Settings' problem appears to be a UI event handling issue, at least partly. I had been sliding the, well, sliders. It seems that only updates the screen and doesn't store the change. But if I click once on a slider, it slides across and the change is stored.

That doesn't help activate a 'Scan Schedule' though. In that case it's a check box that doesn't store its status.

Link to post
Share on other sites

Hello @anotheralanc:

If an entry exists in MB3's Scan Schedule, then that entry will be executed when its time comes due.  What you may perceive as activation request box is a check-box, on the far left of the entry, for merely pre-selecting for editing/deleting only.

When a toggle switch is moved, right or left, unseen operations are taking place that may take a few moments to complete.

You may wish to consult the Malwarebytes 3.0 User Guide for additional information.

Thank you.

Edited by 1PW
Link to post
Share on other sites


Thanks for the clarification re the Scan Schedule.

However, the toggle action is a consistent problem on this machine. Those 'unseen operations' are not taking place when I move (slide, drag) a toggle. It doesn't matter how long I wait, the new settings value is not stored and the toggle is seen in its original position the next time it is visible. To absolutely nail this down  - it is impossible for me to change a setting's value by moving a toggle.

By contrast if I click on a toggle, the result is exactly what I expect (and what you describe). When that settings tab is visible again, the toggle is in the new position and presumably the setting has changed. The difference is unambiguous.

I can upload a screen video of this behaviour if I'm still not making myself clear.

However, since I have a workaround (the click) for the toggles and you have dealt with my confusion re the scan schedules, I can run the program and I am happy.

Thanks again for your help. Much appreciated.



Link to post
Share on other sites

Hello @anotheralanc:

If the above clean install procedure has not produced a perfectly functioning MB3 application, please use the complete reporting instructions within Having problems using Malwarebytes? Please follow these steps and then you may append this topic with your documentation/data.

Thank you.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.