Jump to content

Can't Enable Self Protection (and some other things)

Recommended Posts

Ok so I have a bit of a small story to tell. I have been using Malwarebytes for nearly a year now and I was extremely satisfied with the product. That was until 3.0 came out. I get a notification saying there is a product update and I of course update to the supposedly better 3.0 version, but upon installation I am faced with a series of bugs. The first one being that upon every reboot I would have to re-enter my product key (which led to having to contact customer support to unlock the key after reactivating it so many times). The next bug was that Real Time protection kept randomly getting disabled and always was disabled upon reboot. Lastly it kept thinking it was still in the previous version and kept trying to reinstall itself and notifying me about it but couldn't because it was protecting itself from itself (since it thought it was an external program) and everything. Even the remover tool. I ended up having to boot into safe mode and manually uninstalling, then switching to a 2.x version that worked from an old installer and then leaving Malwarebytes 3.0 to update and mature for a while in hopes of it eventually working. So I decided about a month a month later to reinstall 3.0 and it actually worked. I got everything set up and working and no problems at all. Except one thing which is why I am here. (probably could have left the above out but it may help in troubleshooting since I really don't know if I 100% got the first install of 3.0 off my system) Now that the rambling is done here is the problem:


Ok so the problem--as stated in the title--is that I can't enable the built in Self Protection Module. I noticed this in the settings here recently and tried to enable it and when I click on it nothing happens. It doesn't try to or anything. Its like the slider is a static image. Also the "Enable Self Protection on Early Start" says "Unavailable." I think its probably just because the protection isn't enabled in the first place or maybe not. Anyways I remember seeing this before and when I tried enabling it Malwarebytes froze and became unresponsive. I think oh great another bug. So I restart Malwarebytes and it seems to have actually enabled. I leave it be not looking at it for a while then I notice it not enabled again. If anyone needs logs or anything just tell me how to get them and I will post them here.


Any help would be greatly appreciated!

Link to post
Share on other sites

EDIT SINCE IT WONT LET ME EDIT THE ORIGINAL POST: After playing around with Malwarebytes and just trying to do something like restart it I get the same bug as the first round if installations (minus the disabling of real time protection). After I reboot the whole thing works again (minus the self protection module). Also to restart the program I have to launch it as administrator (should be running as admin automatically though, right?) or else I get the "Cannot connect to service" error message which I also encountered before in the first install, but when I do that it launches, disables everything like malware protection and anti-exploit. All of that. Then after a few seconds it drops my product key and then I'm stuck with that until I restart my computer.

I would also like to say I did lots of things to troubleshoot the first installation and even contacted customer support for help but got me nowhere so I decided to go back to the latest 2.x version. I say first installation but it was actually about 4 different installations... anyways I just wanted to clear that up

At this point I am thinking of going back to a 2.x version since all of these bugs really make me question if Malwarebytes is protecting my computer at all. (not going actually going to test it... since you know... don't want to actually get infected if something goes wrong)

As always any help would be greatly appreciated!

Link to post
Share on other sites

Hello @InvalidProfile

Our latest MB 3.0.6 CU4 version has fixed most of the issues, including some of the protection modules getting disabled.

I would recommend trying this latest build first and activating with your key.

If you still continue to experience issues we can certainly work on getting logs and troubleshooting the problem.

Please check the following post for more details on our latest MB 3.0.6 build.

Thank you, 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.