Jump to content

MWB blocking static DNS

Recommended Posts

I have my DNS manually set to Google DNS ( and Sometime in the last three weeks, MWB decided it suddenly wasn't going to let it work anymore. If I set my DNS to automatically get a server from the router (, I could browse just fine. As soon as I set it back to Google, I wouldn't be able to look up any IPs again. I could ping all day long with no problem, but browsing in Chrome was impossible. I tried other public DNS servers all with the same result. On a hunch I set the Google DNS servers as exclusions in MWB and boom, I'm browsing like a champ again.

What up with that? MWB never even threw an exclusion popup, it apparently just randomly decided to silently block Google DNS.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.