Jump to content

Premium version won't activate


Recommended Posts

I've been struggling with this for a few days and it is frustrating. 3.0 worked fine for some time with a Business Product Key. Something has changed in the product. I am have trouble on multiple machines in different environments. I have deactivated, removed, rebooted clean uninstalled and reinstalled with no luck. Disabled my Firewall and removed AV. Then I tried simply deactivating the product and updates work fine. It seems to me like the Business key is what is killing it. I have a consumer key I will try to see if the results are different.

Link to post
Share on other sites

  • Root Admin

Hello @PaulO

I'm sorry, but our stance would be for you to remove the Malwarebytes 3 and install the business 1.8 version you're licensed for. I don't have an exact date but I know they are actively working to get the 3.x version ready for business accounts in the near future.

Thank you

Ron

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.