Jump to content

Bizarre Windows Issue - Help Needed

Recommended Posts

This is a long explanation, but hear me out.

Windows 10 is giving me ridiculous problems. [i.e. For months, my IPv6 failed to work (and that caused a lot of issues), but that mysteriously fixed itself. Still don't know why that happened or even what fixed it.]

But that's not the issue at hand. I'm dealing with what is some bizarre form of a memory leak. What exactly do I mean? Well, here's the story behind it. (Don't worry, I'll have a tl;dr summary.)

A little over a year ago (Feb 19 or earlier), I was on my two-month-old Windows 10 Lenovo laptop. (Later it will be important to know that it is a Flex, which like the Yoga, has a tablet mode - with auto-rotation.) I was having insane lag issues, and eventually realized that under CPU on the Performance tab of Task Manager, I had a lot of threads running (not logical threads [just 4 of those], I mean like threads running inside of processes). How many is a lot? Well, only about 60,833 of them. I'm pretty sure that was the exact number. I discovered that one svchost.exe was responsible for 60k of them - so most of them. The computer went into a frozen state (it had been doing that for a while), but this time I had to just hold the power button down and boot it back up.

Fast forward a year and a month, and here's what I've learned so far. Upon booting, the threads that that process is running will rise at a rate of about 1 thread per second. If I restart Sensor Service (one of the services under that svchost), the number stops climbing. It can start again randomly, but it's usually when booted or opened from sleep mode. Thanks to SysInternals' Process Explorer, I can see the individual threads, and Sensor Service seems to form large quantities of threads that are then put in the suspended/wait state. I can kill them individually (or resume them and just let them either crash or end, not sure which), but if there are 100+, it's not exactly feasible from there. I don't know why this "thread leak" happens. I've tried reconfiguring the startup type of that service, and have recently isolated it in its own process so that I can kill it without interfering with other services. I've looked at the registry keys for it, I've tried everything I can think of, and I have yet to find what exactly is broken (I need deeper than just "SensorService.dll"), how it is broken, or what I can do about it. I also have yet to find any forum post anywhere detailing any issue that seems to be a similar case. I just thought I'd put out a help request, because after a year (and a major OS update!), it's still driving me crazy.

TL;DR: SensorService.dll is creating a ton of threads, and I have no clue why after a year of finding more details about it. Although, my recent discovery of SysInternals has helped me a lot.

If you need some kind of log, 1. I will do that later because I'm on a Chromebook at the moment and about to go to sleep; 2. please don't ask me to use a sketchy-looking program. I'm a bit hesitant to trust many of those single-purpose generic-log-making programs, and this may be the one time I decide to trust Norton if it puts a file in quarantine (even though it's tried to quarantine all kinds of widely-trusted programs).

Any help would be greatly appreciated. It just dawned on me today that this started plaguing me over a year ago. I find game-crashing glitches in all kinds of software, and it seems that Windows 10 is no exception.



Technical specifications of the laptop in question:
Lenovo Flex 3-1580
Intel Pentium 4405U (2 cores, 2 logical threads per core, 2.1 Ghz, no turbo capability)
Intel Graphics 510 (Integrated graphics)
4 GB RAM (DDR3, Form-factor SODIMM at 1600 Mhz)
Other unimportant details: (500 GB HDD, 2x USB 3.0, 1x USB 2.0, 1x HDMI, 1x 3.5mm auxiliary, 1x SD/SDHC/SDXC card reader, Bluetooth {4.0?}, Qualcomm Atheros Wi-fi 802.11ac {probably 1x1, only goes to around 40 Mb/s on 802.11n}, 1x Gigabit Ethernet Port, 1x Kensington Lock, 1366x768 10-input capacitive touch screen, keyboard backlighting, Alps-something-or-other 5-touch trackpad)

These are from memory and may not be 100% accurate.
Is it bad that I know my laptop's specs in that much detail?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.