Jump to content

Malwarebytes does not find updates ?

Recommended Posts

I have previously had Malwarebytes 3.0.5 installed and working !!! :)

I have received a software update that has upgraded the software to

Once upgraded the Dashboard states that the 'Updates are not current'.

No matter how many times I try to update, no updates are found.

On Version, I was on 'Component Package 1.0.75' and 'Update Package 1.0.1535'

I am now on at Version 'Component Package 1.0.75' and 'Update Package 1.0.1394'

Should i be getting the updates ?

How do I fix this ?




Edited by PhoneNumberZero
Missed Screen Cap
Link to post
Share on other sites

Here are my Logs. [To assist problem solving efforts]

Clearly shows Ver 3.0.5 working and downloading the update to 'Component Package' and 'Update Package'

When the update to 3.0.6 is downloaded and installed, then future updates fail. !!!


"SDK/Controller package is downloaded and installed by ver

"DB/ClsEng package is downloaded and installed by ver

Line 679 onwards: ===> 920    "A New version (3.0.6) of pkg [mbam-c.installer.consumer] (FULL) is available" & downloaded.

Line 884                : ===> 322    "General Error - HTTP POST failed"

Line 885                : ===> 1304    "Exception details: msg=Permission denied, name=I/O error, what=I/O error, cls=class Poco::IOException"

Line 886                : ===> 704    "Received a [-10] response from Keystone. This isn't one of the expected httpStatus returns."


Link to post
Share on other sites

I had a similar problem, where the updates were not being checked and downloaded automatically, even though I had check and download automatically selected in settings. Even after e-mailing, all they could say was uninstall the present version, reinstall the latest version and update. Well I did this and it lasted two days, before reverting to what had happened previously.

However, things went from bad to worse a day later, when I got the BSOD issue with version 3, which is all over this forum, but that's another story.

Apparently they are working to fix a number off issues with version 3, however, I am now back to version 2, waiting for a corrected version 3, with all the issues corrected to be released.

Link to post
Share on other sites

Thanks Bomberh, I know what you mean :)

I had reverted to Version 2 when 3.0.4 had problems.

I then tried 3.0.5 that eventually installed with UPDATES working !!!

[Although i think the problem may have been the updates are not 'pushed' en mass but in batches ???]

I will be patient and see where this goes ......... I can always go back to Version 2 until Ver 3 evolves :)

Link to post
Share on other sites

:welcome:  Phonenumberzero,


Let's please make some adjustments for the startup settings of Malwabytes
Inside of *Malwarebytes* under *Settings* -> *Protection*,
scroll down to Startup Options   ( see image snapshot below)
Start Malwarebytes at Windows startup  should be on by default.

Be sure that *Delay* Real-time Protection is set to OFF ( 1) & lets have it OFF

Look at Enable *self-protection module* (2)  and lets have it OFF

When all done, close Malwarebytes.
Please use the Windows Start menu and do a Restart.
Perhaps if this is on Windows 10, you should do a Restart >> Shutdown  ( then wait a minute)  & then power back ON & startup Windows.

Have patience on the next round as Windows loads up.


If that does not help the issue, then please read the following link   and attach to your next reply the 4 requested logs - Diagnostic Logs (the 4 logs are: mbam logs zipped, FRST.txt, Addition.txt and mb-checkResult.txt)

Link to post
Share on other sites


Thanks for the advice. Sorry for not mentioning the OS type/version.

FYI: It is in the MBAMSERVICE.LOG, the 'Service controller Initalisation' messages list the found OS/Ver.

198    "Service Controller starting controller initialization"
199    "Product code MBAM-C"
202    "OS Version Windows 7 Service Pack 1"

I tried what you said but it did not work.

I tried a clean install in a new Win 7 Sp1 Virtual Machine to eliminate the impact of any other software.

This did work and showed that the latest Update Package was 1541 :)

I retried the install on my PC using the original 'mb3-setup-consumer-', and this worked, got Update Package 1541.

I assume that the POST error had been fixed at Malwarebytes end of the link ???


Thanks for your assistance / pointer to a solution. :)

Link to post
Share on other sites


Problem not fixed !!!

I have got the same problem after 3.0.6 has been working for less than 2 days !!!

[No updates to any software etc to explain sudden stop !!!]

[The log errors are the same 'POST failure' & "Received a [-10] response from Keystone. This isn't one of the expected httpStatus returns." error.]

I have tried re-installing after performing a 'Deactivate license' & 'mb-clean' etc, it does not work ..... again.

I cannot spend anymore time on this so have rolled back to 3.0.5 which is working and updating 'Component Package' and 'Update Package' as it should.

I will wait a while for 3.0.6 to evolve to a better version !!! :)

Edited by PhoneNumberZero
Correction of Duration 3.0.6 working.!!!
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.