Jump to content

Print screen key no longer working on Surface Pro 4

Recommended Posts

I can't take a screenshot at all.

Before, i could press the PrtScn key and it would automatically save a screenshot into a folder. Now nothing at all happens

Even the old way of pressing the key and then pasting the screenshot into MS Paint doesn't work.

I also tried the snipping tool, which doesn't work either, the entire screen just turns grey when you try to take a snip.


The function key is not on, that's not the problem.

I don't notice any problems with any other keys.

I don't think anything is wrong with the key physically, since tapping it still makes the keyboard light up.

I have tried detaching the keyboard and reattaching it.

I have no reason to suspect its a malware infection, I'm guessing windows 10 changed something when it installed updates recently.


Any and all help will be appreciated, Thank you.

Edited by InterneTurtle
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.