Jump to content

Real-Time Protection help

Recommended Posts


Same issue with me. Win7 SP1 all updates applied.

When I shutdown or reboot web protection is et to off, when I click the turn on button it stays at starting literally forever(I left it like this for 5 days).

What worked for me, and it is odd, I went to services.msc (windows 10 users will have to search google or soemthing-win10 is hosed but that's another post) stopped the malwares service(which shuts down the whole application) and when it was stopped I simply clicked start again and it started fine-with web protection turned on.

hopefully this will help someone--sometime in the future( I rarely shutdown or reboot my PC-maybe once every 3-6 months) I'll try to remember to set it to automatic startup delayed - it may be conflicting with other services I have starting from boot.



Link to post
Share on other sites

I tried all of the steps in this thread: https://forums.malwarebytes.com/topic/195576-real-time-protection-layer-turning-off-try-this/

along with the following:


quit malwarebytes tray application. Stop malwarebytes service. use add/remove programs to uninstall malwarebytes. Reboot windows 7. delete malwarebytes folder from program files and %userprofile%appdata/roaming and search registry for *malwarebyte and deleting everything found. Reboot windows 7 once more. Then re-install malwarebytes fresh. update as much as it would. Everything running fine when I left this morning. All Malwarebytes functions said they were on. I did not enable early start nor did I enable the protection module. When I came home an hour ago ALL malwarebytes functions were off. Not just the web protection module. So, I uninstalled the latest version and went though all the above steps again. I attempted to install the original version I purchased (I just keep buying 5 licenses every year for the past 4 years) which as version 1.5.something or another and of course it installed fine and failed to update any definitions (1400 days old-lol)-so now I have uninstalled that version and put version 3.0.6 back on and I'm about to reboot.


Link to post
Share on other sites

Ok everything is working fine again...or at least it says it is...I don't believe it though-not after the past week. Not for a second. I'll be back here in 8 hrs or so with a report. Who knows, maybe the second time following all those steps above will be magic or something.


Link to post
Share on other sites

oh yeah..I turned off auto application updates because lets face it--malwarebytes was good for years...the economy being what it is I'm sure the penny pushers are driving the programmers hard..I won't say any more about that..but I will say that my trust in malwarebytes perfection (it has always worked perfectly in the past) has been somewhat let down and I feel a bit like I did about windows 10--don't trust it. If this isn't resolved soon I'll be foregoing the payment on my next license and simply finding something else or just trusting my firewall (corporate firewall/IDS/IPS PC) which has ad/malware/ protection all in itself-it does not HAVE the coverage of malwarebytes and it won't detect anything based on activities and it needs to download an updated malicious website list everyday but my family is extremely computer (3 programmers and me IT technician for 30 years) litterate and we kno0w what to avoid and where NOT to go..or at least where we need to tread carefully. I basically pay for malwarebytes for those nights when I am trashed outta my head drunk and click happy :-)

Link to post
Share on other sites

I really appreciate the offer Ron. However, since my system is clean and I won't be uninstalling my antivirus (Vipre) I figure this is a MB issue that has to be resolve at the application level, not the configuration level. my programmer wife and both my programmer sons agreed after I described to them the issue I am having and the troubleshooting steps I have taken. I took the time to install a clean Windows 7 SP1 VM. I installed nothing on that VM except for MB. Same issues with web protection module.


I will absolutely NOT waste days or weeks of my time troubleshooting what amounts to a beta release called "final version". I HAVE to put up with that behavior from Microsoft (until I run out of Windows 7 support anyways-then conversion to Linux will be my option), but I do not have to put up with that from any other software company out there - there are way to many other options to choose from.


So, I am about to uninstall MB from my PC and go without-wasting a few months of money on the remaining license I might add.


What I do not understand is WHY MB does not have the previous version available for download? It worked fine with my PC - I did not have ANY issues whatsoever until I upgraded to 3.0.6 a week ago. Removing v.3.0.6 and reinstalling v.3.0.5 might just fix my issue but MB has not given me that option. Instead they want me to beta test, submit issues for them to resolve and beta test some more. I do not get paid to beta test MB software.


Cheers and good luck resolving this nightmare.

Link to post
Share on other sites

5 hours ago, yodamin said:

What I do not understand is WHY MB does not have the previous version available for download?

I have tried Malwarebytes 3.0 but want to go back to MBAM 2.2.1
If for whatever reason you want to downgrade to MBAM 2.2.1 and wait for a new version of 3.0, you can do so easily. Simply uninstall Malwarebytes 3.0, reboot and then download and install MBAM 2.2.1 from here.

De Activate first.

Edited by Porthos
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.