Jump to content
MHN39

Unfortunately, MBAM Mobile has stopped

Recommended Posts

Hi!

Today, I turned on my phone and it repeatedly (2 or 3 times said "unfortunately, malwarebytes anti-malware has stopped). It was in the middle of me playing Madden Mobile. This has never happened to me before. I uninstalled MBAM Mobile, turned my phone off, turned it back on and reinstalled it. Same result, even when I wasn't playing any games. Madden Mobile is the only game on my phone is a Motorola Moto E. I've temporarily switched to ESET until the problem is resolved. I'll update this thread if the problem goes away.

Thanks,

Michael 

Share this post


Link to post
Share on other sites

I'm also experiencing the exact same problem with my Moto g4 Plus.  Just started doing this today. Tried everything you did with same results. I've had this app for several months with no issues until today.   I also have a second older Moto g with the exact same issue.   I'm puzzled at this point since the app worked so well until today.

Share this post


Link to post
Share on other sites

I'm also feeling a little better knowing we're not alone with this issue.

I'm curious, do you also have a Moto G phone as well?  

Thanks :)

 

BTW, I left a support ticket request with MBAM on this issue so I'll report back with their recommendations.

Edited by bwh

Share this post


Link to post
Share on other sites
3 minutes ago, bwh said:

I'm also feeling a little better knowing we're not alone with this issue.

I'm curious, do you also have a Moto G phone as well?  

Thanks :)

 

BTW, I left a support ticket request with MBAM on this issue so I'll report back if they have a solution.

Nope, Droid Turbo 2.

Share this post


Link to post
Share on other sites

Same here on three Android tablets...   running Android 5.1.1 (Huawey Mediapad2), 7.0 Motorola Nexus 6, and 7.1.1 (Google pixel C).

Share this post


Link to post
Share on other sites

It appears to be fixed, both mine and my fiancés phones are working properly now.

I had an idea of what was causing the issue, roughly 11PM last night both our tablets and smart phones all had Malwarebytes crashing within similar time frames, my tablet was stable enough that  the scan completed, however when I tried to update it crashed.

This morning I did a little test on my phone since it wouldn’t even run when Malwarebytes tried to open. I simply turned off my phones internet. Malwarebytes booted fine and when I tried to manually update it crashed.

However before it did it tried to download the latest database and then crashed.

In essence Malwarebytes has a useful configuration to try to update every time you turn on the app, in normal circumstances, this is fine. However there’s some key differences between the app and the PC application.

When you try to update the Pc application and the database file is corrupted or wrong, the app gives you a message like ‘failed to establish database connection.’ This is the application informing you that it failed. On a PC Malwarebytes is built to have something known as a catch parameter, think of it as an overarching umbrella for every time the app has a problem. The catch has the error message and it displays it to us.

On an android or windows phone the OS is built differently, there are two possibilities…

  1. The app tried to download a file it could not read or was corrupted and didn’t have a catch parameter to handle an unreadable file so it crashed of its own accord.
  2. The app tried to download a file it could not read or was corrupted and had an error, if smart devices have an overarching rule of ‘if there is an error, close it’ then the app is forced to shut down by the system as a precaution that the system has to take to maintain stability. In this situation there is no way for Malwarebytes to get around it since trying to build in your own catch may breach rules set down by android, apple or windows.

Why did it keep happening? As I said previously the app has a script to run, when the app launches it checks for an active internet connection, when that happens, if it finds an active internet connection it tries to update while booting, it accesses the corrupt file and is forced to close before it can boot.  

I’m just glad that it seems to be fixed, now it could be tempting to complain that MB could future proof this flaw, however, if there are rules set down by smart phone OS developers that stop apps from using catch clauses on themselves then MB can’t do anything to fix it.

Maybe someone goofed and uploaded the wrong file in the wrong place or the database got corrupted, I still see the app as a good piece of kit to have, and I’m all too aware that anti-virus apps like MB have to access a database from outside our devices, that database has to be developed, edited and/or uploaded by a human. Human error, it happens.

Share this post


Link to post
Share on other sites

Same! Helps to see it isn't just me.

Began early this morning, Pacific time.

Android 5.1.1 (Lollipop) here; it's a tablet by Fusion5, 10.6" model with a 2GB quad processor.

Did the uninstall/reinstall routine. That did not help.

I thought it might be related to having a USB storage device attached. (It was an SD card from a camera., inserted in an auxiliary card reader.) So far this morning, without the card reader and card attached to the tablet, I have been able able to get the reinstall going. It performed a full scan. All seems OK at the moment.

Share this post


Link to post
Share on other sites

When it’s an online service and it’s happening to multiple devices that each have different histories and that have no common link (use of the same USB/SD, malware, history of the same user logging in.) then it has to be server side.

Share this post


Link to post
Share on other sites

Same crashing problems on our two Nexus 5X/7.1.1 phones, after uninstalling/reinstalling/rebooting several times.

We were having these problems with the beta app, so I uninstalled again and left the beta program on both phones.  I installed the standard app on both phones and got the same crashes.

Since I did not get any reply from Support (I sent in crash reports from our phones), nor did I see any reply from Support on this forum, I figured this would be fixed on the next update.  So, I figured I'd go back to the beta.  However, I was informed, on both phones, that this was not possible as all spaces were now taken.

Share this post


Link to post
Share on other sites

Hello,

Here is a reply I received from the support team today.  The issue has now been resolved and my devices all work today:

 

We found that this issue was caused by corrupted database update. We have addressed the issue.

If you have not already uninstalled and reinstalled the Malwarebytes app on your device, please do so.

Afterwards, go to the device Settings > General tab > Apps > Malwarebytes Anti-Malware and tap the Clear Data button.

Reboot the device.

Next, launch the app and perform a manual update. Go to the setting screen and tap Settings > Other.
Tap on the Force Update option.

Share this post


Link to post
Share on other sites

I'm having 'mb has stopped' problem on lg phone android 7 & tablet android 6. Starts OK 2nd try on each.

Also mbam reports the phone as rooted. It is not per CPU z. I never Roger it.

I have started using AVG but will keep mbam as a backup on demand scanner.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.