Jump to content

Malwarebytes will not install (update)

Recommended Posts

I have been running a trial MWB I am told there us an update, so I went to website & downloaded v

However the update will not run - I just see a spinner, no progress.

This has been since at least 26 Jan - tried several times - & is annoying since the trial period is just ending.

Running windows10 32bit on an old Dell laptop D520.



Link to post
Share on other sites


Sorry, Devin, I've been unable to reply, forum meta-problem, the reply box would not accept text.

Not quite sure why, but this is a different firefox profile and it works here. I was a little concerned there might have been access-denial malware.

Thanks for responding.

At the time I still had installed, and attempts to install over it failed completely, with a hanging spinner (and no way to stop it spinning).

I contacted support - difficult to find, but it is there - who advised that I uninstall (using windodows), (my typo, but amusing), then run the Malwarebytes Clean Uninstall Tool (mbam-clean- from  xxxx link removed xxxx ), then try to install again.

Which worked.

(The clean uninstall tool did leave options & quaratine and the program directiory untouched, btw. A little odd, that.)

Apparently there are some known issues with installing 3.0.6 over 3.0.5 such as overenthusiastic adblockers and running in safe mode, but niether of these applied to my situation. And some lucky people are automatically advised to uninstal/reinstall. But not me.

The uninstall ~ clean ~ install process solved my immediate problem.



Post updated [02/12/2021 - AdvancedSetup]

The following MBST tool should be used to perform a clean removal and reinstall



Edited by AdvancedSetup
updated information
Link to post
Share on other sites

Maybe not everything, but v3.0.6 install solved, thanks.

The uninstall ~ clean ~ install process solved my immediate problem.

Also, I'm now able to use the forum from my main firefox profile; it works after deleting all malwarebytes cookies, reloading web-page & signing in again. Strange. So, that's solved as well.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.