Jump to content

Need help. Getting "unable to create directory" and Error 5:Access denied message when trying to download latest version

Recommended Posts

Have used Malwarebytes on ASUS laptop for several years with no problems.

Got the message to upgrade the other day and I did with no issues.  Today when I tried to scan it was hanging up.   Thought I would uninstall and then reinstall.  That failed in numerous attempts but  it appears that I have the previous version finally uninstalled.  

So tried to download the latest version.  I keep getting messages about "Setup unable to create directory." with additional messages such as  "Users\username\AppData\Local\Temp\is-60N3B.tmp" plus Error 5:Access Denied.   I tried repeatedly with no success and received similar messages. Never got to a point to put in my 'key.'  I even tried to restore at an earlier point in the past week.  NOTHING works.     

When I download something it goes into my "Download" file.  I am not aware of an "AppData" file.  

Can someone help?  Thanks.

Link to post
Share on other sites

Me too. I have just bought the product last Tuesday. I get " delete file failed code 5 access denied". I have sent multiple emails to tech support but just got directed here. trying to remain positive about this product. why is there not a phone line where one could get help?

Link to post
Share on other sites

Thanks.   I appreciate the suggestions.  Still cannot download -- not even the free version of 3.0.   Thought I would try that then just upgrade since I already purchased 3.0 premium.  Had a license/key for the previous version since last spring.

I appear to have gotten rid of any files, registry, etc of the previous versions.

Per my original post, I am not a techie and have a basic understanding of my computer.    When I upgraded the other day it didnt give me the "error 5" message.  And I've done upgrades for other software in the past with no issues.    Could it be that I need to save it to a different place for it to work?  Usually I put software in my downloads file and I've not had this issue before.  I had issues running windows 10 last year so I still use windows 7 and keep up-to-date on "updates."


Link to post
Share on other sites

Update.  Based on a few responses to a few similar but different posts about challenges to installation, I have succeeded in stalling the new version.

I followed the suggestions from Spam Hunters about creating diagnostic logs.  I do not know what all that indicates, but I have them.  Yesterday I finally managed to clean/uninstall/delete previous version and files associated with failed download.

Then based on on  different post, I downloaded the file from Malwarebytes received when I purchased the new version, saved it to my desktop, renamed it mbam.exe, right-clicked on it and selected "run as administator" and it WORKED!         I wish I had an explanation as to why I had to take those steps to install it (so if someone sees this and can explain it, thank you in advance!).

Thank you.

Link to post
Share on other sites

1 hour ago, Southerner_at_heart said:

A more current update:  All seems to be working HOWEVER, if I try to do  'Custom Scan' and include "Check for Rootkits" it will not allow me to select and drives.

Thoughts on this?  Thanks.

Hi Southerner :)

Do you have a laptop, computer, monitor, etc. with a touchscreen by any chance?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.