Jump to content

Malwarebytes 3.06 1469 not accepting my lifetime licence


Recommended Posts

Hi guys

Has anyone reported the following issue with Malwarebytes 3.06 1469 Premium:

I completely uninstalled Malwarebytes 3 to do a fresh install.  Rebooted.  Then I installed Malwarebytes 3.06 1469 from scratch.  When I go to activate, the serial and key fields do accept my lifetime key and serial number (which I copy and pasted rather than typed to avoid typos).  However, the "activate" button remained greyed out and unclickable.

The only way I was able to get around the issue is to find and install version 2 of Malwarebytes Antimalware. Then I installed Malwarebytes 3.06 1469 Premium over the top of that. Once I had done this Malwarebytes 3.06 1469 Premium remained activated (it took the activation status from version 2)  and now has a status of "never expires".

I notice a couple of Facebook users have reported on Malwarebyte's official Page that they too are having issues with their keys not being accepted in MBAM 3.06.

This is on a fully patched Windows 7 64bit ENT system.

As I said, I have managed to work around it....  but others may not be so lucky if they have this issue.

Link to post
Share on other sites

Thanks for your post as I know someone may need it.   I personally was very fortunate insomuch that I have 4 computers , 3 of which  have lifetime licenses.  My plan of attack was to deactivate my license on MB2,  deactivate MB exploit, then deactivate MB anti-ransomware after turning each of these off, I proceded to run the MB Cleanup program which cleans all loose ends of MB products on the system.   Then I, had already downloaded the 3.0.6.1469 in my downloads folder so I just ran that and installed,  entered my lifetime license .. into each one.. some had ID and Key others  just Key but all three worked flawlessly after doing the above.  Making sure you deactivate the license first may be the key to the issue here, don't really know but I do know what worked for me.

I am now looking for the latest update which must be coming soon to correct the program further.

Link to post
Share on other sites

@promidi did you deactivate the licence first? I have had a similar thing happen when a hdd failed and I couldn't get to MBAM to deactivate it before uninstalling and as the licence is for one computer it may think your trying to put it on two while the other is still active as that's what happened to me. The only way for me to resolve this was to contact Malwarebyte's support.

 

 

Link to post
Share on other sites

Ah that would explain it and make sense.  I definitely did not deactivate it before uninstalling...  Next time I will.  Maybe MBAM should provide an option to enable users to log on the their account on MBAM's website the deactivae their key online in the event of an HDD failure.

Link to post
Share on other sites
Quote

Maybe MBAM should provide an option to enable users to log on the their account on MBAM's website the deactivae their key online in the event of an HDD failure.

This has been suggested some time ago (like 2-3 months) and I'm also for a web interface where you can manage your licences. If I can find the thread, I'll link you to it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.