Jump to content

Unable to re-install MBAM

Recommended Posts


I am running Windows 10 on my home Dell XPS laptop after re-configuring the pc a few days ago following a disk failure. All has been running fine for a few days and I installed MBAM version 3 a couple of days ago and decided to run a scan earlier today. When I tried to open MBAM (for the first time since it was installed) I got an error message that said something like Service error unable to start Malwarebytes Antimalware. I thought I would try to resolve this by uninstalling and re-installing the software and uninstalled using 'Uninstall a Program' but when I tried to re-install I got an error message, as follows:


An error occurred while trying to replace the existing file: DeleteFile failed: code 5 Access is denied

Click Retry to try again, ignore to skip this file (not recommended) or abort to cancel the installation. ‘

So, I aborted the re-install and followed this process:

  1. Navigate to C:\Windows\system32\drivers
  2. Find mbae64.sys, right click and select rename, and change it to mbae64.old
  3. Now try to install new Malwarebytes, it will be installed without any issues

But, when I tried to rename the file in step 2 I got a message that I need administrator permission to rename this file. I was logged on to my system with my user account that has administrator rights so I am not sure what to do.

Please would somebody be able to help me resolve this so I can re-install Malwarrebytes ?

Thanks, Steve

Link to post
Share on other sites

I ran the MBAM cleanup tool from xxxx link removed xxxx  and then re-installed Malwarebytes 3.0 successfully.

After this I re-booted my pc and tried to delete mbae64.old but got a message that the file is in use ! Can anyone help with this please ?


Post updated [02/12/2021 - AdvancedSetup]

The following MBST tool should be used to perform a clean removal and reinstall



Edited by AdvancedSetup
updated information
Link to post
Share on other sites

Hi Deano :)

This looks like a known issue from what I've seen so far. Start by uninstalling Malwarebytes 3.0, and once done, follow dcollins' instructions in the post below (the FRST fix).


Once done, restart your computer and try to install Malwarebytes 3.0 again.

Link to post
Share on other sites


Hi Aura,

After I posted my original question I then posted an update to say that I ran the MBAM cleanup tool from https://downloads.malwarebytes.org/file/mbam_clean and then re-installed Malwarebytes 3.0 successfully.

After this I re-booted my pc and tried to delete mbae64.old but got a message that the file is in use. I asked if anyone could help with this but I have just tried again to delete the old file and it worked ok.

No further issues with MBAM. Thanks for your help.



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.