Jump to content

Ransomware Protection Won't Turn On


Recommended Posts

For reasons I won't go into, primarily that sometimes I am an idiot, I had to restore my desktop to factory settings last night.  This morning, I reinstalled Malwarebytes Premium v 3.0.5.  I got a message that some real time protection features were turned off.  I was able to turn on everything but Ransomware Protection.  When I tried to turn that on, it says Starting... by the button and just hangs.  It's been like that for a good 15 minutes now.  Help?

My computer is a Dell XPS 8910 and I'm running Windows 10 Home.

Thanks in advance for any help.

Link to post
Share on other sites

Hello @KristiB and :welcome:

1.)  Please help your system, and the Malwarebytes' developers/staffers, by supplying any of the missing information requested in the How to Report a New Issue topic and most importantly making sure to include the much-needed MBAMSERVICE.LOG.

2.)  Additionally, attach (do not compress/copy/paste) the separate FRST.txt and the Addition.txt output diagnostic reports from only Log Set 1.  The appropriate Farbar Recovery Scan Tool utility must be executed with "Run as administrator" privileges.

Soon after all the requested data is posted, the Malwarebytes' QA & Developer Teams, and staffers can commence their analysis.  Thank you always for your assistance.

Link to post
Share on other sites

  • 1 month later...

Hi.

The Short.

Try adding Malwarebytes to your anti viruses exclusion list.

The Long.

I was having the same issue. I tried disabling real time protection in my anti virus, Windows Defender. This allowed me to turn on ransomware protection. I reboot the computer to see if it would hold but it did not. After rebooting Malwarebytes real time protection was turned off as was Windows Defenders. I added Malwarebytes directory as well as the main program to Windows Defenders exclusion list. This seems to have fixed the problem. They are both fully functional at the moment and it holds through a reboot.

Link to post
Share on other sites

I was having the exact same problem too, and I haven't gotten around to figuring it out yet. Every morning when I turned on my PC, I'd get a notification and if I clicked "enable" it would just pop up again. And, just like the OP

> When I tried to turn that on, it says Starting... by the button and just hangs.

...if I tried to turn it on in the application settings, it would say "Starting..." forever.

But today, March 3, after the Malwarebytes update, it turned on! So there's a chance that the latest update fixed something. I have Windows Defender running with the default settings. (I usually run everything on the happy path with default settings, because thing work better that way.)

Edited by chatterbeak
Link to post
Share on other sites

  • 6 months later...
4 hours ago, martinix said:

it just hangs saying 'Starting..'

Can you try installing the latest 3.2.2.2029 over your existing product and let me know if that worked.

Just download the latest installer from : https://downloads.malwarebytes.org/file/mb3

Run the installer on top of your existing product. No need to uninstall.       

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.