Jump to content
denzele

MalwareBytes 3.0 Web Protection not working

Recommended Posts

Since updating from v2 to v3 I can't get Web Protection to work at all . It just hangs on starting and stays on forever .

Running on Win 10 Pro 64 Bit . Restarting doesn't  help . Already send an email to support team but no response so far . Hope someone can help out . 

2016-12-22_211249.png

2016-12-22_211218.png

MBAMService.rar

Share this post


Link to post
Share on other sites

Try exiting the program by right clicking on the tray icon, wait a few minutes, restart it. Is it working now?

Share this post


Link to post
Share on other sites

Same thing here on Windows7. I uninstalled the 3.04 version last night and installed the 3.9.5 version. It seemed to be ok. Then this morning after turning it on I repeatedly got a popup saying Real Time Protection Layers Turned off. I clicked Turn on multiple times no difference. I clicked on Protection Settings which brought up the settings screen.

[The settings screeen should clearly indicate in no uncertain terms which items are turned off and normally are on. As a long term MBAM user I know which ones have to be turned on however novice users may not realize that simply turning every thing on that is off on the Protection Settings screen is not the default. This is because the scan for rootkits option that by default I believe is disabled. There are other options that are also by default turned off on the protection settings page]

I slid the Web Protection to on and the pop up kept coming up repeatedly. I even tried restore defaults which did nothing. I eventually closed MBAM down and tried starting it up again. Again the popup in the systray kept coming up. Went back in and turned on Web Protection and this time it took

 

2016-12-24_095709.png

Share this post


Link to post
Share on other sites

I can confirm as for this morning mine got fixed . Another thing that I noticed and its really annoying when you want to restore quarantined item it always wants you to restart PC in order to do so . Too many things I do sometimes and I can't close everything but yet I need that file that got picked up in fist place as malware . Back in V2 you could do restoration without restarting PC . Anyone else with same problem ?  

2016-12-25_101008.png

Share this post


Link to post
Share on other sites

Having nothing but problems with MBam 3.05. One system which I stupidly thought of doing an in place upgrade only to see it fail is still having issues. This after I uninstalled the prior 3.04 version and installed 3.05 from scratch. MBam did not indicate any issues via it systray icon yet when I used the same systray icon to check for updates it showed that I am not fully protected. Malware Protections is off and can not be enabled. I can also not exit MBAM. When I tell it to quit nothing happens 

Is there any way of removing all traces of 3.x and starting from a fresh slate?

 

Share this post


Link to post
Share on other sites

I got it working but I had to reboot the entire system. Then when I closed MBAM down via the systray it did in fact close properly. However when I started it up again via its short cut it briefly flashed up a big orange warning popup saying that realtime protection was not enabled. Checking via the Dashboard showed that in fact Real Time Protection was enabled.

Share this post


Link to post
Share on other sites

I spoke too soon . Back again same problem . Seriously what a heck is going on ? Wish that I never updated in first place . Any mods out there ? Support ?

2016-12-25_115125.png

Share this post


Link to post
Share on other sites
On 12/24/2016 at 8:04 AM, denzele said:

Since updating from v2 to v3 I can't get Web Protection to work at all . It just hangs on starting and stays on forever .

Running on Win 10 Pro 64 Bit . Restarting doesn't  help . Already send an email to support team but no response so far . Hope someone can help out . 

2016-12-22_211249.png

2016-12-22_211218.png

MBAMService.rar

Hi denzele,

Two things.

  1. When you upload a log to the forum, you should switch the format to ZIP instead of RAR. I've attached a screenshot to show you where to find the setting.
  2. You haven't uploaded a log file, but the application as per the second screenshot.

To upload the MBAMSERVICE.LOG, hit Windows key + R to open the Run command and then copy/paste the following path and click OK. You'll find it there.

C:\ProgramData\Malwarebytes\MBAMService\logs

Zip_file_using_WinRAR.PNG

NO_LOG.PNG

Share this post


Link to post
Share on other sites

Same issues here, from time to time it is the web protection, others the malware protection etc...
Driving me crazy to see the exclamation mark in the icon on the task bar, and then when i open the main window with the dashboard, things look OK in there....

Disturbing and confusing, please provide a fix or a workaround asap.

 

 

2016-12-25_19-09-19.png

2016-12-25_19-10-10.png

MBAMSERVICE.zip

Share this post


Link to post
Share on other sites

Mine got fixed yet again . Not sure how . Hope it stays this way now . Sorry for rar file . If it happens again I'll upload zip file.

Anyone can tell me if restart of PC is needed now after restoring quarantined files ? That wasn't the keys in V2 .

Share this post


Link to post
Share on other sites

Well once again when I booted up one computer here, the one which I did a clean uninstall of 2.x and then installed 3.x, it again flashed up its warning that one of the protection shields was not enabled. I checked and sure enough web protection was turned off. Turning it on manually did not work, I left it sit there for a minute or two. I had to close MBAM down and then start the program up again. Then the pop up showed up but when I went in to check all the shields were enabled. The pop up was still on the screen but I just clicked on Turn On option on it to make the pop up disappear.

 

Share this post


Link to post
Share on other sites
On 25/12/2016 at 6:29 PM, Yannis said:

Same issues here, from time to time it is the web protection, others the malware protection etc...
Driving me crazy to see the exclamation mark in the icon on the task bar, and then when i open the main window with the dashboard, things look OK in there....

Disturbing and confusing, please provide a fix or a workaround asap.

 

 

2016-12-25_19-09-19.png

2016-12-25_19-10-10.png

MBAMSERVICE.zip

Happy to see I am not the only with that problem, I am starting to think what am I paying for here, and why is the program no still in beta 

Share this post


Link to post
Share on other sites

Getting fed up with 3.0.5. I brought another computer out of sleep mode. It immediately started scanning the system bringing the system to to its knees. As well Malware Protectsion, Ransomwaree and Web Protection all showed as being off. I also got an alert that the virus definitions were out of date. I had to wait for the scan to finish. Eventually all but Malware Protection got enabled. When I went to enable malware protection it showed the all too familar "Starting..." and it never activated. Yet again I had to try to shutdown MBAM but I could not. When I selected Shutdown MBAM UAC on Windows10 popped up and I clicked on it. MBam  never closed down. I had to reboot the machine!

 

Share this post


Link to post
Share on other sites

This worked for me in Win 7: First, turn off any other anti-virus programs you might be running. (In my case, MS Security Essentials)

1. Right click the MBAM systray icon.

2. Select "Quit Malwarebytes." This will cause the Windows Action Center to red-flag your anti-virus programs.

3. Click the flag (Action Center) and select "Check Anti-virus programs. This will cause a pop-up to appear listing the status of your anti-virus programs.

4. Select Malwarebytes.

5. Click "Turn On." Wait a few seconds.

The big MBAM systray pop-up telling you to turn on protection will probably still show up one more time (It did for me), but if you open MBAM BEFORE clicking "Turn On" you should see that all the layers are, in fact, on. So you can simply X out of the pop-up without clicking anything.

Both these issues (Not starting all protections, and the systray pop-up) are BUGS that I'm sure MBAM will get worked out, but it is annoying and concerning.

Note: If you don't turn off your other programs before starting this list, the Action Center won't flag the problem and you won't have access to the Windows feature in step #2. However, after you've gone through all the steps, and MBAM is fully working, you can turn your other programs back on without it changing MBAM's status. At least that was the case with MS Security Essentials. If you're running something else you'll have to see for yourself how it affects MBAM.

Good luck!

Edited by Blumuze

Share this post


Link to post
Share on other sites

I seem to have a different issue all together..

When Web Protection and Malware Protection are enabled, I cannot open any of my browsers after closing them the first time. They get stuck hanging in task manager. Once I turn off Web Protection and Malware Protection, or quit MB, the issue goes away.

Share this post


Link to post
Share on other sites
On 09/01/2017 at 9:12 AM, jkapernicus said:

I am also getting this popup. I have KIS 17 running as well. Windows 10.

Is this due to a conflict with KIS?

Thanks

Back again with same problem . Been ok for some time . i'm running KIS as well . There could be something in there between these two maybe . I'll try to stop KIS and run see what happens .

Share this post


Link to post
Share on other sites

How do you guys doing? I have the same problem exactly, windows 7, no scanning, and the live web protection Off, if I switch it to on shows starting and happens nothing. It is 18th of January, this thread started 24th of December, and still no anwer, no solution?

Share this post


Link to post
Share on other sites

I had these problems as well (Windows 7) when I installed the 3.04 version: couldn't shut down, constant nags that I wasn't protected and problems with my browser.  I wrote to Support and was sent version 3.0.5.  It didn't solve any of the problems so I wrote back.  This was the reply I received on 27 December:

"Thanks for the updated info, sorry you ran into the issues and we hope to have things sorted out very soon.

Closing ticket. have a nice day."

Not very encouraging.  I put version 2 back on.

 

 

Share this post


Link to post
Share on other sites

I just noticed the popup as soon as Kaspersky began it's Rootkit scan. That is finished but MalwareBytes web protection service will not restart.

Share this post


Link to post
Share on other sites

I have Windows 7 Pro x64 and, like many here, was getting the web protection "Off" popup on every reboot. What I found was if I terminated and restarted MBAM, the web protection module would show as active with no error. So, with that in mind, my eventual workaround was to alter the service startup type of "Malwarebytes Service" from "Automatic" to "Automatic (Delayed Start)". So far, no error messages.

With that said, there is likely a potential security issue being created due to the delay in the service's startup, so keep that in mind. 

Perhaps this will help someone else while a more proper fix is in process.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.