Jump to content

MB 3 unable to connect the service

Recommended Posts

My trial for premium was due to run out in an hour, so I selected in MB to stop the premium trial.  I then installed MBAE beta, and MBARW beta, but Malwarebytes 3 will not start.  When I click on the MB icon I get the message "unable to connect the service".  I tried a restart, didn't help.  

Checked in services and it says that  MB3 Service are set to automatic and running, but the Malwarebytes Service reports that it is set to automatic, but no sign of it running.  When I tried to start MB3 services I got a, "Error 0x80040154: c.ass not registered".  I have tried a restart of my computer, no help.   MBAE and MBARW are running, no problem there.  

I would like to have MB3 on my computer to perform occasional scans.  Should I uninstall it and reinstall?  I monitored MB3's install with RevoPro, should I delete with that?  If I do the reinstall will it delete the MBAE and MBARW, like it did on MB3's original install.  Not really a problem as I would just reinstall MBAE and MBARW.

My computer is a Windows 10/Pro 64 bit with all of MS's recent updates.

Thanks for any help! 

Link to post
Share on other sites

Hi tacua :)

This is a known issue with Malwarebytes 3.0. The given solution is to re-run the installer.

  • Occasionally, after installing, the user could see a “failure to connect to service” error, usually a reboot or rerunning the installer will correct the failure.



Link to post
Share on other sites

Thanks Aura, I had done as you suggested before, and it did not work.  I did it again, had MBARW, and MBAE installed, did the MB3 reinstall.  As soon as you install the MB3 it deletes the MBAE and the MBARW.  If I reinstall both MBAE and MBARW,  MB3 will not start.  Through trial and error I found that I can have the MBAE running with the free version of Malwarebytes 3, but MBARW causes the problem.  As soon as I have MBARW installed, MB3 won't start.

Link to post
Share on other sites

Aura, thanks for getting back to me.  I don't know if I ever had just the new version of Malwarebytes 3 running with MBARW.  It took quite a few installs to reach my conclusion that MBARW was the problem.  Every time Malwarebytes 3 doesn't start and requires a reinstall, it deletes MBAE,  and MBARW, which then requires them to be reinstalled also.  

I went back into my Services App. and notice that the MB3 file, which I could not start, is not even present now.  That particular service must have been part of the MBARW program.  The computer is running fine with the free version of Malwarebytes igetting along fine with the MBAE  If I have another problem, such as when either of these two programs update, I might do further testing as per your suggestion.  Till I have a problem or lots of free time I'll continue with this configuration I have now.

Thanks again Aura for your help.  

Link to post
Share on other sites

This is normal, installing Malwarebytes 3.0 will remove every other Malwarebytes products, since 3.0 is a "all-in-one" package.

Sadly I'm not home at the moment so I don't have access to my VMs to test, but I will probably on the 26. I'll install Malwarebytes 3.0 followed by MBARW and see if I can reproduce your issue.

Link to post
Share on other sites

Alright so I just installed Malwarebytes 3.0.5 and Malwarebytes Anti-Ransomware Beta 8 in my VM. I left Malwarebytes open for the install on MBARW, and this popped-up right after (it's from MBARW).


I'm going to take a really wild guess here: Malwarebytes Anti-Ransomware Beta installs a service called MB3Service. By the name of it, I imagine this was used as an early development service for Malwarebytes 3.0, so it's possible that there's a conflict between Malwarebytes Service and MB3Service which prevents both programs from being launched together. Here, I'll tag @pbust so he can take a look (Pedro, if you're not in charge of Anti-Ransomware Beta, could you ask someone in that team to check the thread? Thanks!).


Link to post
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Please post a large warning on the Anti-Ransomware Beta download site, that both Malwarebytes 3.0 Free and Premium conflict with Malwarebytes Anti-Ransomware Beta. 

The two together create major problems that are difficult to diagnose, and then removing and re-installing the software creates additional headaches.  All time consuming and unnecessary.

Unless I overlooked something, there is no warning.

Also, please forgive that I have contacted both Aura and dcollins via other methods about this.

Link to post
Share on other sites

2 hours ago, Telos said:

@tacua Not to take this thread in a different direction... but quite often the “failure to connect to service” error is related to F-Secure's DeepGuard protection. Any chance that's onboard your system?

No it is not.  The problem is with MB 3 free not getting along with MBARW.

Link to post
Share on other sites

Aura wrote that " Malwarebytes 3.0 Premium bundles Malwarebytes Anti-Ransomware as a protection module, ..."

Can anyone confirm this?  If so, does the built-in MARW module need to be activated or switched on somehow?  And how does this module's performance compare to the MARW Beta?

I don't remember seeing it inside MB3 Premium when I had it installed.  I can't look now because I am waiting untll MB gets back to me and assure me my machine is clean, before I reinstall MB3.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.