Jump to content

Unable to connect the service


Recommended Posts

But this service (Windows Management Instrumentation) should run anyway!

However, I had this behaviour too, here it was a conflict with F-Secure (maybe with DeepGuard). I had to exclude the Malwarebytes Folder (which should exclude that from DeepGuard too), and now it runs.

Important: Until I had resolved that problem, after I had start Malwarebytes from Tray, the program did not run correctly. Addidionally, I could not close Malwarebytes in Tray.

PS: Sorry for my "english", it's not my native language ...

Link to post
Share on other sites

15 hours ago, Alpengreis said:

However, I had this behaviour too, here it was a conflict with F-Secure (maybe with DeepGuard). I had to exclude the Malwarebytes Folder (which should exclude that from DeepGuard too), and now it runs.

1

I had to disable DeepGuard as there is no way to add new exclusions to DeepGuard.

I reported this separately to Malwarebytes and to F-Secure. I suggest you also report false positive to F-Secure so that they will update their DeepGuard database.

Link to post
Share on other sites

7 hours ago, Telos said:

I had to disable DeepGuard as there is no way to add new exclusions to DeepGuard.

I reported this separately to Malwarebytes and to F-Secure. I suggest you also report false positive to F-Secure so that they will update their DeepGuard database.

Well, I read the following article here ...

https://community.f-secure.com/t5/F-Secure-SAFE/DeepGuard-exclusion-settings/m-p/9511

... (it's for business version I know) ... nevertheless: after I excluded the path in my F-Secure Internet Security 2017 "Realtime Exclude list", it works.

And - as far as I know - this was not the first time, I could solve a problem with DeepGuard in this way.

I am also not sure if it's really a DeepGuard false positive, it could be also the case, that the ACCESS itself from DeepGuard is the problem (I even had NO usual report from DeepGuard about Malwarebytes). For example: I had a such maybe similar problem earlier with DeepGuard and EMET. However: because I am not sure about this behaviour, I will not report that to F-Secure.

Thank you.

Link to post
Share on other sites

52 minutes ago, Alpengreis said:

Well, I read the following article here ...

https://community.f-secure.com/t5/F-Secure-SAFE/DeepGuard-exclusion-settings/m-p/9511

... (it's for business version I know) ... nevertheless: after I excluded the path in my F-Secure Internet Security 2017 "Realtime Exclude list", it works.

And - as far as I know - this was not the first time, I could solve a problem with DeepGuard in this way.

I am also not sure if it's really a DeepGuard false positive, it could be also the case, that the ACCESS itself from DeepGuard is the problem (I even had NO usual report from DeepGuard about Malwarebytes). For example: I had a such maybe similar problem earlier with DeepGuard and EMET. However: because I am not sure about this behaviour, I will not report that to F-Secure.

Thank you.

3

I don't have a "Realtime Exclusion list" on my version (non-business), and there is no obvious way to add exclusions unless DeepGuard fully blocks them. I'm not sure why DeepGuard affects MBAM without popping up a notification. But I did find a way to run DeepGuard w/o conflict.

On my F-Secure installation, there is a DeepGuard option to "Use the compatibility mode (lowers security)". When I checked that, and restarted MBAM service I was able to launch MBAM without the "unable to connect the service" warning. This is better than completely disabling DeepGuard, but I'm not sure how compatibility mode works.

I guess I'll prowl around F-Secure to see what that's all about. 

Thanks for the links... they got me to dig a little deeper.

Link to post
Share on other sites

  • Staff

Thanks for all the great info here.  @Telos - Set DeepGuard back the way it was and see if delaying Malwarebytes Protection at Startup alleviates the 'unable to connect to service' message.  I would set the delay to 60 seconds to start, then extend it further if needed and see if any amount of delay resolves the issue.

Link to post
Share on other sites

45 minutes ago, Telos said:

I don't have a "Realtime Exclusion list" on my version (non-business), and there is no obvious way to add exclusions unless DeepGuard fully blocks them. I'm not sure why DeepGuard affects MBAM without popping up a notification. But I did find a way to run DeepGuard w/o conflict.

On my F-Secure installation, there is a DeepGuard option to "Use the compatibility mode (lowers security)". When I checked that, and restarted MBAM service I was able to launch MBAM without the "unable to connect the service" warning. This is better than completely disabling DeepGuard, but I'm not sure how compatibility mode works.

I guess I'll prowl around F-Secure to see what that's all about. 

Thanks for the links... they got me to dig a little deeper.

 

I have the non-business version too. I meant with "Realtime Exclusion list" the following (in german but this should be not a problem):

FSIS-Exclude1.JPGFSIS-Exclude2.JPG

I HOPE this helps you too.

Greetings.

Link to post
Share on other sites

@Alpengreis... I followed your screenshot settings, rebooted and all is well without having to drop DeepGuard into compatibility mode. Very helpful. Thank you. It's hard to find users familiar with F-Secure.

@Ried... With Alpengreis' solution, I can let MBAM start without delay. That sounds like the best outcome. Since MBAM is an alternative to AV protection, excluding it from F-Secure scans seems to have little risk.

Link to post
Share on other sites

  • 2 months later...

Not sure where this stands at the moment, but as an FYI post, I'm running Windows 10 64 bit O/S and use F-Secure which is provided free of charge by my ISP..   I have used Malwarebytes for several years with no problems.    A year or so ago I also added MB Exploit Protection and several months ago added the beta edition of MB Anti Ransomware.  I recently updated my MB software to Version 3.     Immediately I had the same problem being reported : "Malwarebytes Unable to Start - Unable to Connect the Service".  Tracked the problem to F-Secure, specifically, "Deep Guard".   Long story short :  I opened the "Deep Guard" menu under "Settings".  Found all boxes "checked" except the one called "Use the compatibility mode (lowers security)".   Checked that box as well, and closed the menu.   I realize there's a "trade off", but I suspect it's not that great.      Hopefully this will suffice until MB & F-Secure learn how to play well with each other.

I adjusted MB to delay real time protection by 60 seconds on start up.     Now everything works fine.

Ktown

 

Edited by Ktown
Link to post
Share on other sites

@Ktown While you can check "Use compatibility mode" which affects DeepGuard performance for your entire machine, I recommend instead, that you add the MBAM folder under /Program Files to F-Secure's virus scanning exclusions (as pictured above) and let DeepGuard in full measure run without "compatibility mode" checked. Your call, or course.

Link to post
Share on other sites

2 hours ago, Ktown said:
1 hour ago, Telos said:

@Ktown While you can check "Use compatibility mode" which affects DeepGuard performance for your entire machine, I recommend instead, that you add the MBAM folder under /Program Files to F-Secure's virus scanning exclusions (as pictured above) and let DeepGuard in full measure run without "compatibility mode" checked. Your call, or course.

Exactly ... *I* would not "shut down" to the DeepGuard compatibility mode to solve that problem. See my postings above (with pictures) to have a probably more senseful way ...

 

Link to post
Share on other sites

1 hour ago, Telos said:

@Ktown While you can check "Use compatibility mode" which affects DeepGuard performance for your entire machine, I recommend instead, that you add the MBAM folder under /Program Files to F-Secure's virus scanning exclusions (as pictured above) and let DeepGuard in full measure run without "compatibility mode" checked. Your call, or course.

Exactly ... *I* would not "shut down" to the DeepGuard compatibility mode to solve that problem. Ktown, See my postings above (with pictures) to have a probably more senseful way ...

Link to post
Share on other sites

I had tried numerous things to correct the issue, and I was sure I had followed Alpengreis' procedure which I was sure hadn't worked.   But I went back to the F-secure menus and tried the procedure again, and it works !       So I've now "un-checked" the "Use Compatibility Mode",   I've re-booted the computer twice to make sure there's no further issues, and MB works fine, no issues.

Thanks very much Telos & Alpengreis for the extra "push" and the help.    Much appreciated.   Have a great week end.

Link to post
Share on other sites

19 hours ago, Ktown said:

I had tried numerous things to correct the issue, and I was sure I had followed Alpengreis' procedure which I was sure hadn't worked.   But I went back to the F-secure menus and tried the procedure again, and it works !       So I've now "un-checked" the "Use Compatibility Mode",   I've re-booted the computer twice to make sure there's no further issues, and MB works fine, no issues.

Thanks very much Telos & Alpengreis for the extra "push" and the help.    Much appreciated.   Have a great week end.

Glad to hear that it works! Enjoy the weekend too :-)

Link to post
Share on other sites

I had this same issue when upgrading from MBAM 2.x to 3.0.6.

However I don't have any idea what Deepguard is.

The MalwareBytes service didn't exist in the Services list (services.msc), so I downloaded the installer manually and reinstalled it.

However it didn't preserve my license.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.