Jump to content

Compatibility with dnscrypt

Recommended Posts

Hello there @pbust

I am using malwarebytes anti malware and Dnscrypt-proxy

Here's my config:SimpleDnsCrypt_2016-12-08_08-26-45.png

When dnscrypt-proxy is turned on mbam- website blocking does not work....I turn off dnscrypt>flush dns cache>mbam ip test site>working

I have noticed that there is a proxy settings on mbam....If possible what should I enter in proxy address and port to make it work?

I tried port 53 not working

Any workarounds?(or is this the whole point of encrypting dns queries?)


Link to post
Share on other sites

Greetings :)

My apologies that no one responded to you sooner.  I just saw this post when I was looking through threads without replies and I think I might be able to help, or at least help troubleshoot.

I'm using DNSCrypt on my own system (like you, I'm currently using Simple DNSCrypt) and have been for well over a year now, and while I did have issues with Malicious Website Blocking compatibility early on during the MBAM 2.0 alpha/beta test phase, I haven't had any issues since then as I worked with the Developers directly on tracking down the cause of the issue so that they could find a solution and get it fixed, which they did before 2.0 was released.  Likewise, since it was fixed in 2.0, I also have no problems between the two now running Malwarebytes 3.0 so I'm not certain why it's causing issues with your system.

So to be clear, when DNSCrypte is enabled, if you visit iptest.malwarebytes.org in your browser you are able to reach the page and it says:

If you are able to reach this page it means that IP protection is disabled on your machine.

But if you disable DNSCrypt and flush your DNS cache, the page is blocked so that you are unable to reach that domain, is that correct?  If so, then I'd also suggest perhaps checking your HOSTS file to verify that it hasn't been altered in some way, and also perhaps try disabling the DNS Client service (it's used for DNS caching by Windows) to see if that helps or not.  The only reason I suggest disabling that service is because I myself am using a large HOSTS file (managed via HostsMan; currently containing over 500,000 entries) which requires disabling that service, so it's possible that due to the fact that I have that service disabled because of my use of a large HOSTS file, that I have not seen this problem as a result.  It shouldn't have any effect, but I'd simply like to eliminate the service as a variable since it's one difference I know likely exists between our two setups.

By the way, what version of Windows are you running this on?  I'm using Windows 7 x64 Ultimate SP1 fully patched myself.  I have not tested this setup on any other Windows versions.

Edited by exile360
Link to post
Share on other sites

Excellent, I'm glad that it worked for you :)

Now that said, I'm going to report this to the Malwarebytes 3.0 team anyway as disabling that service should not be required in order to make the two get along with each other, so hopefully they'll be able to fix the issue in a future release.

Thanks again for reporting this to us and testing my workaround :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.