Jump to content

MBAM Console Timeouts


Recommended Posts

Things I Hate About the MBAM Console

  1. Inactivity timeouts that force you to log back in on the reg.
  2. When you log back in, the console steals focus (unnecessary, it can stay in the background).
  3. When the inactivity timeout occurs, you have to click to acknowledge that there was an inactivity timeout, then wait several seconds to get the login dialogue box. Why not just popup the login dialogue instead of making us click to get the login dialogue after an inactivity timeout.
  4. After waiting to get the re-login dialogue box, it steals focus (again, unnecessary). Leave it in the background.
  5. After re-logging in, and after the console steals focus for the millionth time, the console pops up on the screen where the task bar is, instead of popping back up on the screen where it timed out (UNNECESSARY).

For the LOVE OF GOD, why do you torture us with these unnecessary features of the MBAM console???

We are security professionals, so why is it necessary to cause the console to time out in the first place? None of the complaints above would exist if it wasn't designed to timeout on us.

Your UX designers are either arrogant and sadistic, or their bosses are.

 

Link to post
Share on other sites

Hi Crimius! I can definitely see how that can be frustrating. The good news is that you can currently change the length of time before the timeout happens. Right now you have to edit a configuration file, but this will be configurable in the UI in the 1.8 release!

I'd highly recommend backing up the configuration file listed below in case of any issues.

The config file you need to edit is SC.Server.WindowsService.exe.config which can be found in the Malwarebytes Management Server install folder (the default is C:\Program Files (x86)\Malwarebytes Management Server). You're looking for the line below. The timeout is done in seconds, so you can change that number to a maximum value of 99999. Once done, you'll need to restart the Malwarebytes Management Service and re-open the Management Console for the change to take effect.

<add key="ConsoleSessionTimeoutInSeconds" value="3600" />

 

Edited by dcollins
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.