Jump to content

Opens, flash on screen, then nothing...


Recommended Posts

First off, I LOVE Malwarebytes for Mac! It's predecessor, Adwaremedic, was also amazing. I recommend this software to everyone. One of my customers is having a problem and I can't resolve it. He when he launches Malwarebytes, it flashes on the screen for a second and goes away. There is no error, it is just gone. I tried removing all the prefs and some support files I found in the System library, I trashed the App and downloaded a fresh copy of the latest version (1.2.4) but the same error happens. After I did all that I did see the popup allowing the software so it was up for more than a second but once I agreed, it just went away. 

I did check console and this is what I found:

10/17/16 4:25:56.501 PM authd[139]: server[622]: Failed to update rule com.malwarebytes.HelperTool.InstallTool
10/17/16 4:25:56.503 PM com.apple.xpc.launchd[1]: (com.malwarebytes.antimalware.234592[622]) Service exited due to signal: Abort trap: 6
10/17/16 4:25:56.502 PM diagnosticd[132]: error evaluating process info - pid: 622, puniqueid: 622
10/17/16 4:25:56.532 PM com.apple.xpc.launchd[1]: (com.apple.ReportCrash[623]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.ReportCrash
10/17/16 4:25:56.876 PM ReportCrash[623]: Saved crash report for Malwarebytes Anti-Malware[622] version 1.2.4 (1.2.4.584) to /Users/evb/Library/Logs/DiagnosticReports/Malwarebytes Anti-Malware_2016-10-17-162556_13-MacBook-Pro-Retina.crash

Got any ideas? Thank you!

DM

Link to post
Share on other sites

  • Staff

I've never seen anything like that, but I suspect that something is wrong with the helper tool, so I'd recommend deleting the helper tool.

To do that, in the Finder, choose Go to Folder from the Go menu. Then, in the window that opens, paste the following path:

/Library/LaunchDaemons

Then click the Go button.

In the folder that opens, look for an item named "com.malwarebytes.HelperTool.plist" and move that to the trash.

Next, go to this folder:

/Library/PrivilegedHelperTools

In that folder, move the file named "com.malwarebytes.HelperTool" to the trash.

Finally, restart the computer. Then try re-opening Malwarebytes Anti-Malware, and enter the user password to reinstall the helper tool.

Let me know whether that solves the problem.

Link to post
Share on other sites

Hello Thomas,

Wow, the man himself, thank you for helping me.

Unfortunately no luck however on this first try. I followed your directions to the letter. I did the reboot before attempting to make it work, I also downloaded a fresh copy of Malwarebytes. It did the exact same thing, I see the prompt for password with Malwarebytes open in the background but as soon as I authenticate, it just flashes off the screen. Here is the console log:

10/19/16 10:32:33.631 AM diagnosticd[125]: error evaluating process info - pid: 462, puniqueid: 462
10/19/16 10:32:33.661 AM com.apple.xpc.launchd[1]: (com.apple.ReportCrash[467]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.ReportCrash
10/19/16 10:32:34.318 AM ReportCrash[467]: Saved crash report for Malwarebytes Anti-Malware[462] version 1.2.4 (1.2.4.584) to /Users/evb/Library/Logs/DiagnosticReports/Malwarebytes Anti-Malware_2016-10-19-103234_13-MacBook-Pro-Retina.crash
10/19/16 10:32:34.322 AM ReportCrash[467]: Removing excessive log: file:///Users/evb/Library/Logs/DiagnosticReports/Malwarebytes%20Anti-Malware_2016-10-13-101609_13-MacBook-Pro-Retina.crash
10/19/16 10:32:41.415 AM com.apple.xpc.launchd[1]: (com.iskysoft.TunesOverWatchDemo[468]) Service could not initialize: 15G1004: xpcproxy + 12684 [1462][F7717708-ACF7-307D-B04E-998DFC36598F]: 0xd
10/19/16 10:32:41.416 AM com.apple.xpc.launchd[1]: (com.iskysoft.TunesOverWatchDemo) Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
10/19/16 10:32:51.422 AM com.apple.xpc.launchd[1]: (com.iskysoft.TunesOverWatchDemo[469]) Service could not initialize: 15G1004: xpcproxy + 12684 [1462][F7717708-ACF7-307D-B04E-998DFC36598F]: 0xd

 

If you have any thoughts I'd be happy to try them.

Again, thank you for your help and thank you for this wonderful tool!

DM

Link to post
Share on other sites

  • Staff

David,

What happens if you reboot that Mac in safe mode? Does Malwarebytes Anti-Malware for Mac run just fine in safe mode?

http://support.apple.com/kb/HT1455

You will know that you have rebooted in safe mode because it will take much longer, and the screen may redraw very slowly now and then. Also, none of the programs that will normally load at startup will be loaded.

Link to post
Share on other sites

Hello again Thomas,

Since we are doing this in safe mode, I've passed the directions onto my customer and asked them to let me know. He replied with the following:


I followed the instructions, malwarebytes cannot install the helper tool now, i can scan w/out the helper tool, no problems found, but every time i open it it wants to get password to install the helper tool and closes when i put in the password and click install.  so it seems that if it found something i would not be able actuate any activity to deal with it.  next?

I'm not sure he is right that if it did find something it couldn't resolve it. I suppose if the Safe Boot works, that would be an acceptable workaround to whatever other issues exist on this particular Mac. I don't know what the helper tool does to know if it's important. Please advise.

Thank you,

DM

Link to post
Share on other sites

  • Staff

In version 1.1 - 1.2.4, the helper tool exists primarily to help remove files that need root-level permissions to remove. It's fully capable of scanning, and can even remove some threats without the helper tool - but not all threats. Starting with version 1.2.5, which is in beta now, the helper tool will take on the responsibility for scanning as well, making it more critical to the success of the program.

Let me know whether safe mode works. If it does, that's an indicator that some third-party software was interfering with the installation of the helper tool.

If that doesn't help, since the complete manual uninstall didn't work, there's probably something more fundamental wrong with the computer, though I can't guess as to what that might be.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.