Jump to content
edkiefer

User's that had issues with MBAR and Processlasso: fix

Recommended Posts

This is just a update to the high CPU% some users were seeing when running MBAR and PL .

With newest version of MBARbeta(8, v.0.9.17.661) + Processlasso 8.9.8.48 , user should not see a difference with CPU% running both, as was reported before.

I only posted this new post cause old one was locked.

 

Ed: Bitsum QA

Share this post


Link to post
Share on other sites

Thanks Ed!

Indeed, this was an important discovery. I traced the CPU usage to a frequent OpenThread API call that (apparently) MBARW hooks at some level, and resolved it by removing the affected code and replacing it was superior code that didn't need any API calls.

Really, nobody is to blame. We had a high frequency of OpenThread calls, but it never mattered on systems where no hooks are inspecting these calls. Likewise, security software is doing it's best to keep the system safe, so has to watch everything, thus the inherit overhead. Though, as I always say, although you should not run w/o security software, there is no replacing common sense when it comes to safety!

This boosts the performance of Process Lasso with any security security software that is hooking the OpenThread API.

We've confirmed the fix, and if the prior topic was re-opened, could state such there so everyone has a final resolution. @Mods?

Attached is the final profiling image where I discovered the issue.

profiling_results_lasso_mbarw.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.